summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-07-01 18:28:02 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-07-01 18:28:02 +0000
commit2312cb37eb6280dde64c94146b1fed599285860a (patch)
treef7e0382220e079863237048739abc5892ba21041 /sci-chemistry/pdb2pqr
parentFixed some nasty, yet harmless warnings. (diff)
downloadgentoo-2-2312cb37eb6280dde64c94146b1fed599285860a.tar.gz
gentoo-2-2312cb37eb6280dde64c94146b1fed599285860a.tar.bz2
gentoo-2-2312cb37eb6280dde64c94146b1fed599285860a.zip
Replaced global appending of -fPIC to CFLAGS/FFLAGS by a local patch to Makefile.in.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'sci-chemistry/pdb2pqr')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog7
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr-1.1.2-fpic-gentoo.patch18
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild8
3 files changed, 26 insertions, 7 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 88d92922601a..3ac5ecd9c65e 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.3 2006/07/01 16:57:48 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.4 2006/07/01 18:28:02 markusle Exp $
+
+ 01 Jul 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/pdb2pqr-1.1.2-fpic-gentoo.patch, pdb2pqr-1.1.2.ebuild:
+ Replaced global appending of -fPIC to CFLAGS/FFLAGS by a local patch
+ to Makefile.in.
*pdb2pqr-1.1.2 (01 Jul 2006)
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr-1.1.2-fpic-gentoo.patch b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.1.2-fpic-gentoo.patch
new file mode 100644
index 000000000000..254041a7b586
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.1.2-fpic-gentoo.patch
@@ -0,0 +1,18 @@
+--- pdb2pqr-1.1.2/propka/Makefile.in 2006-06-23 10:16:25.000000000 -0400
++++ pdb2pqr-1.1.2-new/propka/Makefile.in 2006-07-01 14:15:29.000000000 -0400
+@@ -210,13 +210,13 @@
+ -rm -f *.tab.c
+
+ .c.o:
+- $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
++ $(COMPILE) -fPIC -c `test -f '$<' || echo '$(srcdir)/'`$<
+
+ .c.obj:
+ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'`
+
+ .f.o:
+- $(F77COMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ $(F77COMPILE) -fPIC -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
+
+ .f.obj:
+ $(F77COMPILE) -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'`
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild
index d837b876ac4c..58e376bd9a38 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild,v 1.1 2006/07/01 16:57:48 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.1.2.ebuild,v 1.2 2006/07/01 18:28:02 markusle Exp $
inherit eutils fortran multilib flag-o-matic distutils
@@ -22,11 +22,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc4-gentoo.patch
-
- # need to add -fPIC to CFLAGS and FFLAGS to avoid TEXTRELS
- # in _propkalib.so
- append-flags -fPIC
- FFLAGS="${FFLAGS} -fPIC"
+ epatch "${FILESDIR}"/${P}-fpic-gentoo.patch
}
src_compile() {