summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 16:13:55 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 16:13:55 +0000
commit5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967 (patch)
treed9e74671b0c6ead03b1e182fea3c830da2fcd2be /sci-chemistry/ortep3
parentFix build with GCC-4.5 wrt bug 321209. Thanks Diego for reporting. (diff)
downloadgentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.tar.gz
gentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.tar.bz2
gentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.zip
Fix for recent fortran compilers, #272577
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ortep3')
-rw-r--r--sci-chemistry/ortep3/ChangeLog10
-rw-r--r--sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild (renamed from sci-chemistry/ortep3/ortep3-1.0.3.ebuild)17
2 files changed, 19 insertions, 8 deletions
diff --git a/sci-chemistry/ortep3/ChangeLog b/sci-chemistry/ortep3/ChangeLog
index c6b526741635..597176e3a680 100644
--- a/sci-chemistry/ortep3/ChangeLog
+++ b/sci-chemistry/ortep3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/ortep3
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ChangeLog,v 1.6 2007/07/22 07:20:46 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ChangeLog,v 1.7 2010/06/24 16:13:55 jlec Exp $
+
+*ortep3-1.0.3-r1 (24 Jun 2010)
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> -ortep3-1.0.3.ebuild,
+ +ortep3-1.0.3-r1.ebuild:
+ Fix for recent fortran compilers, #272577
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; ortep3-1.0.3.ebuild:
Drop virtual/x11 references.
diff --git a/sci-chemistry/ortep3/ortep3-1.0.3.ebuild b/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild
index f6200a098d1d..eb3969da1086 100644
--- a/sci-chemistry/ortep3/ortep3-1.0.3.ebuild
+++ b/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild
@@ -1,20 +1,25 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ortep3-1.0.3.ebuild,v 1.2 2007/07/22 07:20:46 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild,v 1.1 2010/06/24 16:13:55 jlec Exp $
inherit fortran
-FORTRAN="g77"
+FORTRAN="gfortran ifc"
+
DESCRIPTION="Thermal ellipsoid plot program for crystal structure illustrations"
HOMEPAGE="http://www.ornl.gov/sci/ortep/"
SRC_URI="ftp://ftp.ornl.gov/pub/ortep/src/ortep.f"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND="sci-libs/pgplot
+
+RDEPEND="
+ sci-libs/pgplot
x11-libs/libX11"
DEPEND="${RDEPEND}"
+
S=${WORKDIR}
src_unpack() {
@@ -22,11 +27,11 @@ src_unpack() {
}
src_compile() {
- COMMAND="${FORTRANC} -o ortep3 ${FFLAGS:- -O2} ortep.f -lpgplot -lX11"
+ COMMAND="${FORTRANC} ${FFLAGS:- -O2} ${LDFLAGS} -o ${PN} ortep.f -lpgplot -lX11"
echo ${COMMAND}
${COMMAND} || die "Compilation failed"
}
src_install() {
- dobin ortep3
+ dobin ${PN} || die
}