summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-19 23:17:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-19 23:17:56 +0000
commit0260a9a969ae238a34f26cf5f3eb297d0402d49a (patch)
tree876d8e6cd42d2d6dfd34b55aa2b06561cab046cf /sci-chemistry/namd/namd-2.6.ebuild
parentNew MythTV eclass that downloads svn revisions and patches and merges them in... (diff)
downloadgentoo-2-0260a9a969ae238a34f26cf5f3eb297d0402d49a.tar.gz
gentoo-2-0260a9a969ae238a34f26cf5f3eb297d0402d49a.tar.bz2
gentoo-2-0260a9a969ae238a34f26cf5f3eb297d0402d49a.zip
Version bump. This fixes bug #148146.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sci-chemistry/namd/namd-2.6.ebuild')
-rw-r--r--sci-chemistry/namd/namd-2.6.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/sci-chemistry/namd/namd-2.6.ebuild b/sci-chemistry/namd/namd-2.6.ebuild
new file mode 100644
index 000000000000..8a1d259d35e8
--- /dev/null
+++ b/sci-chemistry/namd/namd-2.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/namd/namd-2.6.ebuild,v 1.1 2006/09/19 23:17:56 markusle Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A powerful and highly parallelized molecular dynamics code"
+LICENSE="namd"
+HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
+
+MY_PN="NAMD"
+MY_PV="2.6"
+
+SRC_URI="${MY_PN}_${MY_PV}_Source.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+DEPEND="|| ( app-shells/csh
+ app-shells/tcsh )
+ virtual/libc
+ =sys-cluster/charm-5.9
+ =sci-libs/fftw-2*
+ =dev-lang/tcl-8.4*"
+
+CHARM="charm-5.9"
+NAMD_ARCH="Linux-i686-g++"
+
+NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Source"
+
+pkg_nofetch() {
+ echo
+ einfo "Please download ${MY_PN}_${MY_PV}_Source.tar.gz from"
+ einfo "${NAMD_DOWNLOAD}"
+ einfo "after agreeing to the license and then move it to"
+ einfo "${DISTDIR}"
+ einfo "Be sure to select the ${MY_PV} version!"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # apply a few small fixes to make NAMD compile and
+ # link to the proper libraries
+ epatch "${FILESDIR}"/namd-2.6-gentoo.patch
+
+ cd "${S}"
+
+ # proper compiler and cflags
+ sed -e "s/g++/$(tc-getCXX)/" \
+ -e "s/CXXOPTS = -O3 -march=pentiumpro -ffast-math -static/CXXOPTS = ${CXXFLAGS}/" \
+ -e "s/gcc/$(tc-getCC)/" \
+ -e "s/COPTS = -O3 -march=pentiumpro -ffast-math -static/COPTS = ${CFLAGS}/" \
+ -i arch/${NAMD_ARCH}.arch || \
+ die "Failed to setup ${NAMD_ARCH}.arch"
+
+ # configure
+ ./config tcl fftw ${NAMD_ARCH}
+}
+
+src_compile() {
+ # build namd
+ cd "${S}/${NAMD_ARCH}"
+ emake || die "Failed to build namd"
+}
+
+src_install() {
+ cd "${S}/${NAMD_ARCH}"
+
+ # the binaries
+ dobin ${PN}2 psfgen flipbinpdb flipdcd || \
+ die "Failed to install binaries"
+
+ cd "${S}"
+
+ # some docs
+ dodoc announce.txt license.txt notes.txt || \
+ die "Failed to install docs"
+}
+
+pkg_postinst() {
+ echo
+ einfo "For detailed instructions on how to run and configure"
+ einfo "NAMD please consults the extensive documentation at"
+ einfo "http://www.ks.uiuc.edu/Research/namd/"
+ einfo "and the NAMD tutorials available at"
+ einfo "http://www.ks.uiuc.edu/Training/Tutorials/"
+ einfo "Have fun :)"
+ echo
+}