summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-04-26 13:03:47 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-04-26 13:03:47 +0000
commitf25778990629c008a016fda71f0116e53b89210e (patch)
tree68cfd9d869ae095d759d3ee78ca1263a45839465 /sci-chemistry/chemtool
parentSwitch to slot deps and use java-pkg_doexamples. (diff)
downloadgentoo-2-f25778990629c008a016fda71f0116e53b89210e.tar.gz
gentoo-2-f25778990629c008a016fda71f0116e53b89210e.tar.bz2
gentoo-2-f25778990629c008a016fda71f0116e53b89210e.zip
Version bump and explicitly depend on kdelibs-3.5* (fixes bug #219221).
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/ChangeLog9
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.10.ebuild4
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.11.ebuild65
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild4
-rw-r--r--sci-chemistry/chemtool/files/chemtool-1.6.11-makefile.patch12
5 files changed, 89 insertions, 5 deletions
diff --git a/sci-chemistry/chemtool/ChangeLog b/sci-chemistry/chemtool/ChangeLog
index 7ea68be2905c..3d8add5d21e5 100644
--- a/sci-chemistry/chemtool/ChangeLog
+++ b/sci-chemistry/chemtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/chemtool
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.23 2008/04/22 13:54:33 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.24 2008/04/26 13:03:47 markusle Exp $
+
+*chemtool-1.6.11 (26 Apr 2008)
+
+ 26 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+ chemtool-1.6.9-r1.ebuild, chemtool-1.6.10.ebuild,
+ +files/chemtool-1.6.11-makefile.patch, +chemtool-1.6.11.ebuild:
+ Version bump and explicitly depend on kdelibs-3.5* (fixes bug #219221).
22 Apr 2008; Jeff Gardner <je_fro@gentoo.org> chemtool-1.6.9-r1.ebuild:
Fix typo
diff --git a/sci-chemistry/chemtool/chemtool-1.6.10.ebuild b/sci-chemistry/chemtool/chemtool-1.6.10.ebuild
index ab31fc0f3153..6e725b747a07 100644
--- a/sci-chemistry/chemtool/chemtool-1.6.10.ebuild
+++ b/sci-chemistry/chemtool/chemtool-1.6.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.10.ebuild,v 1.3 2008/04/21 01:40:11 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.10.ebuild,v 1.4 2008/04/26 13:03:47 markusle Exp $
inherit eutils kde-functions
@@ -15,7 +15,7 @@ IUSE="gnome kde nls"
RDEPEND="media-gfx/transfig
=x11-libs/gtk+-2*
- kde? ( kde-base/kdelibs )
+ kde? ( =kde-base/kdelibs-3.5* )
x86? ( media-libs/libemf )"
DEPEND="${RDEPEND}
diff --git a/sci-chemistry/chemtool/chemtool-1.6.11.ebuild b/sci-chemistry/chemtool/chemtool-1.6.11.ebuild
new file mode 100644
index 000000000000..32cfcd3f1533
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.11.ebuild,v 1.1 2008/04/26 13:03:47 markusle Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="gnome kde nls"
+
+RDEPEND="media-gfx/transfig
+ =x11-libs/gtk+-2*
+ kde? ( =kde-base/kdelibs-3.5* )
+ x86? ( media-libs/libemf )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ local config_opts
+ local mycppflags
+ if ! use kde; then
+ unset KDEDIR
+ config_opts="${config_opts} --without-kdedir"
+ else
+ set-kdedir
+ config_opts="${config_opts} --with-kdedir=${KDEDIR}"
+ fi
+ if [ ${ARCH} = "x86" ]; then
+ config_opts="${config_opts} --enable-emf"
+ mycppflags="${mycppflags} -I /usr/include/libEMF"
+ fi
+
+ sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+ die "could not append cppflags"
+
+ if use gnome ; then
+ config_opts="${config_opts} --with-gnomedir=/usr" ;
+ else
+ config_opts="${config_opts} --without-gnomedir" ;
+ fi
+
+ econf ${config_opts} --enable-menu \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL README TODO
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/*
+ if ! use nls; then rm -rf "${D}"/usr/share/locale; fi
+}
diff --git a/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild b/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild
index f3dd2d19e17f..25e2cbbe2e51 100644
--- a/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild
+++ b/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild,v 1.7 2008/04/22 13:54:33 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.9-r1.ebuild,v 1.8 2008/04/26 13:03:47 markusle Exp $
inherit eutils kde-functions
@@ -15,7 +15,7 @@ IUSE="gnome kde nls"
RDEPEND=">=media-gfx/transfig-3.2.3d
=x11-libs/gtk+-2*
- kde? ( kde-base/kdelibs )
+ kde? ( =kde-base/kdelibs-3.5* )
x86? ( >=media-libs/libemf-1.0 )"
DEPEND="${RDEPEND}
diff --git a/sci-chemistry/chemtool/files/chemtool-1.6.11-makefile.patch b/sci-chemistry/chemtool/files/chemtool-1.6.11-makefile.patch
new file mode 100644
index 000000000000..f359578dce0b
--- /dev/null
+++ b/sci-chemistry/chemtool/files/chemtool-1.6.11-makefile.patch
@@ -0,0 +1,12 @@
+diff -Naur chemtool-1.6.11/Makefile.in chemtool-1.6.11.new/Makefile.in
+--- chemtool-1.6.11/Makefile.in 2007-08-26 07:53:59.000000000 -0400
++++ chemtool-1.6.11.new/Makefile.in 2008-04-26 08:52:33.000000000 -0400
+@@ -230,7 +230,7 @@
+ AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@
+
+ # Link time dependencies.
+-LDADD = @LIBINTL@ @GTK_LIBS@
++LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@
+
+ # Additional files to be distributed.
+ EXTRA_DIST = autogen.sh autoclean.sh