summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-23 15:18:32 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-23 15:18:32 +0000
commitb3c5f08ff4bc966637693a639495694c8be96e1e (patch)
tree16c8ebb7437601cf4611e9d418fc0b0bcfeb4883 /sci-chemistry/chemtool
parentStable on amd64 wrt bug #368281 (diff)
downloadgentoo-2-b3c5f08ff4bc966637693a639495694c8be96e1e.tar.gz
gentoo-2-b3c5f08ff4bc966637693a639495694c8be96e1e.tar.bz2
gentoo-2-b3c5f08ff4bc966637693a639495694c8be96e1e.zip
Fix underlinking, #367849
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/ChangeLog9
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.12-r1.ebuild56
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.12.ebuild11
-rw-r--r--sci-chemistry/chemtool/files/1.6.12-no-underlinking.patch50
-rw-r--r--sci-chemistry/chemtool/metadata.xml1
5 files changed, 120 insertions, 7 deletions
diff --git a/sci-chemistry/chemtool/ChangeLog b/sci-chemistry/chemtool/ChangeLog
index bd475bfc7670..5542ae4a9241 100644
--- a/sci-chemistry/chemtool/ChangeLog
+++ b/sci-chemistry/chemtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/chemtool
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.30 2011/03/02 13:12:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.31 2011/05/23 15:18:31 jlec Exp $
+
+*chemtool-1.6.12-r1 (23 May 2011)
+
+ 23 May 2011; Justin Lecher <jlec@gentoo.org>
+ +files/1.6.12-no-underlinking.patch, chemtool-1.6.12.ebuild,
+ +chemtool-1.6.12-r1.ebuild, metadata.xml:
+ Fix underlinking, #367849
02 Mar 2011; Justin Lecher <jlec@gentoo.org> chemtool-1.6.12.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-chemistry/chemtool/chemtool-1.6.12-r1.ebuild b/sci-chemistry/chemtool/chemtool-1.6.12-r1.ebuild
new file mode 100644
index 000000000000..d4e4e835c64c
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.12-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.12-r1.ebuild,v 1.1 2011/05/23 15:18:31 jlec Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="emf gnome nls"
+
+RDEPEND="
+ media-gfx/transfig
+ x11-libs/gtk+:2
+ emf? ( media-libs/libemf )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-no-underlinking.patch
+ eautoreconf
+}
+
+src_configure() {
+ local mycppflags
+
+ if use emf; then
+ mycppflags="${mycppflags} -I /usr/include/libEMF"
+ fi
+
+ sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+ die "could not append cppflags"
+
+ econf \
+ --without-kdedir \
+ $(use_with gnome gnomedir /usr) \
+ $(use_enable emf) \
+ --enable-menu
+}
+
+src_install() {
+ default
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/*
+ if ! use nls; then rm -rf "${ED}"/usr/share/locale; fi
+
+ insinto /usr/share/pixmaps
+ doins chemtool.xpm
+ make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
+}
diff --git a/sci-chemistry/chemtool/chemtool-1.6.12.ebuild b/sci-chemistry/chemtool/chemtool-1.6.12.ebuild
index eaba7fd14181..6093bf8c8d6e 100644
--- a/sci-chemistry/chemtool/chemtool-1.6.12.ebuild
+++ b/sci-chemistry/chemtool/chemtool-1.6.12.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.12.ebuild,v 1.5 2011/03/02 13:12:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.12.ebuild,v 1.6 2011/05/23 15:18:32 jlec Exp $
-EAPI="1"
+EAPI=1
inherit eutils
-DESCRIPTION="A GTK program for drawing organic molecules"
+DESCRIPTION="GTK program for drawing organic molecules"
HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
@@ -43,13 +43,12 @@ src_compile() {
config_opts="${config_opts} --without-gnomedir" ;
fi
- econf ${config_opts} --enable-menu \
- || die "./configure failed"
+ econf ${config_opts} --enable-menu
emake || die "make failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog INSTALL README TODO
insinto /usr/share/${PN}/examples
doins "${S}"/examples/*
diff --git a/sci-chemistry/chemtool/files/1.6.12-no-underlinking.patch b/sci-chemistry/chemtool/files/1.6.12-no-underlinking.patch
new file mode 100644
index 000000000000..acb505108ed2
--- /dev/null
+++ b/sci-chemistry/chemtool/files/1.6.12-no-underlinking.patch
@@ -0,0 +1,50 @@
+ Makefile.am | 4 +++-
+ configure.ac | 20 +-------------------
+ 2 files changed, 4 insertions(+), 20 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 59f9547..dafffaf 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -25,7 +25,9 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+ AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@
+
+ # Link time dependencies.
+-LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@
++LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@ -lX11
++
++AM_CFLAGS = -DGTK2
+
+ # Additional files to be distributed.
+ EXTRA_DIST = autogen.sh autoclean.sh
+diff --git a/configure.ac b/configure.ac
+index 29e3344..6fd754f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,25 +34,7 @@ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+ AC_MSG_CHECKING([for GTK version and compile options ])
+
+-if test x$PKG_CONFIG = xno -o x$enable_gtk1 = xyes ; then
+-AM_PATH_GTK(1.0.2, , exit 1)
+-else
+-if $PKG_CONFIG gtk+-2.0 --cflags ; then
+- GTK_CFLAGS="-DGTK2 `$PKG_CONFIG gtk+-2.0 --cflags` "
+- GTK_LIBS=`$PKG_CONFIG gtk+-2.0 --libs`
+-dnl use_gtk2=yes
+- AC_DEFINE([GTK2], [1], [the GTK2 library])
+- enable_stockgtk=yes
+-else
+-if $PKG_CONFIG --cflags gtk+ ; then
+- GTK_CFLAGS=`$PKG_CONFIG gtk+ --cflags`
+- GTK_LIBS=`$PKG_CONFIG gtk+ --libs`
+-dnl use_gtk2=no
+-fi
+-fi
+-fi
+-
+-dnl AC_MSG_RESULT using GTK2 : $use_gtk2
++PKG_CHECK_MODULES([GTK],[gtk+-2.0])
+
+ dnl Checks for header files.
+ AC_PATH_X
diff --git a/sci-chemistry/chemtool/metadata.xml b/sci-chemistry/chemtool/metadata.xml
index 9ac9ffdb3a41..446f133a9389 100644
--- a/sci-chemistry/chemtool/metadata.xml
+++ b/sci-chemistry/chemtool/metadata.xml
@@ -2,4 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
+ <use><flag name='emf'>EMF export support</flag></use>
</pkgmetadata>