summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-14 06:12:45 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-14 06:12:45 +0000
commitab13d1b7a2b1fa0ee48990a3d73ff4ef4bb7f77a (patch)
tree6924acdec41bae6717b2caf776db5c5cbf3d52bb /sci-chemistry/caver
parentslang is a global flag, remove it for app-mobilephone/yaps (diff)
downloadgentoo-2-ab13d1b7a2b1fa0ee48990a3d73ff4ef4bb7f77a.tar.gz
gentoo-2-ab13d1b7a2b1fa0ee48990a3d73ff4ef4bb7f77a.tar.bz2
gentoo-2-ab13d1b7a2b1fa0ee48990a3d73ff4ef4bb7f77a.zip
Bump. This version does a much better job of finding stuff, and the pymol plugin's a lot more capable.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-chemistry/caver')
-rw-r--r--sci-chemistry/caver/ChangeLog10
-rw-r--r--sci-chemistry/caver/caver-0.99.2.ebuild50
-rw-r--r--sci-chemistry/caver/files/digest-caver-0.99.26
3 files changed, 64 insertions, 2 deletions
diff --git a/sci-chemistry/caver/ChangeLog b/sci-chemistry/caver/ChangeLog
index 1cd00b2ff2dd..ac3376e5cbd3 100644
--- a/sci-chemistry/caver/ChangeLog
+++ b/sci-chemistry/caver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/caver
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.1 2005/12/20 03:56:38 spyderous Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.2 2006/05/14 06:12:45 spyderous Exp $
+
+*caver-0.99.2 (14 May 2006)
+
+ 14 May 2006; Donnie Berkholz <spyderous@gentoo.org>; +caver-0.99.2.ebuild:
+ Bump. This version does a much better job of finding stuff, and the pymol
+ plugin's a lot more capable.
*caver-0.99.1 (20 Dec 2005)
diff --git a/sci-chemistry/caver/caver-0.99.2.ebuild b/sci-chemistry/caver/caver-0.99.2.ebuild
new file mode 100644
index 000000000000..7d6ea5374318
--- /dev/null
+++ b/sci-chemistry/caver/caver-0.99.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-0.99.2.ebuild,v 1.1 2006/05/14 06:12:45 spyderous Exp $
+
+inherit multilib python
+
+MY_PN="${PN}_unix"
+MY_P="${MY_PN}_v${PV}"
+PLUG_P="${MY_P/caver/caverPLUG}"
+DESCRIPTION="Rapid, accurate and fully automated calculation of pathways leading from buried cavities to outside solvent in static and dynamic protein structures"
+HOMEPAGE="http://viper.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.tar.gz
+ pymol? ( ${PLUG_P}.tar.gz )"
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="pymol"
+RDEPEND="media-libs/qhull
+ pymol? ( sci-chemistry/pymol )"
+DEPEND="${RDEPEND}"
+RESTRICT="fetch"
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ einfo "Download ${MY_P}.tar.gz"
+ if use pymol; then
+ einfo "and ${PLUG_P}.tar.gz"
+ fi
+ einfo "from ${HOMEPAGE}. This requires registration."
+ einfo "Place tarballs in ${DISTDIR}."
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ if use pymol; then
+ python_version
+ sed -i \
+ -e "s:^\(CAVER_BINARY_LOCATION\).*:\1 = \"${ROOT}usr/bin/caver\":g" \
+ ${WORKDIR}/${PLUG_P}/caver.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/pmg_tk/startup
+ doins ${WORKDIR}/${PLUG_P}/caver.py
+ fi
+}
+
+pkg_postinst() {
+ if use pymol; then
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/pmg_tk/startup/caver.py
+ fi
+}
diff --git a/sci-chemistry/caver/files/digest-caver-0.99.2 b/sci-chemistry/caver/files/digest-caver-0.99.2
new file mode 100644
index 000000000000..d8d6005ce856
--- /dev/null
+++ b/sci-chemistry/caver/files/digest-caver-0.99.2
@@ -0,0 +1,6 @@
+MD5 e498466fa232d17fb483cc4568576d2b caverPLUG_unix_v0.99.2.tar.gz 81270
+RMD160 58a5b2b7a1efe41a86d507831f754419ae912b12 caverPLUG_unix_v0.99.2.tar.gz 81270
+SHA256 5b7ca30f26023e2ed9eda6a5430ca5db0ebef7b34f7f8d2391a49182ec0663b1 caverPLUG_unix_v0.99.2.tar.gz 81270
+MD5 b258994fab2957ab20eac77d7a74c276 caver_unix_v0.99.2.tar.gz 1152263
+RMD160 01b877bef15d0f0e1ccce8a3dbcda83826ba76c5 caver_unix_v0.99.2.tar.gz 1152263
+SHA256 9934b5e80f375159132c5327df1fa8bd19ce90682c04c4cd9b91e62476e0f98b caver_unix_v0.99.2.tar.gz 1152263