summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-12 10:29:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-12 10:29:36 +0000
commit2c67309e5ca8788d6264e4a249d16009a520c94d (patch)
tree6e2e22cb404076627b84b8c84f1a185487c21978 /sci-chemistry/balbes
parentFix error in sqlite USE flag; cleanup old versions. (diff)
downloadgentoo-2-2c67309e5ca8788d6264e4a249d16009a520c94d.tar.gz
gentoo-2-2c67309e5ca8788d6264e4a249d16009a520c94d.tar.bz2
gentoo-2-2c67309e5ca8788d6264e4a249d16009a520c94d.zip
Buildsystem fix, #319347
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/balbes')
-rw-r--r--sci-chemistry/balbes/ChangeLog9
-rw-r--r--sci-chemistry/balbes/balbes-1.0.0_p100317-r1.ebuild (renamed from sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild)16
-rw-r--r--sci-chemistry/balbes/files/1.0.0_p100317-makefile.patch (renamed from sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch)20
3 files changed, 30 insertions, 15 deletions
diff --git a/sci-chemistry/balbes/ChangeLog b/sci-chemistry/balbes/ChangeLog
index 0ec1bf5aaccb..92a402a02452 100644
--- a/sci-chemistry/balbes/ChangeLog
+++ b/sci-chemistry/balbes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/balbes
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/ChangeLog,v 1.3 2010/04/22 19:53:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/ChangeLog,v 1.4 2010/05/12 10:29:35 jlec Exp $
+
+*balbes-1.0.0_p100317-r1 (12 May 2010)
+
+ 12 May 2010; Justin Lecher <jlec@gentoo.org>
+ -files/1.0.0_p100317-ldflags.patch, -balbes-1.0.0_p100317.ebuild,
+ +files/1.0.0_p100317-makefile.patch, +balbes-1.0.0_p100317-r1.ebuild:
+ Buildsystem fix, #319347
22 Apr 2010; Justin Lecher <jlec@gentoo.org> balbes-1.0.0_p100317.ebuild:
Fixes for Python ABIs
diff --git a/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild b/sci-chemistry/balbes/balbes-1.0.0_p100317-r1.ebuild
index a12f835f00af..4fac8c89ae70 100644
--- a/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild
+++ b/sci-chemistry/balbes/balbes-1.0.0_p100317-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild,v 1.3 2010/04/22 19:53:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/balbes-1.0.0_p100317-r1.ebuild,v 1.1 2010/05/12 10:29:36 jlec Exp $
EAPI="3"
@@ -32,6 +32,7 @@ S="${WORKDIR}"/src
pkg_setup() {
python_set_active_version 2
+ fortran_pkg_setup
}
src_unpack() {
@@ -42,21 +43,12 @@ src_unpack() {
src_prepare() {
mkdir "${WORKDIR}"/bin || die
- epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch "${FILESDIR}"/${PV}-makefile.patch
}
src_compile() {
- # incomplete targets:
- # dimer_search_db domain_search_db domain align3
- targets="search_db get_structure_db manage_db search_dm dom2ch
- save_si get_pdb_list_db update_db
- update_dom_db bl2mtz check_file_db fobs2cif sol_check
- get_trns p2s check_cell alt_sg
- align cell_list create_bins
- get_pdb_list_db get_ch get_nm get_mod"
emake \
- BLANC_FORT="${FORTRANC} ${FFLAGS}" \
- ${targets} || die
+ BLANC_FORT="${FORTRANC} ${FFLAGS}" || die
}
src_install() {
diff --git a/sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch b/sci-chemistry/balbes/files/1.0.0_p100317-makefile.patch
index e1d09b7f3c33..da17240642d7 100644
--- a/sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch
+++ b/sci-chemistry/balbes/files/1.0.0_p100317-makefile.patch
@@ -1,8 +1,24 @@
diff --git a/makefile b/makefile
-index baaceb5..139037e 100755
+index baaceb5..85a7baf 100755
--- a/makefile
+++ b/makefile
-@@ -201,58 +201,58 @@ save_seg_id.o: save_seg_id.f
+@@ -70,6 +70,15 @@ OBJDB_G = get_pdb_list.o
+
+ #OBJDB_Z = blanc2mtz.o libutils.o
+
++# incomplete targets:
++# dimer_search_db domain_search_db domain align3
++all: search_db get_structure_db manage_db search_dm dom2ch \
++ save_si get_pdb_list_db update_db \
++ update_dom_db bl2mtz check_file_db fobs2cif sol_check \
++ get_trns p2s check_cell alt_sg \
++ align cell_list create_bins \
++ get_pdb_list_db get_ch get_nm get_mod
++
+ search_db: sdb_l
+
+ get_structure_db: tdb_l
+@@ -201,58 +210,58 @@ save_seg_id.o: save_seg_id.f
$(BLANC_FORT) -c save_seg_id.f
sdb_l: $(OBJDB_S)