summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-25 09:24:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-25 09:24:23 +0000
commit371ebd98b8935f0e1b6c5f899592ed7c9c69e7e4 (patch)
tree9929c896effdc5a845d7b477cba131e15fcfaca4 /sci-chemistry/apbs
parentVersion bump to ruby-gnome 0.19.4. (diff)
downloadgentoo-2-371ebd98b8935f0e1b6c5f899592ed7c9c69e7e4.tar.gz
gentoo-2-371ebd98b8935f0e1b6c5f899592ed7c9c69e7e4.tar.bz2
gentoo-2-371ebd98b8935f0e1b6c5f899592ed7c9c69e7e4.zip
Python ABI fixes, #316165
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog5
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 0b754f552631..82bb974cf77d 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.27 2010/03/30 07:02:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.28 2010/04/25 09:24:23 jlec Exp $
+
+ 25 Apr 2010; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r2.ebuild:
+ Python ABI fixes, #316165
30 Mar 2010; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r2.ebuild,
metadata.xml:
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild
index 53d63e6bc302..3fa543dbde54 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild,v 1.2 2010/03/30 07:02:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r2.ebuild,v 1.3 2010/04/25 09:24:23 jlec Exp $
EAPI="3"
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="python? 2"
FORTRAN="g77 gfortran ifc"
inherit autotools eutils flag-o-matic fortran python versionator
@@ -24,7 +24,6 @@ KEYWORDS="~x86 ~amd64 ~ppc ~amd64-linux ~x86-linux"
DEPEND="
dev-libs/maloc[mpi=]
blas? ( virtual/blas )
- python? ( dev-lang/python )
sys-libs/readline
arpack? ( sci-libs/arpack )
mpi? ( virtual/mpi )"
@@ -32,6 +31,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-openmp.patch
epatch "${FILESDIR}"/${P}-install-fix.patch
@@ -126,9 +129,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize /usr/$(python_get_sitedir)/${PN}
+ python_mod_optimize ${EPREFIX}/usr/$(python_get_sitedir)/${PN}
}
pkg_postrm() {
- python_mod_cleanup /usr/$(python_get_sitedir)/${PN}
+ python_mod_cleanup ${EPREFIX}/usr/$(python_get_sitedir)/${PN}
}