summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-01 17:25:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-01 17:25:23 +0000
commit2dd190958babd5713eb91fcebf065d5e26fc6b52 (patch)
tree7d5ff44d33b31014e0baf3c68876b6f329e5e4a6 /sci-chemistry/apbs
parentMark stable for ppc64; bug #341755 (diff)
downloadgentoo-2-2dd190958babd5713eb91fcebf065d5e26fc6b52.tar.gz
gentoo-2-2dd190958babd5713eb91fcebf065d5e26fc6b52.tar.bz2
gentoo-2-2dd190958babd5713eb91fcebf065d5e26fc6b52.zip
Include support for FETK
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog7
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild33
-rw-r--r--sci-chemistry/apbs/files/apbs-1.3-mainroutines.patch12
-rw-r--r--sci-chemistry/apbs/files/apbs-1.3-shared.patch8
-rw-r--r--sci-chemistry/apbs/metadata.xml1
5 files changed, 52 insertions, 9 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 0f2562e57856..410f44e06637 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.42 2010/10/31 09:43:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.43 2010/11/01 17:25:22 jlec Exp $
+
+ 01 Nov 2010; Justin Lecher <jlec@gentoo.org> apbs-1.3.ebuild,
+ +files/apbs-1.3-mainroutines.patch, files/apbs-1.3-shared.patch,
+ metadata.xml:
+ Include support for FETK
31 Oct 2010; Justin Lecher <jlec@gentoo.org> apbs-1.3.ebuild:
Make einfo on parallel python and mpi support
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index 761c8d910bfe..803d60cdc66f 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.2 2010/10/31 09:43:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.3 2010/11/01 17:25:22 jlec Exp $
EAPI="3"
@@ -18,13 +18,22 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
SLOT="0"
LICENSE="BSD"
-IUSE="arpack doc mpi openmp python tools"
+IUSE="arpack doc fetk mpi openmp python tools"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-DEPEND="dev-libs/maloc[mpi=]
+DEPEND="
+ dev-libs/maloc[mpi=]
virtual/blas
sys-libs/readline
arpack? ( sci-libs/arpack )
+ fetk? (
+ media-libs/sg
+ sci-libs/amd
+ sci-libs/punc
+ sci-libs/mc
+ sci-libs/gamer
+ sci-libs/umfpack
+ sci-libs/superlu )
mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
@@ -37,6 +46,12 @@ pkg_setup() {
einfo "mpi and python support are incompatible"
einfo "Disabling USE=python"
fi
+ if [[ -z ${MAXMEM} ]]; then
+ einfo "You can specify the max amount of RAM used"
+ einfo "by setting MAXMEM=\"your size in MB\""
+ else
+ einfo "Settings max memory usage to ${MAXMEM} MB"
+ fi
}
src_prepare() {
@@ -48,11 +63,13 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.2.1b-autoconf-2.64.patch \
"${FILESDIR}"/${P}-shared.patch \
"${FILESDIR}"/${PN}-1.2.1b-multilib.patch \
- "${FILESDIR}"/${PN}-1.2.1b-parallelbuild.patch
+ "${FILESDIR}"/${PN}-1.2.1b-parallelbuild.patch \
+ "${FILESDIR}"/${P}-mainroutines.patch
sed "s:GENTOO_PKG_NAME:${PN}:g" \
-i Makefile.am || die "Cannot correct package name"
# this test is broken
sed '/ion-pmf/d' -i examples/Makefile.am || die
+ sed 's:libmaloc.a:libmaloc.so:g' -i configure.ac || die
eautoreconf
find . -name "._*" -exec rm -f '{}' \;
}
@@ -80,6 +97,14 @@ src_configure() {
myconf="${myconf} --enable-tools"
fi
+ if use fetk; then
+ myconf="${myconf} --with-fetk-include=${EPREFIX}/usr/include --with-fetk-library=${EPREFIX}/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --disable-fetk"
+ fi
+
+ [[ -n ${MAXMEM} ]] && myconf="${myconf} --with-maxmem=${MAXMEM}"
+
econf \
--disable-maloc-rebuild \
--enable-shared \
diff --git a/sci-chemistry/apbs/files/apbs-1.3-mainroutines.patch b/sci-chemistry/apbs/files/apbs-1.3-mainroutines.patch
new file mode 100644
index 000000000000..fa8678a971fd
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.3-mainroutines.patch
@@ -0,0 +1,12 @@
+diff --git a/bin/Makefile.am b/bin/Makefile.am
+index 15158ca..f73d276 100644
+--- a/bin/Makefile.am
++++ b/bin/Makefile.am
+@@ -29,6 +29,7 @@ rm.apbs: Makefile
+
+ lib_LTLIBRARIES = libapbsmainroutines.la
+ libapbsmainroutines_la_SOURCES = routines.c
++libapbsmainroutines_la_LIBADD = -L../src/aaa_lib/.libs/ -lapbs @mc_lib@
+ libapbsmainroutines_la_LDFLAGS = -version-info ${APBS_VERSION}
+
+ INCLUDES = @inc_list@
diff --git a/sci-chemistry/apbs/files/apbs-1.3-shared.patch b/sci-chemistry/apbs/files/apbs-1.3-shared.patch
index 1a237b066345..f7eb4dfc1d1f 100644
--- a/sci-chemistry/apbs/files/apbs-1.3-shared.patch
+++ b/sci-chemistry/apbs/files/apbs-1.3-shared.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile.am b/Makefile.am
-index b400095..9e6d698 100644
+index b400095..af3a3a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,9 @@ SUFFIXES = .H .h .C .cc .c .f .o
@@ -81,16 +81,16 @@ index 73fbe21..31a0053 100644
AC_OUTPUT
diff --git a/src/aaa_lib/Makefile.am b/src/aaa_lib/Makefile.am
-index 2c5026b..d8d0650 100644
+index 0064aaa..8b33f70 100644
--- a/src/aaa_lib/Makefile.am
+++ b/src/aaa_lib/Makefile.am
-@@ -22,7 +22,8 @@ libdir = ${prefix}/lib
+@@ -21,7 +21,8 @@ BLAS_LIBS = @blas_lib@
lib_LTLIBRARIES = libapbs.la
libapbs_la_SOURCES = apbs_link.c
-libapbs_la_LIBADD = ${GEN_LIBS} ${FEM_LIBS} ${MG_LIBS} ${PMGZ_LIBS} ${AQUA_LIBS} ${BLAS_LIBS}
+libapbs_la_LIBADD = ${GEN_LIBS} ${FEM_LIBS} ${MG_LIBS} ${PMGZ_LIBS} ${AQUA_LIBS} ${BLAS_LIBS} \
-+ @OPENMP_LIBS@ @maloc_lib@
++ @OPENMP_LIBS@ @maloc_lib@ @mc_lib@
libapbs_la_LDFLAGS = -version-info ${APBS_VERSION}
INCLUDES = -I${top_srcdir}/src/generic -I${top_srcdir}/src/mg -I${top_srcdir}/src/fem @inc_list@
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
index ae94882003a0..8a1c32e03b3d 100644
--- a/sci-chemistry/apbs/metadata.xml
+++ b/sci-chemistry/apbs/metadata.xml
@@ -13,6 +13,7 @@
</maintainer>
<use>
<flag name='arpack'>Include support for arpack libs</flag>
+ <flag name='fetk'>Include support for FeTK</flag>
<flag name='tools'>Install optional tools</flag>
</use>
<longdescription>