summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-11-12 18:45:24 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-11-12 18:45:24 +0000
commite4b3f0b0559fb90c7cb00faebaa607390b274ce7 (patch)
tree0a56dd4ebaf89a41ad7da357b3dcfdf14f126779 /sci-biology
parentDropped vulnerable version, thank Alex Legler for request. (diff)
downloadgentoo-2-e4b3f0b0559fb90c7cb00faebaa607390b274ce7.tar.gz
gentoo-2-e4b3f0b0559fb90c7cb00faebaa607390b274ce7.tar.bz2
gentoo-2-e4b3f0b0559fb90c7cb00faebaa607390b274ce7.zip
Add patch for bug 279087
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/vaal/ChangeLog6
-rw-r--r--sci-biology/vaal/files/vaal-1.2-gcc-x86-no-autocast.patch39
-rw-r--r--sci-biology/vaal/vaal-1.2.ebuild8
3 files changed, 51 insertions, 2 deletions
diff --git a/sci-biology/vaal/ChangeLog b/sci-biology/vaal/ChangeLog
index 26188892693a..349ee153ecc3 100644
--- a/sci-biology/vaal/ChangeLog
+++ b/sci-biology/vaal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/vaal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.1 2009/07/08 03:52:35 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.2 2009/11/12 18:45:22 weaver Exp $
+
+ 12 Nov 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/vaal-1.2-gcc-x86-no-autocast.patch, vaal-1.2.ebuild:
+ Add patch for bug 279087
*vaal-1.2 (07 Jul 2009)
diff --git a/sci-biology/vaal/files/vaal-1.2-gcc-x86-no-autocast.patch b/sci-biology/vaal/files/vaal-1.2-gcc-x86-no-autocast.patch
new file mode 100644
index 000000000000..c021fadb44b1
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-gcc-x86-no-autocast.patch
@@ -0,0 +1,39 @@
+diff -durr VAAL.orig/SortKmersImpl.h VAAL/SortKmersImpl.h
+--- VAAL.orig/SortKmersImpl.h 2009-11-12 13:02:40.116993289 +0000
++++ VAAL/SortKmersImpl.h 2009-11-12 13:04:59.416388534 +0000
+@@ -98,7 +98,7 @@
+ { if ( reads[l].size( ) < KSPAN ) continue;
+ unsigned int N = reads[l].size( ) - KSPAN + 1;
+ if ( S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<1>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
+@@ -180,7 +180,7 @@
+ }
+ if ( q == N ) break;
+ if ( S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
+@@ -207,7 +207,7 @@
+ top += Min( N - top, (unsigned int) 10000 );
+
+ if ( S + 20000 >= R.size( ) || S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
+@@ -318,7 +318,7 @@
+
+ top += Min( N - top, 10000 );
+ if ( S + 2*(top - q) >= R.size( ) ) {
+- unsigned nn = Max( (unsigned) ( 1.2 * R.size( ) ), (S + 2*(top - q)) );
++ unsigned nn = Max( (unsigned) ( 1.2 * R.size( ) ), (unsigned) (S + 2*(top - q)) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<100>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
diff --git a/sci-biology/vaal/vaal-1.2.ebuild b/sci-biology/vaal/vaal-1.2.ebuild
index 7dc50a0c6ba9..b1331c1f320e 100644
--- a/sci-biology/vaal/vaal-1.2.ebuild
+++ b/sci-biology/vaal/vaal-1.2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-1.2.ebuild,v 1.1 2009/07/08 03:52:35 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-1.2.ebuild,v 1.2 2009/11/12 18:45:22 weaver Exp $
EAPI="2"
+inherit base
+
DESCRIPTION="A variant ascertainment algorithm that can be used to detect SNPs, indels, and other polymorphisms"
HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
SRC_URI="ftp://ftp.broad.mit.edu/pub/crd/VAAL/VAAL.1.2.tgz
@@ -17,6 +19,10 @@ KEYWORDS="~amd64 ~x86"
DEPEND=">=dev-libs/boost-1.37.0"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-x86-no-autocast.patch
+)
+
S="${WORKDIR}/VAAL"
src_install() {