summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-19 21:41:54 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-19 21:41:54 +0000
commite0434484a9100db779a63ccc2f2e346035e7b287 (patch)
tree6d1b5efd8a0a076b2e41e04d75fd3021ef35399e /sci-biology
parentDo not apply upstream patch that is already applied. (diff)
downloadgentoo-2-e0434484a9100db779a63ccc2f2e346035e7b287.tar.gz
gentoo-2-e0434484a9100db779a63ccc2f2e346035e7b287.tar.bz2
gentoo-2-e0434484a9100db779a63ccc2f2e346035e7b287.zip
Version bumps, remove old, and add test stage
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bioruby/ChangeLog9
-rw-r--r--sci-biology/bioruby/bioruby-1.3.1.ebuild (renamed from sci-biology/bioruby/bioruby-1.0.0.ebuild)21
-rw-r--r--sci-biology/bioruby/bioruby-9999.ebuild30
3 files changed, 55 insertions, 5 deletions
diff --git a/sci-biology/bioruby/ChangeLog b/sci-biology/bioruby/ChangeLog
index 420e0d6dcf81..54476f459add 100644
--- a/sci-biology/bioruby/ChangeLog
+++ b/sci-biology/bioruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/bioruby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.10 2009/03/24 20:53:41 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.11 2009/09/19 21:41:54 weaver Exp $
+
+*bioruby-9999 (19 Sep 2009)
+*bioruby-1.3.1 (19 Sep 2009)
+
+ 19 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> -bioruby-1.0.0.ebuild,
+ +bioruby-1.3.1.ebuild, +bioruby-9999.ebuild:
+ Version bumps, remove old, and add test stage
24 Mar 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-biology/bioruby/bioruby-1.0.0.ebuild b/sci-biology/bioruby/bioruby-1.3.1.ebuild
index 4f1fc128865b..e48b2543b24a 100644
--- a/sci-biology/bioruby/bioruby-1.0.0.ebuild
+++ b/sci-biology/bioruby/bioruby-1.3.1.ebuild
@@ -1,14 +1,27 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.0.0.ebuild,v 1.2 2006/11/02 02:48:11 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.3.1.ebuild,v 1.1 2009/09/19 21:41:54 weaver Exp $
+
+EAPI="2"
inherit ruby
DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
-LICENSE="GPL-2"
+LICENSE="Ruby"
HOMEPAGE="http://www.bioruby.org/"
SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
SLOT="0"
IUSE=""
-KEYWORDS="~ppc x86"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+USE_RUBY="ruby18"
+
+src_install() {
+ ${RUBY} setup.rb install --prefix="${D}"
+}
+
+src_test() {
+ # NB: Some tests fail but don't raise an error.
+ ${RUBY} setup.rb test || die
+}
diff --git a/sci-biology/bioruby/bioruby-9999.ebuild b/sci-biology/bioruby/bioruby-9999.ebuild
new file mode 100644
index 000000000000..7b2901a24b56
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-9999.ebuild,v 1.1 2009/09/19 21:41:54 weaver Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://github.com/bioruby/bioruby.git"
+
+inherit ruby git
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+#SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
+SRC_URI=""
+
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+USE_RUBY="ruby18"
+
+src_install() {
+ ${RUBY} setup.rb install --prefix="${D}"
+}
+
+src_test() {
+ # NB: Some tests fail but don't raise an error.
+ ${RUBY} setup.rb test || die
+}