summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:36:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:36:17 +0000
commit7531052d60193ae114cc65ee45d76bfaacfbedf7 (patch)
tree70854c27706ac60a6ef4cc7093e88891c1f59725 /sci-biology
parentRespect LDFLAGS wrt bug 336546. Thanks to Diego for the report. Fix implicit ... (diff)
downloadgentoo-2-7531052d60193ae114cc65ee45d76bfaacfbedf7.tar.gz
gentoo-2-7531052d60193ae114cc65ee45d76bfaacfbedf7.tar.bz2
gentoo-2-7531052d60193ae114cc65ee45d76bfaacfbedf7.zip
Respect LDFLAGS wrt bug 336533. Thanks to Diego for the report. Fix implicit function declarations.
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/dialign-tx/ChangeLog9
-rw-r--r--sci-biology/dialign-tx/dialign-tx-1.0.2-r1.ebuild44
-rw-r--r--sci-biology/dialign-tx/files/dialign-tx-1.0.2-implicits.patch18
3 files changed, 70 insertions, 1 deletions
diff --git a/sci-biology/dialign-tx/ChangeLog b/sci-biology/dialign-tx/ChangeLog
index cb8d1df0bba9..7cc5b6fc2eef 100644
--- a/sci-biology/dialign-tx/ChangeLog
+++ b/sci-biology/dialign-tx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/dialign-tx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/dialign-tx/ChangeLog,v 1.3 2010/02/09 11:20:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/dialign-tx/ChangeLog,v 1.4 2010/09/09 09:36:17 xarthisius Exp $
+
+*dialign-tx-1.0.2-r1 (09 Sep 2010)
+
+ 09 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +dialign-tx-1.0.2-r1.ebuild, +files/dialign-tx-1.0.2-implicits.patch:
+ Respect LDFLAGS wrt bug 336533. Thanks to Diego for the report. Fix
+ implicit function declarations.
09 Feb 2010; Pacho Ramos <pacho@gentoo.org> dialign-tx-1.0.2.ebuild:
amd64 stable, bug 298774
diff --git a/sci-biology/dialign-tx/dialign-tx-1.0.2-r1.ebuild b/sci-biology/dialign-tx/dialign-tx-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..bcc252eb42f7
--- /dev/null
+++ b/sci-biology/dialign-tx/dialign-tx-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/dialign-tx/dialign-tx-1.0.2-r1.ebuild,v 1.1 2010/09/09 09:36:17 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+MY_P=DIALIGN-TX_${PV}
+
+DESCRIPTION="Greedy and progressive approaches for segment-based multiple sequence alignment"
+HOMEPAGE="http://dialign-tx.gobics.de/"
+SRC_URI="http://dialign-tx.gobics.de/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s/\$(CC) -o/\$(CC) \$(LDFLAGS) -o/" \
+ -i source/Makefile || die #336533
+ epatch "${FILESDIR}"/${P}-implicits.patch
+}
+
+src_compile() {
+ emake -C source clean
+ emake -C source CC="$(tc-getCC)" \
+ CPPFLAGS="" || die "make failed"
+}
+
+src_install() {
+ DESTTREE="/usr" dobin "${S}"/source/dialign-tx
+ insinto /usr/$(get_libdir)/${PN}/conf
+ doins "${S}"/conf/*
+}
+
+pkg_postinst() {
+ einfo "The configuration directory is"
+ einfo "${ROOT}usr/$(get_libdir)/${PN}/conf"
+ einfo "You will need to pass this to ${PN} on every run."
+}
diff --git a/sci-biology/dialign-tx/files/dialign-tx-1.0.2-implicits.patch b/sci-biology/dialign-tx/files/dialign-tx-1.0.2-implicits.patch
new file mode 100644
index 000000000000..a8388d03232f
--- /dev/null
+++ b/sci-biology/dialign-tx/files/dialign-tx-1.0.2-implicits.patch
@@ -0,0 +1,18 @@
+--- source/museq.c
++++ source/museq.c
+@@ -38,6 +38,7 @@
+ //extern void calc_weight(struct diag* dg, struct scr_matrix* smatrix,
+ // struct prob_dist *pdist);
+ //extern struct diag_col *create_diag_col(int seq_amount);
++extern void free_diag(struct diag* dg);
+ extern void free_diag_col(struct diag_col* dcol);
+ extern struct diag_col *find_all_diags(struct scr_matrix *smatrix,
+ struct prob_dist *pdist,
+@@ -52,6 +53,7 @@
+
+ // alig.c
+ extern struct alignment* create_empty_alignment(struct seq_col *scol);
++extern void free_alignment(struct alignment *algn);
+ //extern char adapt_diag(struct alignment *algn, struct scr_matrix *smatrix, struct diag* dg);
+ extern int simple_aligner(struct seq_col *scol, struct diag_col *dcol,
+ struct scr_matrix* smatrix,