summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-28 07:50:08 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-28 07:50:08 +0000
commit63e7adb2bba6efcd330ebf5bb63c97ac8b54126e (patch)
tree66e9c2109aab9dfcdc3bf0bb07f59a421481cf17 /sci-biology
parentnetsurf eclass preparation. (diff)
downloadgentoo-2-63e7adb2bba6efcd330ebf5bb63c97ac8b54126e.tar.gz
gentoo-2-63e7adb2bba6efcd330ebf5bb63c97ac8b54126e.tar.bz2
gentoo-2-63e7adb2bba6efcd330ebf5bb63c97ac8b54126e.zip
sci-biology/rebase: Version Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/rebase/ChangeLog10
-rw-r--r--sci-biology/rebase/metadata.xml4
-rw-r--r--sci-biology/rebase/rebase-1303.ebuild46
3 files changed, 56 insertions, 4 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 32f2200f4bf2..33a7616f0221 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/rebase
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.114 2012/03/08 07:15:15 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.115 2013/02/28 07:50:07 jlec Exp $
+
+*rebase-1303 (28 Feb 2013)
+
+ 28 Feb 2013; Justin Lecher <jlec@gentoo.org> +rebase-1303.ebuild,
+ metadata.xml:
+ Version Bump
08 Mar 2012; Justin Lecher <jlec@gentoo.org> -rebase-1006.ebuild,
-rebase-1105.ebuild:
diff --git a/sci-biology/rebase/metadata.xml b/sci-biology/rebase/metadata.xml
index 752a98d2dc33..734fcff7e215 100644
--- a/sci-biology/rebase/metadata.xml
+++ b/sci-biology/rebase/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-biology</herd>
- <longdescription>
+ <herd>sci-biology</herd>
+ <longdescription>
The Restriction Enzyme data BASE is a collection of information about
restriction enzymes and related proteins. It is maintained by New
England Biolabs. It contains published and unpublished references,
diff --git a/sci-biology/rebase/rebase-1303.ebuild b/sci-biology/rebase/rebase-1303.ebuild
new file mode 100644
index 000000000000..87e0294ef32a
--- /dev/null
+++ b/sci-biology/rebase/rebase-1303.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1303.ebuild,v 1.1 2013/02/28 07:50:08 jlec Exp $
+
+EAPI=5
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="emboss minimal"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup}
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ
+ fi
+}