summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-19 23:54:54 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-19 23:54:54 +0000
commit5f224b328bd29396143ca65419d9eeeaf3c3821d (patch)
tree55b67187871fe5d184e5c8b5e0f8180afed6810d /sci-biology
parentStable on alpha wrt security bug #109097 (diff)
downloadgentoo-2-5f224b328bd29396143ca65419d9eeeaf3c3821d.tar.gz
gentoo-2-5f224b328bd29396143ca65419d9eeeaf3c3821d.tar.bz2
gentoo-2-5f224b328bd29396143ca65419d9eeeaf3c3821d.zip
New version
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/t-coffee/ChangeLog7
-rw-r--r--sci-biology/t-coffee/Manifest2
-rw-r--r--sci-biology/t-coffee/files/digest-t-coffee-3.181
-rw-r--r--sci-biology/t-coffee/t-coffee-3.18.ebuild49
4 files changed, 58 insertions, 1 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index 2fb79eeb2e5c..d77312913a26 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.8 2005/10/17 17:47:06 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.9 2005/10/19 23:54:54 ribosome Exp $
+
+*t-coffee-3.18 (19 Oct 2005)
+
+ 19 Oct 2005; Olivier Fisette <ribosome@gentoo.org> +t-coffee-3.18.ebuild:
+ New version.
17 Oct 2005; Olivier Fisette <ribosome@gentoo.org> -t-coffee-2.50.ebuild:
Pruning old version.
diff --git a/sci-biology/t-coffee/Manifest b/sci-biology/t-coffee/Manifest
index 156831a0700a..a504abc1d25d 100644
--- a/sci-biology/t-coffee/Manifest
+++ b/sci-biology/t-coffee/Manifest
@@ -1,4 +1,6 @@
MD5 6fb318682c83d5a0f5d956f5272a66c6 t-coffee-2.66.ebuild 1142
+MD5 1b3cfe698f44aa57293497f6c09c7dc5 t-coffee-3.18.ebuild 1476
MD5 f5115567e411d3524b23f98a8c0e1acd ChangeLog 1421
MD5 0bbfd32ca9864625c55ab6460dbbd963 metadata.xml 755
MD5 ed78ff61d489ff54debcffde53dca64e files/digest-t-coffee-2.66 87
+MD5 1b980450cd09068868ab6fc2868cd19e files/digest-t-coffee-3.18 87
diff --git a/sci-biology/t-coffee/files/digest-t-coffee-3.18 b/sci-biology/t-coffee/files/digest-t-coffee-3.18
new file mode 100644
index 000000000000..18345cb2e017
--- /dev/null
+++ b/sci-biology/t-coffee/files/digest-t-coffee-3.18
@@ -0,0 +1 @@
+MD5 e671383b9e6b90ded56c615acd2f51c4 T-COFFEE_distribution_Version_3.18.tar.gz 1540558
diff --git a/sci-biology/t-coffee/t-coffee-3.18.ebuild b/sci-biology/t-coffee/t-coffee-3.18.ebuild
new file mode 100644
index 000000000000..c3abe7f0a6b0
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-3.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-3.18.ebuild,v 1.1 2005/10/19 23:54:54 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="t-coffee"
+HOMEPAGE="http://igs-server.cnrs-mrs.fr/~cnotred/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://igs-server.cnrs-mrs.fr/~cnotred/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+RESTRICT="nomirror"
+
+DEPEND="sci-biology/clustalw"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC) ${CFLAGS}/" -i makefile || die \
+ "Failed to patch makefile."
+}
+
+src_compile() {
+ make all || die "Compilation failed."
+}
+
+src_install() {
+ cd "${TCDIR}"/bin
+ dobin t_coffee || die "Failed to install program."
+ insinto /usr/share/${PN}/lib/html
+ doins ${TCDIR}/html/* || die "Failed to install HTML documentation,"
+
+ dodoc ${TCDIR}/doc/README4T-COFFEE || die \
+ "Failed to install basic documentation."
+ insinto /usr/share/doc/${PF}
+ doins ${TCDIR}/doc/t_coffee{_doc.{doc,pdf},.pdf} || die \
+ "Failed to install manuals and articles."
+ doins ${TCDIR}/doc/*.txt || die "Failed to install documentation."
+
+ insinto /usr/share/${PN}/example
+ doins ${TCDIR}/example/* || die "Failed to install example files."
+}