summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-26 06:22:16 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-26 06:22:16 +0000
commit56a3c453fff695f899bf3fb49ce0bed8f96678e4 (patch)
treef70312766ace7f0b0b8c3ff845fd64a9a37284d5 /sci-biology
parentBump (diff)
downloadgentoo-2-56a3c453fff695f899bf3fb49ce0bed8f96678e4.tar.gz
gentoo-2-56a3c453fff695f899bf3fb49ce0bed8f96678e4.tar.bz2
gentoo-2-56a3c453fff695f899bf3fb49ce0bed8f96678e4.zip
Version Bump and patch for file collision, thanks Martin Mokrejs for the fix, bug #247394; Respect CXX, CXXFLAGS and LDFLAGS
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/glimmer/ChangeLog15
-rw-r--r--sci-biology/glimmer/files/glimmer-3.02b-jobserver-fix.patch22
-rw-r--r--sci-biology/glimmer/files/glimmer-3.02b-ldflags.patch88
-rw-r--r--sci-biology/glimmer/files/glimmer-3.02b-rename_extract.patch196
-rw-r--r--sci-biology/glimmer/glimmer-3.02-r3.ebuild (renamed from sci-biology/glimmer/glimmer-3.02-r1.ebuild)41
-rw-r--r--sci-biology/glimmer/glimmer-3.02b.ebuild68
6 files changed, 412 insertions, 18 deletions
diff --git a/sci-biology/glimmer/ChangeLog b/sci-biology/glimmer/ChangeLog
index c3d61e9970ae..9dc6606b7d70 100644
--- a/sci-biology/glimmer/ChangeLog
+++ b/sci-biology/glimmer/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-biology/glimmer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/glimmer/ChangeLog,v 1.10 2013/03/11 15:17:43 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/glimmer/ChangeLog,v 1.11 2015/05/26 06:22:16 jlec Exp $
+
+*glimmer-3.02b (26 May 2015)
+*glimmer-3.02-r3 (26 May 2015)
+
+ 26 May 2015; Justin Lecher <jlec@gentoo.org>
+ +files/glimmer-3.02b-jobserver-fix.patch, +files/glimmer-3.02b-ldflags.patch,
+ +files/glimmer-3.02b-rename_extract.patch, +glimmer-3.02-r3.ebuild,
+ +glimmer-3.02b.ebuild, -glimmer-3.02-r1.ebuild:
+ Version Bump and patch for file collision, thanks Martin Mokrejs for the fix,
+ bug #247394; Respect CXX, CXXFLAGS and LDFLAGS
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
@@ -44,4 +54,3 @@
07 Sep 2008; weaver <weaver@gentoo.org> +metadata.xml,
+glimmer-3.02.ebuild:
Import from science overlay
-
diff --git a/sci-biology/glimmer/files/glimmer-3.02b-jobserver-fix.patch b/sci-biology/glimmer/files/glimmer-3.02b-jobserver-fix.patch
new file mode 100644
index 000000000000..91498b116d12
--- /dev/null
+++ b/sci-biology/glimmer/files/glimmer-3.02b-jobserver-fix.patch
@@ -0,0 +1,22 @@
+diff -ru glimmer3.02-orig/src/Makefile glimmer3.02/src/Makefile
+--- glimmer3.02-orig/src/Makefile 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/src/Makefile 2010-03-18 14:30:15.000000000 +0100
+@@ -2,12 +2,12 @@
+
+
+ all:
+- @ TGT=objs
+- @ $(dosubdirs)
+- @ TGT=libs
+- @ $(dosubdirs)
+- @ TGT=progs
+- @ $(dosubdirs)
++ @+ TGT=objs
++ @+ $(dosubdirs)
++ @+ TGT=libs
++ @+ $(dosubdirs)
++ @+ TGT=progs
++ @+ $(dosubdirs)
+
+
+ install: all
diff --git a/sci-biology/glimmer/files/glimmer-3.02b-ldflags.patch b/sci-biology/glimmer/files/glimmer-3.02b-ldflags.patch
new file mode 100644
index 000000000000..0a04fbef1dcc
--- /dev/null
+++ b/sci-biology/glimmer/files/glimmer-3.02b-ldflags.patch
@@ -0,0 +1,88 @@
+diff --git a/src/c_make.gen b/src/c_make.gen
+index 414dead..84c3030 100644
+--- a/src/c_make.gen
++++ b/src/c_make.gen
+@@ -200,45 +200,12 @@ LOCAL_SYS_INC=$(SEP_PATH)/../SYS/inc
+ #### Do not redefine if (a) passed in on command line, or (b)
+ #### defined in an environment variable.
+
+-ifneq "$(origin CC)" "environment"
+-CC = cc
+-endif
+-
+-ifneq "$(origin CPPFLAGS)" "environment"
+-CPPFLAGS=
+-endif
+-
+-ifneq "$(origin CFLAGS)" "environment"
+-CFLAGS =
+-endif
+-
+-ifneq "$(origin CDEFS)" "environment"
+-CDEFS =
+-endif
+-
+-ifneq "$(origin CXX)" "environment"
+-CXX = g++
+-endif
+-
+-ifneq "$(origin CXXFLAGS)" "environment"
+-CXXFLAGS=
+-endif
+-
+-ifneq "$(origin CXXDEFS)" "environment"
+-CXXDEFS= -D__cplusplus
+-endif
+-
+-ifneq "$(origin AR)" "environment"
+-AR = ar
+-endif
+-
+-ifneq "$(origin ARFLAGS)" "environment"
+-ARFLAGS = rvs
+-endif
+-
+-ifneq "$(origin LDFLAGS)" "environment"
+-LDFLAGS =
+-endif
++CC ?= cc
++CXX ?= g++
++CXXFLAGS ?=
++CXXDEFS = -D__cplusplus
++AR ?= ar
++ARFLAGS ?= rvs
+
+ #### Delete default suffix rules
+ .SUFFIXES:
+@@ -359,13 +326,13 @@ $(PROGS):
+ cd $(LOCAL_OBJ); \
+ if $(CC) -o $(LOCAL_BIN)/$(notdir $@) $(LDFLAGS) \
+ $(LD_DIRS) $(filter-out lib%.a, $+) \
+- $(patsubst lib%.a, -l%, $(filter lib%.a, $+)) ; then \
++ $(patsubst lib%.a, -l%, $(filter lib%.a, $+)) $(LIBS) ; then \
+ true; else rm -f $(LOCAL_BIN)/$(notdir $@); fi; \
+ else \
+ cd $(LOCAL_OBJ); \
+ if $(CXX) -o $(LOCAL_BIN)/$(notdir $@) $(LDFLAGS) \
+ $(LD_DIRS) $(filter-out lib%.a, $+) \
+- $(patsubst lib%.a, -l%, $(filter lib%.a, $+)) ; then \
++ $(patsubst lib%.a, -l%, $(filter lib%.a, $+)) $(LIBS) ; then \
+ true; else rm -f $(LOCAL_BIN)/$(notdir $@); fi; \
+ fi ;
+
+diff --git a/src/c_make.glm b/src/c_make.glm
+index 0decc17..b82131c 100644
+--- a/src/c_make.glm
++++ b/src/c_make.glm
+@@ -8,10 +8,7 @@ include $(LOCAL_WORK)/src/c_make.gen
+
+ SUBDIRS = Common ICM Glimmer Util
+
+-CFLAGS = -g -Wall
+-CXXFLAGS = -g -Wall
+-
+-LDFLAGS = -g -lm
++LIBS = -lm
+
+
+ #AS_BUILD_DIR =$(LOCAL_WORK)
diff --git a/sci-biology/glimmer/files/glimmer-3.02b-rename_extract.patch b/sci-biology/glimmer/files/glimmer-3.02b-rename_extract.patch
new file mode 100644
index 000000000000..6eebc5610414
--- /dev/null
+++ b/sci-biology/glimmer/files/glimmer-3.02b-rename_extract.patch
@@ -0,0 +1,196 @@
+diff -r -u glimmer3.02.old/docs/notes.tex glimmer3.02/docs/notes.tex
+--- glimmer3.02.old/docs/notes.tex 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/docs/notes.tex 2015-05-25 22:41:39.450340098 +0200
+@@ -306,7 +306,7 @@
+ The script would then run the commands:
+ \BSV\begin{verbatim}
+ long-orfs -n -t 1.15 genom.seq run1.longorfs
+- extract -t genom.seq run1.longorfs > run1.train
++ glimmer_extract -t genom.seq run1.longorfs > run1.train
+ build-icm -r run1.icm < run1.train
+ glimmer3 -o50 -g110 -t30 genom.seq run1.icm run1
+ \end{verbatim}\ESV
+@@ -330,9 +330,9 @@
+ \end{verbatim}\ESV
+ The script would then run the commands:
+ \BSV\begin{verbatim}
+- extract -t genom.seq train.coords > run2.train
++ glimmer_extract -t genom.seq train.coords > run2.train
+ build-icm -r run2.icm < run2.train
+- upstream-coords.awk 25 0 train.coords | extract genom.seq - > run2.upstream
++ upstream-coords.awk 25 0 train.coords | glimmer_extract genom.seq - > run2.upstream
+ elph run2.upstream LEN=6 | get-motif-counts.awk > run2.motif
+ set startuse = `start-codon-distrib -3 genom.seq train.coords`
+ glimmer3 -o50 -g110 -t30 -b run2.motif -P $startuse genom.seq run2.icm run2
+@@ -358,11 +358,11 @@
+ The script would then run the commands:
+ \BSV\begin{verbatim}
+ long-orfs -n -t 1.15 genom.seq run3.longorfs
+- extract -t genom.seq run3.longorfs > run3.train
++ glimmer_extract -t genom.seq run3.longorfs > run3.train
+ build-icm -r run3.icm < run3.train
+ glimmer3 -o50 -g110 -t30 genom.seq run3.icm run3.run1
+ tail +2 run3.run1.predict > run3.coords
+- upstream-coords.awk 25 0 run3.coords | extract genom.seq - > run3.upstream
++ upstream-coords.awk 25 0 run3.coords | glimmer_extract genom.seq - > run3.upstream
+ elph run3.upstream LEN=6 | get-motif-counts.awk > run3.motif
+ set startuse = `start-codon-distrib -3 genom.seq run3.coords`
+ glimmer3 -o50 -g110 -t30 -b run3.motif -P $startuse genom.seq run3.icm run3
+@@ -1081,12 +1081,12 @@
+ \Pg{entropy-score}\, [\Desc{options}] \Desc{sequence} \Desc{coords}
+ \eq
+
+-\subsubsection{\Pg{extract} Program}
++\subsubsection{\Pg{glimmer_extract} Program}
+ This program reads a genome sequence and a list of coordinates
+ for it and outputs a multi-fasta file of the regions specified
+ by the coordinates. Output goes to standard output.
+ \bq
+- \Pg{extract}\, [\Desc{options}] \Desc{sequence} \Desc{coords}
++ \Pg{glimmer_extract}\, [\Desc{options}] \Desc{sequence} \Desc{coords}
+ \eq
+
+ \subsubsection{\Pg{multi-extract} Program}
+diff -r -u glimmer3.02.old/sample-run/g3-from-scratch.csh glimmer3.02/sample-run/g3-from-scratch.csh
+--- glimmer3.02.old/sample-run/g3-from-scratch.csh 2006-06-12 21:46:35.000000000 +0200
++++ glimmer3.02/sample-run/g3-from-scratch.csh 2015-05-25 22:40:18.450338748 +0200
+@@ -50,7 +50,7 @@
+ step2:
+ # Extract the training sequences from the genome file
+ echo "Step 2 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $tag.longorfs > $tag.train
++$glimmerpath/glimmer_extract -t $genome $tag.longorfs > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+diff -r -u glimmer3.02.old/sample-run/g3-from-training.csh glimmer3.02/sample-run/g3-from-training.csh
+--- glimmer3.02.old/sample-run/g3-from-training.csh 2006-06-12 21:46:35.000000000 +0200
++++ glimmer3.02/sample-run/g3-from-training.csh 2015-05-25 22:40:18.450338748 +0200
+@@ -42,7 +42,7 @@
+ step1:
+ # Extract the training sequences from the genome file
+ echo "Step 1 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $coords > $tag.train
++$glimmerpath/glimmer_extract -t $genome $coords > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+@@ -66,7 +66,7 @@
+ # upstream of the start locations in $coords
+ echo "Step 3 of ${numsteps}: Making PWM from upstream regions"
+ $awkpath/upstream-coords.awk 25 0 $coords \
+- | $glimmerpath/extract $genome - > $tag.upstream
++ | $glimmerpath/glimmer_extract $genome - > $tag.upstream
+ $elphbin $tag.upstream LEN=6 | $awkpath/get-motif-counts.awk > $tag.motif
+ if ($status != 0) then
+ echo "Failed to create PWM"
+diff -r -u glimmer3.02.old/sample-run/g3-iterated.csh glimmer3.02/sample-run/g3-iterated.csh
+--- glimmer3.02.old/sample-run/g3-iterated.csh 2006-06-13 14:15:28.000000000 +0200
++++ glimmer3.02/sample-run/g3-iterated.csh 2015-05-25 22:40:18.450338748 +0200
+@@ -57,7 +57,7 @@
+ step2:
+ # Extract the training sequences from the genome file
+ echo "Step 2 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $tag.longorfs > $tag.train
++$glimmerpath/glimmer_extract -t $genome $tag.longorfs > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+@@ -103,7 +103,7 @@
+ # upstream of the start locations in $tag.coords
+ echo "Step 6 of ${numsteps}: Making PWM from upstream regions"
+ $awkpath/upstream-coords.awk 25 0 $tag.coords \
+- | $glimmerpath/extract $genome - > $tag.upstream
++ | $glimmerpath/glimmer_extract $genome - > $tag.upstream
+ $elphbin $tag.upstream LEN=6 | $awkpath/get-motif-counts.awk > $tag.motif
+ if ($status != 0) then
+ echo "Failed to create PWM"
+diff -r -u glimmer3.02.old/scripts/g3-from-scratch.csh glimmer3.02/scripts/g3-from-scratch.csh
+--- glimmer3.02.old/scripts/g3-from-scratch.csh 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/scripts/g3-from-scratch.csh 2015-05-25 22:44:44.190343177 +0200
+@@ -50,7 +50,7 @@
+ step2:
+ # Extract the training sequences from the genome file
+ echo "Step 2 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $tag.longorfs > $tag.train
++$glimmerpath/glimmer_extract -t $genome $tag.longorfs > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+diff -r -u glimmer3.02.old/scripts/g3-from-training.csh glimmer3.02/scripts/g3-from-training.csh
+--- glimmer3.02.old/scripts/g3-from-training.csh 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/scripts/g3-from-training.csh 2015-05-25 22:44:44.190343177 +0200
+@@ -42,7 +42,7 @@
+ step1:
+ # Extract the training sequences from the genome file
+ echo "Step 1 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $coords > $tag.train
++$glimmerpath/glimmer_extract -t $genome $coords > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+@@ -66,7 +66,7 @@
+ # upstream of the start locations in $coords
+ echo "Step 3 of ${numsteps}: Making PWM from upstream regions"
+ $awkpath/upstream-coords.awk 25 0 $coords \
+- | $glimmerpath/extract $genome - > $tag.upstream
++ | $glimmerpath/glimmer_extract $genome - > $tag.upstream
+ $elphbin $tag.upstream LEN=6 | $awkpath/get-motif-counts.awk > $tag.motif
+ if ($status != 0) then
+ echo "Failed to create PWM"
+diff -r -u glimmer3.02.old/scripts/g3-iterated.csh glimmer3.02/scripts/g3-iterated.csh
+--- glimmer3.02.old/scripts/g3-iterated.csh 2006-06-13 14:15:46.000000000 +0200
++++ glimmer3.02/scripts/g3-iterated.csh 2015-05-25 22:44:44.190343177 +0200
+@@ -57,7 +57,7 @@
+ step2:
+ # Extract the training sequences from the genome file
+ echo "Step 2 of ${numsteps}: Extracting training sequences"
+-$glimmerpath/extract -t $genome $tag.longorfs > $tag.train
++$glimmerpath/glimmer_extract -t $genome $tag.longorfs > $tag.train
+ if ($status != 0) then
+ echo "Failed to extract training sequences"
+ exit
+@@ -103,7 +103,7 @@
+ # upstream of the start locations in $tag.coords
+ echo "Step 6 of ${numsteps}: Making PWM from upstream regions"
+ $awkpath/upstream-coords.awk 25 0 $tag.coords \
+- | $glimmerpath/extract $genome - > $tag.upstream
++ | $glimmerpath/glimmer_extract $genome - > $tag.upstream
+ $elphbin $tag.upstream LEN=6 | $awkpath/get-motif-counts.awk > $tag.motif
+ if ($status != 0) then
+ echo "Failed to create PWM"
+diff -r -u glimmer3.02.old/src/Util/Makefile glimmer3.02/src/Util/Makefile
+--- glimmer3.02.old/src/Util/Makefile 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/src/Util/Makefile 2015-05-25 22:43:12.760341653 +0200
+@@ -8,7 +8,7 @@
+ SOURCES = $(UTIL_SRCS)
+ OBJECTS = $(UTIL_OBJS)
+
+-PROGS = entropy-profile entropy-score extract multi-extract start-codon-distrib \
++PROGS = entropy-profile entropy-score glimmer_extract multi-extract start-codon-distrib \
+ uncovered window-acgt
+
+ LIBRARIES =
+diff -r -u glimmer3.02.old/src/Util/extract.cc glimmer3.02/src/Util/extract.cc
+--- glimmer3.02.old/src/Util/extract.cc 2006-06-12 21:40:14.000000000 +0200
++++ glimmer3.02/src/Util/extract.cc 2015-05-25 22:44:01.760342470 +0200
+@@ -297,7 +297,7 @@
+
+ {
+ fprintf (stderr,
+- "USAGE: extract [options] <sequence-file> <coords>\n"
++ "USAGE: glimmer_extract [options] <sequence-file> <coords>\n"
+ "\n"
+ "Read fasta-format <sequence-file> and extract from it the\n"
+ "subsequences specified by <coords>. By default, <coords>\n"
+--- glimmer3.02.old/src/Util/Makefile 2015-05-25 22:43:12.760341653 +0200
++++ glimmer-3.02-r3/work/glimmer3.02/src/Util/Makefile 2015-05-25 23:13:34.230372010 +0200
+@@ -21,7 +21,7 @@
+
+ entropy-score: entropy-score.o libGLMcommon.a
+
+-extract: extract.o libGLMcommon.a
++glimmer_extract: extract.o libGLMcommon.a
+
+ multi-extract: multi-extract.o libGLMcommon.a
+
diff --git a/sci-biology/glimmer/glimmer-3.02-r1.ebuild b/sci-biology/glimmer/glimmer-3.02-r3.ebuild
index 532c3bc51c07..b182561f4671 100644
--- a/sci-biology/glimmer/glimmer-3.02-r1.ebuild
+++ b/sci-biology/glimmer/glimmer-3.02-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/glimmer/glimmer-3.02-r1.ebuild,v 1.4 2010/01/03 14:17:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/glimmer/glimmer-3.02-r3.ebuild,v 1.1 2015/05/26 06:22:16 jlec Exp $
-EAPI="2"
+EAPI="5"
-inherit eutils
+inherit eutils toolchain-funcs
MY_PV=${PV//./}
@@ -15,15 +15,20 @@ SRC_URI="http://www.cbcb.umd.edu/software/${PN}/${PN}${MY_PV}.tar.gz"
LICENSE="Artistic"
SLOT="0"
IUSE=""
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
DEPEND=""
-RDEPEND="app-shells/tcsh
- !app-crypt/pkcrack
- !media-libs/libextractor"
+RDEPEND="app-shells/tcsh"
S="${WORKDIR}/${PN}${PV}"
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc210.patch
+ "${FILESDIR}"/${P}-jobserver-fix.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${PN}-3.02b-rename_extract.patch
+)
+
src_prepare() {
sed -i -e 's|\(set awkpath =\).*|\1 /usr/share/'${PN}'/scripts|' \
-e 's|\(set glimmerpath =\).*|\1 /usr/bin|' scripts/* || die "failed to rewrite paths"
@@ -31,20 +36,26 @@ src_prepare() {
sed -i 's/$(MAKE) $(TGT)/$(MAKE) $(TGT) || exit 1/' src/c_make.gen || die
# GCC 4.3 include fix
sed -i 's/include <string>/include <string.h>/' src/Common/delcher.hh || die
- epatch "${FILESDIR}/${PN}-${PV}-glibc210.patch"
+ epatch "${PATCHES[@]}"
}
src_compile() {
- emake -C src || die
+ emake \
+ -C src \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ CXXFLAGS="${CXXFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- rm bin/test
- dobin bin/* || die
+ rm bin/test || die
+ dobin bin/*
- dodir /usr/share/${PN}/scripts
- insinto /usr/share/${PN}/scripts
- doins scripts/* || die
+ insinto /usr/share/${PN}
+ doins -r scripts
dodoc glim302notes.pdf
}
diff --git a/sci-biology/glimmer/glimmer-3.02b.ebuild b/sci-biology/glimmer/glimmer-3.02b.ebuild
new file mode 100644
index 000000000000..1890c5332896
--- /dev/null
+++ b/sci-biology/glimmer/glimmer-3.02b.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/glimmer/glimmer-3.02b.ebuild,v 1.1 2015/05/26 06:22:16 jlec Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV//./}
+
+DESCRIPTION="An HMM-based microbial gene finding system from TIGR"
+HOMEPAGE="http://ccb.jhu.edu/software/glimmer"
+SRC_URI="http://ccb.jhu.edu/software/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/tcsh
+ sci-biology/elph"
+
+#S="${WORKDIR}/${PN}${PV}"
+S="${WORKDIR}/${PN}3.02"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-jobserver-fix.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-rename_extract.patch
+)
+
+src_prepare() {
+ sed -i -e 's|\(set awkpath =\).*|\1 /usr/share/'${PN}'/scripts|' \
+ -e 's|\(set glimmerpath =\).*|\1 /usr/bin|' scripts/* || die "failed to rewrite paths"
+ # Fix Makefile to die on failure
+ sed -i 's/$(MAKE) $(TGT)/$(MAKE) $(TGT) || exit 1/' src/c_make.gen || die
+ # GCC 4.3 include fix
+ sed -i 's/include <string>/include <string.h>/' src/Common/delcher.hh || die
+ #
+ sed -i "s+/fs/szgenefinding/Glimmer3/bin+%${D}/bin/glimmer3+" scripts/g3-* || die
+ sed -i "s+/fs/szgenefinding/Glimmer3/scripts+%${D}/share/glimmer/scripts+" scripts/g3-* || die
+ sed -i "s+/nfshomes/adelcher/bin/elph+%${D}/bin/elph+" scripts/g3-* || die
+ sed -i "s/@ if/if/" src/c_make.gen || die
+ # avoid file collision on /usr/bin/extract #247394
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() {
+ emake \
+ -C src \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ CXXFLAGS="${CXXFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ rm bin/test || die
+ dobin bin/*
+
+ insinto /usr/share/${PN}
+ doins -r scripts
+
+ dodoc glim302notes.pdf
+}