summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-01-02 22:37:02 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-01-02 22:37:02 +0000
commit4b310f6b276b2bbd51c44393af589fffe19d582d (patch)
treeb49eb57ef14a5fa1b4894a31ac8dcf876f7f787a /sci-biology
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-4b310f6b276b2bbd51c44393af589fffe19d582d.tar.gz
gentoo-2-4b310f6b276b2bbd51c44393af589fffe19d582d.tar.bz2
gentoo-2-4b310f6b276b2bbd51c44393af589fffe19d582d.zip
Use toolchain-funcs rather than gcc
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tree-puzzle/ChangeLog7
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild4
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild10
3 files changed, 12 insertions, 9 deletions
diff --git a/sci-biology/tree-puzzle/ChangeLog b/sci-biology/tree-puzzle/ChangeLog
index 836f3e0973b2..8f65183631ac 100644
--- a/sci-biology/tree-puzzle/ChangeLog
+++ b/sci-biology/tree-puzzle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/tree-puzzle
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.2 2004/12/23 20:20:08 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.3 2005/01/02 22:37:02 ribosome Exp $
+
+ 02 Jan 2005; Olivier Fisette <ribosome@gentoo.org> tree-puzzle-5.2.ebuild:
+ Use the toolchain-funcs rather than the gcc eclass.
*tree-puzzle-5.2 (23 Dec 2004)
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild
index 1e7df801683a..7af4baacf092 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild,v 1.1 2004/12/23 18:14:07 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.1.ebuild,v 1.2 2005/01/02 22:37:02 ribosome Exp $
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
HOMEPAGE="http://www.tree-puzzle.de"
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index baeb97170c3f..f4918e685664 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.1 2004/12/23 18:14:07 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.2 2005/01/02 22:37:02 ribosome Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
HOMEPAGE="http://www.tree-puzzle.de"
@@ -17,7 +17,7 @@ DEPEND="virtual/libc
mpi? ( sys-cluster/lam-mpi )"
pkg_setup () {
- use mpi && [ $(gcc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
Either disable the \"mpi\" USE flag to compile only the non-parallelized
version of the program, or use gcc as your compiler (CC=\"gcc\")."
}
@@ -29,7 +29,7 @@ src_compile() {
sed -i -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' Makefile
sed -i -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' Makefile
fi
- cd {S}
+ cd ${S}
emake || die
}