summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-28 00:16:02 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-28 00:16:02 +0000
commit1b2dab8fcc01f89e697d1b922d7d2cfe5dfd96b3 (patch)
tree27ca97f5f0f170e6f38e2eccf05d47c06e3a99f8 /sci-biology
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1b2dab8fcc01f89e697d1b922d7d2cfe5dfd96b3.tar.gz
gentoo-2-1b2dab8fcc01f89e697d1b922d7d2cfe5dfd96b3.tar.bz2
gentoo-2-1b2dab8fcc01f89e697d1b922d7d2cfe5dfd96b3.zip
New package, ebuild written by me
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/diya/ChangeLog10
-rw-r--r--sci-biology/diya/diya-1.0_rc4.ebuild43
-rw-r--r--sci-biology/diya/metadata.xml9
3 files changed, 62 insertions, 0 deletions
diff --git a/sci-biology/diya/ChangeLog b/sci-biology/diya/ChangeLog
new file mode 100644
index 000000000000..10a6db4f096d
--- /dev/null
+++ b/sci-biology/diya/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/diya
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/diya/ChangeLog,v 1.1 2009/09/28 00:16:02 weaver Exp $
+
+*diya-1.0_rc4 (27 Sep 2009)
+
+ 27 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+ +diya-1.0_rc4.ebuild:
+ New package, ebuild written by me
+
diff --git a/sci-biology/diya/diya-1.0_rc4.ebuild b/sci-biology/diya/diya-1.0_rc4.ebuild
new file mode 100644
index 000000000000..044b16b4a52d
--- /dev/null
+++ b/sci-biology/diya/diya-1.0_rc4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/diya/diya-1.0_rc4.ebuild,v 1.1 2009/09/28 00:16:02 weaver Exp $
+
+EAPI="2"
+
+inherit perl-module
+
+DESCRIPTION="Do It Yourself Annotation, a collection of tools and libraries for sequence assembly and annotation"
+HOMEPAGE="http://gmod.org/wiki/Diya"
+SRC_URI="mirror://sourceforge/diyg/files/diya/diya-1.0/diya-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="-minimal"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sci-biology/bioperl
+ dev-perl/Data-Utilities
+ dev-perl/XML-Simple"
+RDEPEND="${DEPEND}
+ !minimal? (
+ sci-biology/mummer
+ sci-biology/glimmer
+ sci-biology/trnascan-se
+ sci-biology/infernal )"
+
+# see ftp://ftp.ncbi.nih.gov/blast/ to check if blast and blast+ are different from ncbi-tools and ncbi-tools++
+# * rfamscan.pl v0.1 (http://www.sanger.ac.uk/Users/sgj/code/)
+# * UniRef50 (http://www.ebi.ac.uk/uniref/)
+# * Protein Clusters (ftp://ftp.ncbi.nih.gov/genomes/Bacteria/CLUSTERS/)
+# The file cddid_all.tbl can be found at ftp://ftp.ncbi.nih.gov/pub/mmdb/cdd/.
+
+S="${WORKDIR}/diya-${PV/_/-}"
+
+SRC_TEST=do
+
+src_install() {
+ mydoc="INSTALL README docs/diya.html"
+ perl-module_src_install
+ insinto /usr/share/${PN}
+ doins -r diya.conf docs examples scripts || die
+}
diff --git a/sci-biology/diya/metadata.xml b/sci-biology/diya/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/diya/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>