summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2009-09-01 18:58:58 +0000
committerOlivier Fisette <ribosome@gentoo.org>2009-09-01 18:58:58 +0000
commitfe92747a505ba0c4ed9f10d4dddf34645e3a3f9f (patch)
tree3d6e1d03a7a6d089f853ac223960fcf6d0c328f0 /sci-biology/prints
parent- stable on x86 and amd64 (diff)
downloadgentoo-2-fe92747a505ba0c4ed9f10d4dddf34645e3a3f9f.tar.gz
gentoo-2-fe92747a505ba0c4ed9f10d4dddf34645e3a3f9f.tar.bz2
gentoo-2-fe92747a505ba0c4ed9f10d4dddf34645e3a3f9f.zip
New upsteam version.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/prints')
-rw-r--r--sci-biology/prints/ChangeLog9
-rw-r--r--sci-biology/prints/prints-39.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-biology/prints/ChangeLog b/sci-biology/prints/ChangeLog
index de21ec19c24a..99fc1766cb97 100644
--- a/sci-biology/prints/ChangeLog
+++ b/sci-biology/prints/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/prints
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/ChangeLog,v 1.19 2006/11/02 20:21:23 grobian Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/ChangeLog,v 1.20 2009/09/01 18:58:58 ribosome Exp $
+
+*prints-39.0 (01 Sep 2009)
+
+ 01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> +prints-39.0.ebuild:
+ New upstream version.
02 Nov 2006; Fabian Groffen <grobian@gentoo.org> prints-38.0.ebuild:
Dropped ppc-macos, see you in prefix.
diff --git a/sci-biology/prints/prints-39.0.ebuild b/sci-biology/prints/prints-39.0.ebuild
new file mode 100644
index 000000000000..ff93cb5208d4
--- /dev/null
+++ b/sci-biology/prints/prints-39.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/prints-39.0.ebuild,v 1.1 2009/09/01 18:58:58 ribosome Exp $
+
+MY_PV="${PV/./_}"
+
+DESCRIPTION="A protein motif fingerprint database"
+LICENSE="public-domain"
+HOMEPAGE="http://www.bioinf.man.ac.uk/dbbrowser/PRINTS/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PRINTS
+ echo
+ einfo "Indexing PRINTS for usage with EMBOSS."
+ EMBOSS_DATA="." printsextract -auto -infile prints${MY_PV}.dat || die \
+ "Indexing PRINTS failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins newpr.lis ${PN}${MY_PV}.{all.fasta,dat,kdat,lis,nam,vsn} || die \
+ "Installing raw database failed."
+ fi
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PRINTS
+ doins PRINTS/* || die "Installing EMBOSS data files failed."
+ fi
+ dodoc README || die "Documentation installation failed."
+}