summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2009-01-16 17:04:14 +0000
committerOlivier Fisette <ribosome@gentoo.org>2009-01-16 17:04:14 +0000
commit7a707eee7fcbe9ee04d4e46a2b03219a0090a9d5 (patch)
tree820fd00a0e29ee4a3cc31570f779d26cf402a665 /sci-biology/biopython
parentBits of Mono use this license. (diff)
downloadgentoo-2-7a707eee7fcbe9ee04d4e46a2b03219a0090a9d5.tar.gz
gentoo-2-7a707eee7fcbe9ee04d4e46a2b03219a0090a9d5.tar.bz2
gentoo-2-7a707eee7fcbe9ee04d4e46a2b03219a0090a9d5.zip
New upstream version (fixes bug #248799).
(Portage version: 2.2_rc21/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog11
-rw-r--r--sci-biology/biopython/biopython-1.49.ebuild53
-rw-r--r--sci-biology/biopython/files/biopython-1.49-flex.patch21
3 files changed, 83 insertions, 2 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 127fa2230028..4180a4714b76 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/biopython
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.26 2008/08/06 14:53:49 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.27 2009/01/16 17:04:14 ribosome Exp $
+
+*biopython-1.49 (16 Jan 2009)
+
+ 16 Jan 2009; Olivier Fisette <ribosome@gentoo.org>
+ +files/biopython-1.49-flex.patch, +biopython-1.49.ebuild:
+ Version bump. Thanks to Juan Aguado <juantxorena@gmail.com> for his work.
+ Fixes bug #248799.
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-biology/biopython/biopython-1.49.ebuild b/sci-biology/biopython/biopython-1.49.ebuild
new file mode 100644
index 000000000000..a85481d50c21
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.49.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.49.ebuild,v 1.1 2009/01/16 17:04:14 ribosome Exp $
+
+NEED_PYTHON=2.3
+inherit distutils eutils
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+LICENSE="as-is"
+HOMEPAGE="http://www.biopython.org"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+SLOT="0"
+IUSE="mysql postgres"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="dev-python/numpy
+ >=dev-python/reportlab-2.0
+ sys-devel/flex"
+
+RDEPEND="${DEPEND}
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-flex.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CONTRIB DEPRECATED NEWS README"
+ distutils_src_install
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
+ die "Failed to install documentation."
+ dodir "/usr/share/${PN}"
+ rm Tests/*.pyc || \
+ die "Failed to remove precompiled test files."
+ cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
+ die "Failed to install shared files."
+}
+
+src_test() {
+ cd "${S}/Tests"
+ PYTHONPATH="${PYTHONPATH}:${S}" \
+ python run_tests.py --no-gui || die "Tests failed."
+}
diff --git a/sci-biology/biopython/files/biopython-1.49-flex.patch b/sci-biology/biopython/files/biopython-1.49-flex.patch
new file mode 100644
index 000000000000..afd509444c68
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.49-flex.patch
@@ -0,0 +1,21 @@
+--- setup.py.old 2008-11-25 18:03:16.000000000 +0100
++++ setup.py 2008-11-25 18:04:14.000000000 +0100
+@@ -341,12 +341,12 @@
+ include_dirs=["Bio"]
+ ),
+ #Commented out due to the build dependency on flex, see Bug 2619
+-# Extension('Bio.PDB.mmCIF.MMCIFlex',
+-# ['Bio/PDB/mmCIF/lex.yy.c',
+-# 'Bio/PDB/mmCIF/MMCIFlexmodule.c'],
+-# include_dirs=["Bio"],
+-# libraries=["fl"]
+-# ),
++ Extension('Bio.PDB.mmCIF.MMCIFlex',
++ ['Bio/PDB/mmCIF/lex.yy.c',
++ 'Bio/PDB/mmCIF/MMCIFlexmodule.c'],
++ include_dirs=["Bio"],
++ libraries=["fl"]
++ ),
+ Extension('Bio.Nexus.cnexus',
+ ['Bio/Nexus/cnexus.c']
+ ),