summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:04:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:04:05 +0000
commit7108bd6e868ca394892d4df3fbf60c03e3d27089 (patch)
treedbd2cb414ebfda1ccbbe70b47074183adb038db2 /sci-biology/biopython
parentVersion bumps (diff)
downloadgentoo-2-7108bd6e868ca394892d4df3fbf60c03e3d27089.tar.gz
gentoo-2-7108bd6e868ca394892d4df3fbf60c03e3d27089.tar.bz2
gentoo-2-7108bd6e868ca394892d4df3fbf60c03e3d27089.zip
Delete older ebuilds.
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/biopython-1.49.ebuild53
-rw-r--r--sci-biology/biopython/biopython-1.51.ebuild53
-rw-r--r--sci-biology/biopython/biopython-1.52.ebuild53
3 files changed, 0 insertions, 159 deletions
diff --git a/sci-biology/biopython/biopython-1.49.ebuild b/sci-biology/biopython/biopython-1.49.ebuild
deleted file mode 100644
index 4c74b28477cf..000000000000
--- a/sci-biology/biopython/biopython-1.49.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.49.ebuild,v 1.6 2009/08/26 12:38:25 klausman Exp $
-
-NEED_PYTHON=2.3
-inherit distutils eutils
-
-DESCRIPTION="Biopython - Python modules for computational molecular biology"
-LICENSE="as-is"
-HOMEPAGE="http://www.biopython.org"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-SLOT="0"
-IUSE="mysql postgres"
-KEYWORDS="alpha amd64 ppc sparc x86"
-
-DEPEND="dev-python/numpy
- >=dev-python/reportlab-2.0
- sys-devel/flex"
-
-RDEPEND="${DEPEND}
- mysql? ( dev-python/mysql-python )
- postgres? ( dev-python/psycopg )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-flex.patch"
-}
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- DOCS="CONTRIB DEPRECATED NEWS README"
- distutils_src_install
-
- dodir "/usr/share/doc/${PF}"
- cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
- die "Failed to install documentation."
- dodir "/usr/share/${PN}"
- rm Tests/*.pyc || \
- die "Failed to remove precompiled test files."
- cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
- die "Failed to install shared files."
-}
-
-src_test() {
- cd "${S}/Tests"
- PYTHONPATH="${PYTHONPATH}:${S}" \
- python run_tests.py --no-gui || die "Tests failed."
-}
diff --git a/sci-biology/biopython/biopython-1.51.ebuild b/sci-biology/biopython/biopython-1.51.ebuild
deleted file mode 100644
index 3614eed87af8..000000000000
--- a/sci-biology/biopython/biopython-1.51.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.51.ebuild,v 1.1 2009/09/09 21:45:48 weaver Exp $
-
-EAPI="2"
-
-NEED_PYTHON=2.4
-inherit distutils eutils base
-
-DESCRIPTION="Biopython - Python modules for computational molecular biology"
-LICENSE="as-is"
-HOMEPAGE="http://www.biopython.org"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-SLOT="0"
-IUSE="mysql postgres"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="dev-python/numpy
- >=dev-python/reportlab-2.0
- sys-devel/flex"
-
-RDEPEND="${DEPEND}
- mysql? ( dev-python/mysql-python )
- postgres? ( dev-python/psycopg )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-flex.patch
-)
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- DOCS="CONTRIB DEPRECATED NEWS README"
- distutils_src_install
-
- dodir "/usr/share/doc/${PF}"
- cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
- die "Failed to install documentation."
- dodir "/usr/share/${PN}"
- rm -f Tests/*.pyc || \
- die "Failed to remove precompiled test files."
- cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
- die "Failed to install shared files."
-}
-
-src_test() {
- cd "${S}/Tests"
- PYTHONPATH="${PYTHONPATH}:${S}" \
- python run_tests.py --no-gui || die "Tests failed."
-}
diff --git a/sci-biology/biopython/biopython-1.52.ebuild b/sci-biology/biopython/biopython-1.52.ebuild
deleted file mode 100644
index a4a8967e81e2..000000000000
--- a/sci-biology/biopython/biopython-1.52.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.52.ebuild,v 1.2 2009/10/31 17:56:54 maekke Exp $
-
-EAPI="2"
-
-NEED_PYTHON=2.4
-inherit distutils eutils base
-
-DESCRIPTION="Biopython - Python modules for computational molecular biology"
-LICENSE="as-is"
-HOMEPAGE="http://www.biopython.org"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-SLOT="0"
-IUSE="mysql postgres"
-KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
-
-DEPEND="dev-python/numpy
- >=dev-python/reportlab-2.0
- sys-devel/flex"
-
-RDEPEND="${DEPEND}
- mysql? ( dev-python/mysql-python )
- postgres? ( dev-python/psycopg )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.51-flex.patch
-)
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- DOCS="CONTRIB DEPRECATED NEWS README"
- distutils_src_install
-
- dodir "/usr/share/doc/${PF}"
- cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
- die "Failed to install documentation."
- dodir "/usr/share/${PN}"
- rm -f Tests/*.pyc || \
- die "Failed to remove precompiled test files."
- cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
- die "Failed to install shared files."
-}
-
-src_test() {
- cd "${S}/Tests"
- PYTHONPATH="${PYTHONPATH}:${S}" \
- python run_tests.py --no-gui || die "Tests failed."
-}