summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 00:00:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 00:00:31 +0000
commitea8660b6522b854ff6c498c635b640aecf3b55e7 (patch)
tree9733b1a69061dc609dedf9d4ec73da9b5e4d6218 /sci-astronomy
parentFix @EULA typo in previous commit. (diff)
downloadgentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.tar.gz
gentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.tar.bz2
gentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/swarp/ChangeLog8
-rw-r--r--sci-astronomy/swarp/files/swarp-configure.patch54
-rw-r--r--sci-astronomy/swarp/swarp-2.17.6.ebuild35
3 files changed, 96 insertions, 1 deletions
diff --git a/sci-astronomy/swarp/ChangeLog b/sci-astronomy/swarp/ChangeLog
index ce965dd46179..6a2bbc0576ee 100644
--- a/sci-astronomy/swarp/ChangeLog
+++ b/sci-astronomy/swarp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/swarp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.1 2009/02/17 20:54:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.2 2009/07/28 00:00:31 bicatali Exp $
+
+*swarp-2.17.6 (28 Jul 2009)
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +swarp-2.17.6.ebuild,
+ +files/swarp-configure.patch:
+ Version bump
*swarp-2.17.1 (17 Feb 2009)
diff --git a/sci-astronomy/swarp/files/swarp-configure.patch b/sci-astronomy/swarp/files/swarp-configure.patch
new file mode 100644
index 000000000000..af62726761de
--- /dev/null
+++ b/sci-astronomy/swarp/files/swarp-configure.patch
@@ -0,0 +1,54 @@
+--- configure.ac.orig 2009-03-26 22:58:33.000000000 +0000
++++ configure.ac 2009-03-26 22:59:45.000000000 +0000
+@@ -21,41 +21,16 @@
+
+ # Include macros
+ sinclude(acx_pthread.m4)
+-sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_urbi_resolve_dir.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+ # Checks for programs.
+-# GCC is chosen last because it is likely to yield less optimized code
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C
+ AM_PROG_CC_STDC
+ # C Compiler: Check that it is POSIX-compliant
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+
+@@ -65,9 +40,6 @@
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(malloc.h unistd.h sys/mman.h)
+-if test $use_icc = "yes" -a $CC = "icc"; then
+-AC_CHECK_HEADERS(mathimf.h)
+-fi
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/sci-astronomy/swarp/swarp-2.17.6.ebuild b/sci-astronomy/swarp/swarp-2.17.6.ebuild
new file mode 100644
index 000000000000..cac1db943eb2
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.17.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/swarp-2.17.6.ebuild,v 1.1 2009/07/28 00:00:31 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://astromatic.iap.fr/software/swarp"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/* || die
+ fi
+}