summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-01-19 07:31:12 +0000
committerDaniel Goller <morfic@gentoo.org>2006-01-19 07:31:12 +0000
commit82b4c66cf22bb2bfca37604ff9d6ed8544cb31c4 (patch)
treee8a6ddbdeb284b1f961ea4bf458c756e1457f49e /sci-astronomy
parentold ebuilds remved. marked 0.4.29 as x86 (diff)
downloadgentoo-2-82b4c66cf22bb2bfca37604ff9d6ed8544cb31c4.tar.gz
gentoo-2-82b4c66cf22bb2bfca37604ff9d6ed8544cb31c4.tar.bz2
gentoo-2-82b4c66cf22bb2bfca37604ff9d6ed8544cb31c4.zip
Fixing Makefiles wrt to bug #119339
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog5
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 36a22617e38f..890ae436a2d2 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.7 2006/01/17 05:58:44 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.8 2006/01/19 07:31:12 morfic Exp $
+
+ 19 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
+ Fixing bug #119339 while taking care of access violations
17 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
Fixing Access Violations, closing bug #119189
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 4bdeb7d4c2db..27b35598a3b5 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.3 2006/01/17 05:58:44 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.4 2006/01/19 07:31:12 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -43,8 +43,8 @@ pkg_setup() {
einfo "USE=\"gtk\" detected."
mygui="gtk"
elif use kde && use gnome; then
- einfo "Both gnome and kde support requested. Defaulting to gtk"
- mygui="gtk"
+ einfo "Both gnome and kde support requested. Defaulting to kde"
+ mygui="kde"
else
ewarn "If you want to use the full gui, set USE=\"{kde/gnome/gtk}\""
ewarn "Defaulting to glut support (no GUI)."
@@ -74,11 +74,17 @@ src_compile() {
econf \
--with-${mygui} \
+ --with-pic \
$(use_with arts) \
$(use_with lua) \
$(use_enable threads threading) \
$(use_enable nls) \
|| die "econf failed"
+
+ #fix Makefiles to avoid Access Violations while fixing bug #119339
+ for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
+ sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
+
emake || die "emake failed"
}
@@ -86,7 +92,6 @@ src_install() {
if [ "${mygui}" = "gnome" ]; then
gnome2_src_install
else
- EXTRA_EINSTALL="pkgdatadir=${D}/usr/share/celestia"
einstall || die "einstall failed"
fi