summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-01-23 04:59:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-01-23 04:59:38 +0000
commit7cffdd1c447641f47c7522e5d002f70017d8999d (patch)
treea9238262538cbfbae603b2d8cace997411490624 /sci-astronomy
parentdisable wx-config as per moloh's suggestion (diff)
downloadgentoo-2-7cffdd1c447641f47c7522e5d002f70017d8999d.tar.gz
gentoo-2-7cffdd1c447641f47c7522e5d002f70017d8999d.tar.bz2
gentoo-2-7cffdd1c447641f47c7522e5d002f70017d8999d.zip
old
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/files/digest-stellarium-0.9.03
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch58
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch20
-rw-r--r--sci-astronomy/stellarium/stellarium-0.9.0.ebuild58
4 files changed, 0 insertions, 139 deletions
diff --git a/sci-astronomy/stellarium/files/digest-stellarium-0.9.0 b/sci-astronomy/stellarium/files/digest-stellarium-0.9.0
deleted file mode 100644
index 0d877cfb1fce..000000000000
--- a/sci-astronomy/stellarium/files/digest-stellarium-0.9.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 781a5171705c72e4dd3d08c9b1e4c15c stellarium-0.9.0.tar.gz 33759482
-RMD160 ab960f4adbeed505cb9da1fedc5cd207c882267e stellarium-0.9.0.tar.gz 33759482
-SHA256 a1d4e009d16d745ff1bd03b4fcaa772fe607a255295964171d241cac519d9242 stellarium-0.9.0.tar.gz 33759482
diff --git a/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch b/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch
deleted file mode 100644
index 348a32b26a8c..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Index: stellarium-0.7.1/src/observator.h
-===================================================================
---- stellarium-0.7.1.orig/src/observator.h
-+++ stellarium-0.7.1/src/observator.h
-@@ -112,8 +112,8 @@ private:
- string s_time_format_to_string(S_TIME_FORMAT) const;
-
- // Convert the date format enum to its associated string and reverse
-- S_DATE_FORMAT Observator::string_to_s_date_format(const string& df) const;
-- string Observator::s_date_format_to_string(S_DATE_FORMAT df) const;
-+ S_DATE_FORMAT string_to_s_date_format(const string& df) const;
-+ string s_date_format_to_string(S_DATE_FORMAT df) const;
-
- // for changing position
- bool flag_move_to;
-Index: stellarium-0.7.1/src/projector.h
-===================================================================
---- stellarium-0.7.1.orig/src/projector.h
-+++ stellarium-0.7.1/src/projector.h
-@@ -75,7 +75,7 @@ public:
- virtual void set_viewport(int x, int y, int w, int h);
-
- // Fill with black around the circle
-- void Projector::draw_viewport_shape(void);
-+ void draw_viewport_shape(void);
-
- int viewW(void) const {return vec_viewport[2];}
- int viewH(void) const {return vec_viewport[3];}
-Index: stellarium-0.7.1/src/stel_command_interface.h
-===================================================================
---- stellarium-0.7.1.orig/src/stel_command_interface.h
-+++ stellarium-0.7.1/src/stel_command_interface.h
-@@ -43,9 +43,9 @@ class StelCommandInterface : CommandInte
- public:
- StelCommandInterface(stel_core * core);
- virtual ~StelCommandInterface();
-- virtual int StelCommandInterface::execute_command(string commandline);
-- virtual int StelCommandInterface::execute_command(string command, double arg);
-- virtual int StelCommandInterface::execute_command(string command, int arg);
-+ virtual int execute_command(string commandline);
-+ virtual int execute_command(string command, double arg);
-+ virtual int execute_command(string command, int arg);
- virtual int execute_command(string command, unsigned long int &wait, bool trusted);
- virtual int set_flag(string name, string value, bool &newval, bool trusted);
- void update(int delta_time);
-Index: stellarium-0.7.1/src/stel_ui.h
-===================================================================
---- stellarium-0.7.1.orig/src/stel_ui.h
-+++ stellarium-0.7.1/src/stel_ui.h
-@@ -316,7 +316,7 @@ private:
- void tui_cb_sky_time(); // change effect parameters
-
- // Parse a file of type /usr/share/zoneinfo/zone.tab
-- s_tui::MultiSet_item<string>* stel_ui::create_tree_from_time_zone_file(const string& zonetab);
-+ s_tui::MultiSet_item<string>* create_tree_from_time_zone_file(const string& zonetab);
-
- bool ScriptDirectoryRead;
- };
diff --git a/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch b/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch
deleted file mode 100644
index a9a1bc379e85..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.8.0-gcc41.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/s_gui.h
-+++ src/s_gui.h
-@@ -510,7 +510,7 @@
-
- private:
- callback<void> onChangeCallback;
-- void ScrollBar::adjustSize(void);
-+ void adjustSize(void);
- Button scrollBt;
- bool vertical;
- unsigned int scrollOffset, scrollSize;
-@@ -837,7 +837,7 @@
- class City
- {
- public:
-- City::City(const string& _name = "", const string& _state = "", const string& _country = "",
-+ City(const string& _name = "", const string& _state = "", const string& _country = "",
- double _longitude = 0.f, double _latitude = 0.f, float zone = 0, int _showatzoom = 0, int _altitude = 0);
- void addCity(const string& _name = "", const string& _state = "", const string& _country = "",
- double _longitude = 0.f, double _latitude = 0.f, float zone = 0, int _showatzoom = 0, int _altitude = 0);
diff --git a/sci-astronomy/stellarium/stellarium-0.9.0.ebuild b/sci-astronomy/stellarium/stellarium-0.9.0.ebuild
deleted file mode 100644
index 6252bd8e8016..000000000000
--- a/sci-astronomy/stellarium/stellarium-0.9.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.9.0.ebuild,v 1.3 2007/08/16 20:06:49 mr_bones_ Exp $
-
-inherit toolchain-funcs eutils qt4
-
-DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
-HOMEPAGE="http://www.stellarium.org/"
-SRC_URI="mirror://sourceforge/stellarium/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls"
-
-RDEPEND="virtual/opengl
- virtual/glu
- media-libs/libpng
- media-libs/freetype
- dev-libs/boost
- media-libs/jpeg
- net-misc/curl
- $(qt4_min_version 4.2)
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.6
- nls? ( sys-devel/gettext )
- x11-libs/libXt"
-
-# bug #186194
-QT4_BUILT_WITH_USE_CHECK="opengl"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if ! use nls ; then
- sed -i \
- -e 's/ENABLE_NLS 1/ENABLE_NLS 0/' \
- CMakeLists.txt \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- CC=$(tc-getCC) \
- CXX=$(tc-getCXX) \
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- || die "cmake failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- use nls || rm -rf "${D}/usr/share/locale"
- make_desktop_entry stellarium Stellarium
- dodoc AUTHORS ChangeLog README TODO
-}