summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-24 18:13:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-24 18:13:38 +0000
commit162463187fd0d9a82e589dc88881bbd0c49a07c6 (patch)
tree190dd05d95fabf3fa3d33bba02888966573de3a5 /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-162463187fd0d9a82e589dc88881bbd0c49a07c6.tar.gz
gentoo-2-162463187fd0d9a82e589dc88881bbd0c49a07c6.tar.bz2
gentoo-2-162463187fd0d9a82e589dc88881bbd0c49a07c6.zip
Bump. Added a patch to avoid overflows
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/skycat/ChangeLog11
-rw-r--r--sci-astronomy/skycat/files/skycat-3.1.1-gcc45.patch30
-rw-r--r--sci-astronomy/skycat/skycat-3.0.2.ebuild51
-rw-r--r--sci-astronomy/skycat/skycat-3.1.1.ebuild (renamed from sci-astronomy/skycat/skycat-3.0.2-r1.ebuild)37
4 files changed, 61 insertions, 68 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index ab1bf6dc52bb..b8e34a49430b 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/skycat
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.6 2009/09/25 03:19:55 markusle Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.7 2010/09/24 18:13:38 bicatali Exp $
+
+*skycat-3.1.1 (24 Sep 2010)
+
+ 24 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> -skycat-3.0.2.ebuild,
+ -skycat-3.0.2-r1.ebuild, +skycat-3.1.1.ebuild,
+ +files/skycat-3.1.1-gcc45.patch:
+ Bump. Added a patch to avoid overflows
*skycat-3.0.2-r2 (25 Sep 2009)
diff --git a/sci-astronomy/skycat/files/skycat-3.1.1-gcc45.patch b/sci-astronomy/skycat/files/skycat-3.1.1-gcc45.patch
new file mode 100644
index 000000000000..32b7f86656c8
--- /dev/null
+++ b/sci-astronomy/skycat/files/skycat-3.1.1-gcc45.patch
@@ -0,0 +1,30 @@
+--- astrotcl/generic/ImageIO.h.orig 2010-09-24 06:31:03.000000000 +0100
++++ astrotcl/generic/ImageIO.h 2010-09-24 06:32:06.000000000 +0100
+@@ -28,6 +28,7 @@
+
+ #include <iostream>
+ #include <cmath>
++#include <cstdlib>
+ #include "WCSRep.h"
+ #include "Mem.h"
+
+--- ./rtd/generic/histzero.c.orig 2010-09-24 06:36:08.000000000 +0100
++++ ./rtd/generic/histzero.c 2010-09-24 06:37:48.000000000 +0100
+@@ -15,6 +15,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "histeq.h" /* define SubrangeLink */
+
+ static void merge_links();
+--- ./rtd/generic/histmap.c.orig 2010-09-24 06:35:59.000000000 +0100
++++ ./rtd/generic/histmap.c 2010-09-24 06:37:26.000000000 +0100
+@@ -17,6 +17,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "histeq.h" /* define SubrangeLink, List */
+
+
diff --git a/sci-astronomy/skycat/skycat-3.0.2.ebuild b/sci-astronomy/skycat/skycat-3.0.2.ebuild
deleted file mode 100644
index 154ddf670acf..000000000000
--- a/sci-astronomy/skycat/skycat-3.0.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2.ebuild,v 1.1 2008/06/26 11:34:30 bicatali Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="ESO astronomical image visualizer with catalog access."
-HOMEPAGE="http://archive.eso.org/skycat"
-SRC_URI="ftp://ftp.eso.org/pub/archive/${PN}/Sources/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="threads"
-
-DEPEND="x11-libs/libXext
- >=dev-tcltk/tclx-2.4
- >=dev-tcltk/blt-2.4
- >=dev-tcltk/itcl-3.3
- >=dev-tcltk/iwidgets-4.0.1
- >=dev-tcltk/tkimg-1.3"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # fix buggy tcl.m4 for bash3
- epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
- # fix old style headers, set as error by new g++
- epatch "${FILESDIR}"/${PN}-3.0.1-gcc43.patch
- eautoconf
-}
-
-src_compile() {
- econf \
- $(use_enable threads) \
- || die "econf failed"
- emake
- # a second time to make sure every dir passed
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README CHANGES VERSION
- for d in tclutil astrotcl rtd cat skycat; do
- docinto ${d}
- for f in README CHANGES VERSION; do
- newdoc ${f} ${f}.${d}
- done
- done
-}
diff --git a/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild b/sci-astronomy/skycat/skycat-3.1.1.ebuild
index 9d9c9a4070ac..81cc3f77a336 100644
--- a/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
+++ b/sci-astronomy/skycat/skycat-3.1.1.ebuild
@@ -1,45 +1,52 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild,v 1.2 2009/09/16 04:20:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.1.1.ebuild,v 1.1 2010/09/24 18:13:38 bicatali Exp $
+EAPI=2
inherit eutils autotools
DESCRIPTION="ESO astronomical image visualizer with catalog access."
HOMEPAGE="http://archive.eso.org/skycat"
-SRC_URI="ftp://ftp.eso.org/pub/archive/${PN}/Sources/${P}.tar.gz"
+SRC_URI="http://archive.eso.org/cms/tools-documentation/skycat-download/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="threads"
-RDEPEND="${DEPEND}"
DEPEND="x11-libs/libXext
>=dev-tcltk/tclx-2.4
>=dev-tcltk/blt-2.4
>=dev-tcltk/itcl-3.3
>=dev-tcltk/iwidgets-4.0.1
- >=dev-tcltk/tkimg-1.3"
+ >=dev-tcltk/tkimg-1.3
+ sci-libs/cfitsio
+ sci-astronomy/wcstools"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# fix buggy tcl.m4 for bash3
epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
- # fix old style headers, set as error by new g++
- epatch "${FILESDIR}"/${PN}-3.0.1-gcc43.patch
-
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-gcc45.patch
+ #epatch "${FILESDIR}"/${PN}-3.0.2-glibc-2.10.patch
# need fix for tk-8.5
if has_version ">=dev-lang/tk-8.5" ; then
- epatch "${FILESDIR}"/${P}-tk8.5.patch
+ epatch "${FILESDIR}"/${PN}-3.0.2-tk8.5.patch
fi
+ epatch "${FILESDIR}"/${PN}-3.0.2-makefile-qa.patch
+ # use system libs
+ epatch "${FILESDIR}"/${PN}-3.0.2-systemlibs.patch
+ rm -fr "${S}"/astrotcl/cfitsio/ "${S}"/astrotcl/libwcs/ \
+ || die "Failed to remove included libs"
+ eautoreconf
+}
- eautoconf
+src_configure() {
+ econf $(use_enable threads) --enable-merge
}
src_compile() {
- econf $(use_enable threads)
emake
emake || die "emake failed"
}