summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-18 17:58:11 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-18 17:58:11 +0000
commitc80f69b9b3885ed9dbb3711225c2ca737c4f18fd (patch)
treeca58abdad951d2ece2bf56d6589d44c051cc01ba /sci-astronomy/setiathome
parentVersion bump, #124199. (diff)
downloadgentoo-2-c80f69b9b3885ed9dbb3711225c2ca737c4f18fd.tar.gz
gentoo-2-c80f69b9b3885ed9dbb3711225c2ca737c4f18fd.tar.bz2
gentoo-2-c80f69b9b3885ed9dbb3711225c2ca737c4f18fd.zip
Add patch to fix compilation with gcc-4.1; bug #132336
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-astronomy/setiathome')
-rw-r--r--sci-astronomy/setiathome/ChangeLog6
-rw-r--r--sci-astronomy/setiathome/files/digest-setiathome-4.18-r14
-rw-r--r--sci-astronomy/setiathome/files/setiathome-4.18-gcc41.patch11
-rw-r--r--sci-astronomy/setiathome/setiathome-4.18-r1.ebuild11
4 files changed, 30 insertions, 2 deletions
diff --git a/sci-astronomy/setiathome/ChangeLog b/sci-astronomy/setiathome/ChangeLog
index 0900623c96f2..63f54d7324e9 100644
--- a/sci-astronomy/setiathome/ChangeLog
+++ b/sci-astronomy/setiathome/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/setiathome
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/ChangeLog,v 1.15 2006/04/23 03:16:11 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/ChangeLog,v 1.16 2006/05/18 17:58:11 halcy0n Exp $
+
+ 18 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/setiathome-4.18-gcc41.patch, setiathome-4.18-r1.ebuild:
+ Add patch to fix compilation with gcc-4.1; bug #132336
23 Apr 2006; Thomas Cort <tcort@gentoo.org> setiathome-4.18-r1.ebuild:
Added ~alpha keyword wrt Bug #103250.
diff --git a/sci-astronomy/setiathome/files/digest-setiathome-4.18-r1 b/sci-astronomy/setiathome/files/digest-setiathome-4.18-r1
index 354c8dd8e440..5b31dfb8e7bb 100644
--- a/sci-astronomy/setiathome/files/digest-setiathome-4.18-r1
+++ b/sci-astronomy/setiathome/files/digest-setiathome-4.18-r1
@@ -1,2 +1,6 @@
MD5 af114631d61e117de9bafa197864a8ff boinc_public-cvs-2005-08-13.tar.gz 6054534
+RMD160 2585effd13c1b6e093141dbc34bebd770c6041be boinc_public-cvs-2005-08-13.tar.gz 6054534
+SHA256 3a8b7f3d462a0fa5f1d0ad14c77f790a3cf12b1237a09636cd82b9bfefc2afb7 boinc_public-cvs-2005-08-13.tar.gz 6054534
MD5 f0c57d5713071b167582228d07d82621 seti_boinc-client-cvs-2005-08-20.tar.gz 1861233
+RMD160 e3fa7c2acdeba61c404fd024e290057d97337be7 seti_boinc-client-cvs-2005-08-20.tar.gz 1861233
+SHA256 964b5195f9b69c99518d46e4057b10b3c42b5c54f26fd549dec7c70f16db815d seti_boinc-client-cvs-2005-08-20.tar.gz 1861233
diff --git a/sci-astronomy/setiathome/files/setiathome-4.18-gcc41.patch b/sci-astronomy/setiathome/files/setiathome-4.18-gcc41.patch
new file mode 100644
index 000000000000..f157442e9fec
--- /dev/null
+++ b/sci-astronomy/setiathome/files/setiathome-4.18-gcc41.patch
@@ -0,0 +1,11 @@
+--- db/sqlblob.h.orig 2006-05-05 14:16:53.000000000 +0200
++++ db/sqlblob.h 2006-05-05 14:17:42.000000000 +0200
+@@ -68,7 +68,7 @@
+ start=end+1;
+ end=buf.find(tag);
+ if (b.mem) delete(b.mem);
+- b.mem=new std::vector<T>(xml_decode_string(buf.c_str()+start,end-start,enc_string));
++ b.mem=new std::vector<T>(xml_decode_string<T>(buf.c_str()+start,end-start,enc_string));
+ return i;
+ }
+
diff --git a/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild b/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
index 2f432e2b9597..0be36cf0f415 100644
--- a/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
+++ b/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild,v 1.4 2006/04/23 03:16:11 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild,v 1.5 2006/05/18 17:58:11 halcy0n Exp $
+
+inherit eutils
MY_PN="seti_boinc-client-cvs"
MY_PV="2005-08-20"
@@ -22,6 +24,13 @@ DEPEND="~sci-misc/boinc-4.72.20050813
S=${WORKDIR}/seti_boinc
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
# The setiathome GUI doesn't work - so disable it for now...
econf BOINCDIR=${WORKDIR}/boinc_public \