summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 01:33:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 01:33:30 +0000
commit61b02029639264d5e4896b7571c46d1d8caeabf6 (patch)
treedc6a10a1349b31de3451ab0d970db95483c505c0 /net-zope/zconfig
parentDelete older ebuild. (diff)
downloadgentoo-2-61b02029639264d5e4896b7571c46d1d8caeabf6.tar.gz
gentoo-2-61b02029639264d5e4896b7571c46d1d8caeabf6.tar.bz2
gentoo-2-61b02029639264d5e4896b7571c46d1d8caeabf6.zip
Version bump.
(Portage version: 2.2.0_alpha28_p7/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zconfig')
-rw-r--r--net-zope/zconfig/ChangeLog10
-rw-r--r--net-zope/zconfig/zconfig-2.9.0.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/net-zope/zconfig/ChangeLog b/net-zope/zconfig/ChangeLog
index d135b60ea08c..48f45d1f98d4 100644
--- a/net-zope/zconfig/ChangeLog
+++ b/net-zope/zconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zconfig
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/ChangeLog,v 1.5 2010/04/18 00:54:07 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/ChangeLog,v 1.6 2011/03/25 01:33:30 arfrever Exp $
+
+*zconfig-2.9.0 (25 Mar 2011)
+
+ 25 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zconfig-2.9.0.ebuild:
+ Version bump.
*zconfig-2.8.0 (18 Apr 2010)
diff --git a/net-zope/zconfig/zconfig-2.9.0.ebuild b/net-zope/zconfig/zconfig-2.9.0.ebuild
new file mode 100644
index 000000000000..7ba7625a57eb
--- /dev/null
+++ b/net-zope/zconfig/zconfig-2.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/zconfig-2.9.0.ebuild,v 1.1 2011/03/25 01:33:30 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="ZConfig"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Structured Configuration Library"
+HOMEPAGE="http://pypi.python.org/pypi/ZConfig"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ test? ( net-zope/zope-testing )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="NEWS.txt README.txt"
+PYTHON_MODNAME="${MY_PN}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.7.1-fix_tests.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ rm -fr "${ED}"usr/$(get_libdir)/python*/site-packages/ZConfig/tests
+}