summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-08-23 00:25:28 +0000
committerJim Ramsay <lack@gentoo.org>2008-08-23 00:25:28 +0000
commitdf88644a941d290cab6171770fce6d97b225bd5b (patch)
treeb6f3cc5e2ca0fc268b8b244d5e0c6fd8c1fe6837 /net-www
parentBump to kvm-73 (diff)
downloadgentoo-2-df88644a941d290cab6171770fce6d97b225bd5b.tar.gz
gentoo-2-df88644a941d290cab6171770fce6d97b225bd5b.tar.bz2
gentoo-2-df88644a941d290cab6171770fce6d97b225bd5b.zip
Version bump (Bug #234542)
(Portage version: 2.2_rc4/cvs/Linux 2.6.24-gentoo x86_64)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/netscape-flash/ChangeLog8
-rw-r--r--net-www/netscape-flash/netscape-flash-10_beta20080811.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 5b466edffce4..fdebbd897488 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.69 2008/07/03 13:42:46 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.70 2008/08/23 00:25:28 lack Exp $
+
+*netscape-flash-10_beta20080811 (22 Aug 2008)
+
+ 22 Aug 2008; Jim Ramsay <lack@gentoo.org>
+ +netscape-flash-10_beta20080811.ebuild:
+ Version bump (Bug #234542)
*netscape-flash-10_beta20080702 (03 Jul 2008)
diff --git a/net-www/netscape-flash/netscape-flash-10_beta20080811.ebuild b/net-www/netscape-flash/netscape-flash-10_beta20080811.ebuild
new file mode 100644
index 000000000000..8d3582fdd88d
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-10_beta20080811.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10_beta20080811.ebuild,v 1.1 2008/08/23 00:25:28 lack Exp $
+
+inherit nsplugins versionator
+
+MV=$(get_major_version)
+
+# Excellent, Adobe uses that unsortable though surprisingly popular date
+# convention "MMDDYY", so build that out of a proper "YYYYMMDD" beta version
+# component:
+BETA=$(get_version_component_range 2)
+BETA=${BETA#beta}
+BV=${BETA:4:2}${BETA:6:2}${BETA:2:2}
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://download.macromedia.com/pub/labs/flashplayer${MV}/flashplayer${MV}_install_linux_${BV}.tar.gz"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+RESTRICT="strip mirror"
+
+S="${WORKDIR}/install_flash_player_${MV}_linux"
+
+DEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs
+ net-libs/xulrunner-bin )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig
+ dev-libs/nss
+ net-misc/curl
+ >=sys-libs/glibc-2.4 )
+ app-text/acroread
+ media-fonts/corefonts"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+
+ # This version especially is ugly in that it hard-requires libcurl.so.3. On
+ # x86 systems, we could just symlink to libcurl.so.4, but by using acroread
+ # to provide the needed libs we have a single solution that works for both
+ # amd64 and x86, which I like marginally better.
+ echo 'LDPATH="/opt/Adobe/Reader8/Reader/intellinux/lib"' > 99flash-10-libhack
+ doenvd 99flash-10-libhack
+
+ # Apparently the next release will dynamically check for libcurl.so.4 and
+ # libcurl.so.3, so this will be much less ugly (especially if we can get
+ # libcurl into one of the emul-linux-x86 packages).
+}
+
+pkg_postinst() {
+ ewarn "Flash player is closed-source, with a long history of security"
+ ewarn "issues. Please consider only running flash applets you know to"
+ ewarn "be safe. The firefox 'flashblock' extension may help:"
+ ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
+}