summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-03-09 01:39:35 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-03-09 01:39:35 +0000
commitca47206b68e8ce15512b19a99fb129abc4a0d93e (patch)
tree1d2d56f2a5154622bdce2b3e6facfcae152765e4 /net-www
parentrevert back to unstable (diff)
downloadgentoo-2-ca47206b68e8ce15512b19a99fb129abc4a0d93e.tar.gz
gentoo-2-ca47206b68e8ce15512b19a99fb129abc4a0d93e.tar.bz2
gentoo-2-ca47206b68e8ce15512b19a99fb129abc4a0d93e.zip
Version bump.
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/nspluginwrapper/ChangeLog8
-rw-r--r--net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.33
-rw-r--r--net-www/nspluginwrapper/nspluginwrapper-0.9.91.3.ebuild65
3 files changed, 75 insertions, 1 deletions
diff --git a/net-www/nspluginwrapper/ChangeLog b/net-www/nspluginwrapper/ChangeLog
index 4aaecdfee4db..ab0113f6efa6 100644
--- a/net-www/nspluginwrapper/ChangeLog
+++ b/net-www/nspluginwrapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/nspluginwrapper
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.10 2007/01/08 02:28:17 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.11 2007/03/09 01:39:35 chutzpah Exp $
+
+*nspluginwrapper-0.9.91.3 (09 Mar 2007)
+
+ 09 Mar 2007; Patrick McLean <chutzpah@gentoo.org>
+ +nspluginwrapper-0.9.91.3.ebuild:
+ Version bump.
08 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
-nspluginwrapper-0.9.90.4.ebuild, nspluginwrapper-0.9.91.2.ebuild:
diff --git a/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.3 b/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.3
new file mode 100644
index 000000000000..1e816816fa8f
--- /dev/null
+++ b/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.3
@@ -0,0 +1,3 @@
+MD5 0e047db84a979237fb28a9e8360890b0 nspluginwrapper-0.9.91.3.tar.bz2 257648
+RMD160 660d928b508c342003f9ff3483ce8b8d25919e90 nspluginwrapper-0.9.91.3.tar.bz2 257648
+SHA256 3672dcf615f0a0c4a4bafc6e97cd134ad84ea402f916d0c3accff8e9a0aa6c8e nspluginwrapper-0.9.91.3.tar.bz2 257648
diff --git a/net-www/nspluginwrapper/nspluginwrapper-0.9.91.3.ebuild b/net-www/nspluginwrapper/nspluginwrapper-0.9.91.3.ebuild
new file mode 100644
index 000000000000..7341ae3df8cf
--- /dev/null
+++ b/net-www/nspluginwrapper/nspluginwrapper-0.9.91.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-0.9.91.3.ebuild,v 1.1 2007/03/09 01:39:35 chutzpah Exp $
+
+inherit nsplugins flag-o-matic multilib
+
+DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
+HOMEPAGE="http://www.gibix.net/projects/nspluginwrapper/"
+SRC_URI="http://www.gibix.net/projects/nspluginwrapper/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-gtklibs
+ sys-apps/setarch"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --with-biarch \
+ --with-lib32=$(ABI=x86 get_libdir) \
+ --with-lib64=$(get_libdir) \
+ --pkglibdir=/usr/$(get_libdir)/${PN} || die
+ emake || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" DONT_STRIP=yes install || die
+
+ inst_plugin /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npwrapper.so
+ dosym /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npconfig /usr/bin/nspluginwrapper
+
+ dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ einfo "Auto installing 32bit plugins..."
+ nspluginwrapper -a -i
+ elog "Any 32bit plugins you currently have installed have now been"
+ elog "configured to work in a 64bit browser. Any plugins you install in"
+ elog "the future will first need to be setup with:"
+ elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
+ elog "before they will function in a 64bit browser"
+ elog
+}
+
+# this is terribly ugly, but without a way to query portage as to whether
+# we are upgrading/reinstalling a package versus unmerging, I can't think of
+# a better way
+
+pkg_prerm() {
+ einfo "Removing wrapper plugins..."
+ nspluginwrapper -a -r
+}
+
+pkg_postrm() {
+ if [[ -x /usr/bin/nspluginwrapper ]]; then
+ einfo "Auto installing 32bit plugins..."
+ nspluginwrapper -a -i
+ fi
+}