summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-07 16:28:20 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-07 16:28:20 +0000
commita1b4499a9b7db79b5272b565b6aaff676fa11aa3 (patch)
tree43c2d9292be822f986d35d72788ee2ace40b0c56 /net-www
parentRemove xmms useflag in view of the removal of xmms later this month. (diff)
downloadgentoo-2-a1b4499a9b7db79b5272b565b6aaff676fa11aa3.tar.gz
gentoo-2-a1b4499a9b7db79b5272b565b6aaff676fa11aa3.tar.bz2
gentoo-2-a1b4499a9b7db79b5272b565b6aaff676fa11aa3.zip
make cvs ebuild working again based on my prepared ebuild for 0.7.2
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/ChangeLog10
-rw-r--r--net-www/gnash/gnash-0.7.1_p20099999.ebuild59
2 files changed, 38 insertions, 31 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index b6613b6bbb21..bbba2da64e7e 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.23 2006/10/20 19:35:37 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.24 2006/11/07 16:28:20 genstef Exp $
+
+ 07 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ gnash-0.7.1_p20099999.ebuild:
+ make cvs ebuild working again based on my prepared ebuild for 0.7.2
+
+ 07 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ gnash-0.7.1_p20099999.ebuild:
+ make cvs ebuild working again based on my prepared ebuild for 0.7.2
20 Oct 2006; Stefan Schweizer <genstef@gentoo.org>
gnash-0.7.1_p20099999.ebuild:
diff --git a/net-www/gnash/gnash-0.7.1_p20099999.ebuild b/net-www/gnash/gnash-0.7.1_p20099999.ebuild
index 250e07db6708..c7976f642c64 100644
--- a/net-www/gnash/gnash-0.7.1_p20099999.ebuild
+++ b/net-www/gnash/gnash-0.7.1_p20099999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1_p20099999.ebuild,v 1.4 2006/10/20 19:35:37 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1_p20099999.ebuild,v 1.5 2006/11/07 16:28:20 genstef Exp $
-inherit nsplugins kde-functions autotools cvs
+inherit nsplugins autotools cvs
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -16,25 +16,29 @@ S=${WORKDIR}/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-*"
-IUSE="gstreamer mad nsplugin nptl xml kde video_cards_i810"
+IUSE="agg gstreamer ffmpeg nsplugin xml video_cards_i810"
#dmalloc, broken see bug 142939
#dmalloc? ( dev-libs/dmalloc )
# $(use_enable dmalloc) \
RDEPEND="
xml? ( dev-libs/libxml2 )
- kde? (
- kde-base/kdelibs
- x11-libs/qt
- )
sys-libs/zlib
media-libs/jpeg
- mad? ( media-libs/libmad )
media-libs/libogg
media-libs/libpng
- media-libs/libsdl
net-misc/curl
- virtual/opengl
+ !ffmpeg? ( media-libs/libmad )
+ ffmpeg? ( media-video/ffmpeg )
+ gstreamer? ( media-libs/gstreamer
+ || (
+ media-plugins/gst-plugins-ffmpeg
+ media-plugins/gst-plugins-mad
+ media-plugins/gst-plugins-lame
+ )
+ )
+ !gstreamer? ( media-libs/libsdl )
+ dev-libs/boost
|| (
( x11-libs/libX11
x11-libs/libXi
@@ -43,34 +47,26 @@ RDEPEND="
x11-proto/xproto )
virtual/x11
)
- gstreamer? ( media-libs/gstreamer )
- !gstreamer? ( media-libs/sdl-mixer )
dev-libs/atk
dev-libs/glib
>x11-libs/gtk+-2
x11-libs/pango
- dev-libs/boost
- x11-libs/gtkglext"
+ !agg? ( virtual/opengl x11-libs/gtkglext )
+ agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
-set-kdedir
-
src_unpack() {
cvs_src_unpack
cd ${S}
-
- # enable sound by default
- ssed="bool.*do_sound[ \t]*=[ \t]*"
- grep "${ssed}" . -rl | xargs \
- sed -i -e "s:\(${ssed}\)false:\1true:"
-
- AT_M4DIR="macros" eautoreconf
+ AT_M4DIR=macros AT_NO_RECURSIVE=1 eautoreconf
+ cd libltdl
+ eautoreconf
}
src_compile() {
local myconf
- use nsplugin && myconf="${myconf} --enable-plugin --with-plugindir=/opt/netscape/plugins"
+ use nsplugin && myconf="${myconf} --with-plugindir=/opt/netscape/plugins"
#--enable-renderer=engine Specify rendering engine:
# OpenGL (default)
@@ -79,6 +75,9 @@ src_compile() {
#if use cairo; then
# myconf="${myconf} --enable-renderer=cairo"
#fi
+ if use agg; then
+ myconf="${myconf} --enable-renderer=agg"
+ fi
#--enable-gui=flavor Specify gui flavor:
# GTK
# SDL -> has no controls, we do not USE it
@@ -90,19 +89,19 @@ src_compile() {
myconf="${myconf} --enable-sound=sdl"
fi
- if use kde; then
- myconf="${myconf} --enable-gui=KDE"
+ if use ffmpeg; then
+ myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
+ # klash is broken, thus we do not offer it
econf \
- $(use_enable kde klash) \
- $(use_enable mad mp3) \
- $(use_enable nptl pthreads) \
+ $(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
+ --disable-klash \
${myconf} || die "econf failed"
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {