summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-08-08 01:32:53 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-08-08 01:32:53 +0000
commit1ed0f6c9df44ccb91b0e0515cac5d0d39cf585e1 (patch)
tree36658162031af5bdecd7c3dac6091512d619505e /net-www
parentinitial ebuild (diff)
downloadgentoo-2-1ed0f6c9df44ccb91b0e0515cac5d0d39cf585e1.tar.gz
gentoo-2-1ed0f6c9df44ccb91b0e0515cac5d0d39cf585e1.tar.bz2
gentoo-2-1ed0f6c9df44ccb91b0e0515cac5d0d39cf585e1.zip
Fixed titlebar icons and added desktop icons.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/dillo/ChangeLog8
-rw-r--r--net-www/dillo/Manifest6
-rw-r--r--net-www/dillo/dillo-0.7.3-r1.ebuild102
-rw-r--r--net-www/dillo/dillo-0.7.3.ebuild4
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.3-r12
5 files changed, 117 insertions, 5 deletions
diff --git a/net-www/dillo/ChangeLog b/net-www/dillo/ChangeLog
index 6007efa91c9a..bdd028fd356b 100644
--- a/net-www/dillo/ChangeLog
+++ b/net-www/dillo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/dillo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.20 2003/08/07 20:07:57 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.21 2003/08/08 01:32:34 bcowan Exp $
+
+*dillo-0.7.3-r1 (07 Aug 2003)
+
+ 07 Aug 2003; Brad Cowan <bcowan@gentoo.org> dillo-0.7.3-r1.ebuild,
+ dillo-0.7.3.ebuild:
+ Fixed titlebar icons and added desktop icons.
*dillo-0.7.3 (07 Aug 2003)
diff --git a/net-www/dillo/Manifest b/net-www/dillo/Manifest
index 4849b80d9413..a6b38bc064c9 100644
--- a/net-www/dillo/Manifest
+++ b/net-www/dillo/Manifest
@@ -1,11 +1,13 @@
MD5 8bcbeb7159eece4089d8ee32ff7e9f13 dillo-0.7.1.2.ebuild 2626
MD5 bc617827cd8905f25370512ef9820a17 dillo-0.6.6-r3.ebuild 1825
-MD5 7260ba02a80822c1b58e9939d5b41c35 dillo-0.7.3.ebuild 2607
+MD5 3ae0b6d31b4688bcd206854bb7115a2a dillo-0.7.3.ebuild 2589
MD5 c16761beed57dcf79ee9788e94d8ddfa dillo-0.7.2.ebuild 2617
-MD5 a74ae09b007ba0820b9d5dc38b3b77e2 ChangeLog 3274
+MD5 0b312b0eb4189f9471a41d7b04ab9100 ChangeLog 3445
MD5 bb024c046663310fea23f507727ceb3e dillo-0.6.6-r1.ebuild 1752
+MD5 ac23223bf52a421407977104e34cafcc dillo-0.7.3-r1.ebuild 2689
MD5 8ef69023a009d501ca2eeb936019c3b7 files/digest-dillo-0.7.2 141
MD5 984074748b7502f94e80310c5cc609e6 files/digest-dillo-0.7.3 141
MD5 5decce9a16842c213d1ca6790768de4e files/digest-dillo-0.7.1.2 142
MD5 7195171b7f074adc1f5f496fceaa8919 files/digest-dillo-0.6.6-r1 133
MD5 87c4d5f926ddf281a2470cb024eb11b9 files/digest-dillo-0.6.6-r3 140
+MD5 228c86b4db650b4d95d9ccbe853cecce files/digest-dillo-0.7.3-r1 142
diff --git a/net-www/dillo/dillo-0.7.3-r1.ebuild b/net-www/dillo/dillo-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..6c9394d8d713
--- /dev/null
+++ b/net-www/dillo/dillo-0.7.3-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r1.ebuild,v 1.1 2003/08/08 01:32:34 bcowan Exp $
+
+inherit flag-o-matic
+
+IUSE="ipv6 kde gnome mozilla"
+
+S=${WORKDIR}/${P}
+S2=${WORKDIR}/dillo-gentoo-extras-patch3
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://dillo.auriga.wearlab.de/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc ~alpha ~mips ~hppa"
+
+replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ ebegin "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ ebegin "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ ebegin "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ ebegin "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ ebegin "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ eend 0
+ else
+ ebegin "Using default Dillo icon set"
+ eend 0
+ fi
+}
+
+src_compile() {
+ econf `use_enable ipv6` || die
+ emake || make || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ einstall
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/net-www/dillo/dillo-0.7.3.ebuild b/net-www/dillo/dillo-0.7.3.ebuild
index b349dd0be0c5..18c2ee0b0d42 100644
--- a/net-www/dillo/dillo-0.7.3.ebuild
+++ b/net-www/dillo/dillo-0.7.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3.ebuild,v 1.1 2003/08/07 20:07:57 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3.ebuild,v 1.2 2003/08/08 01:32:34 bcowan Exp $
inherit flag-o-matic
-IUSE="ipv6 kde gnome mozilla"
+IUSE="ipv6"
S=${WORKDIR}/${P}
S2=${WORKDIR}/gentoo-dillo-extras-patch
diff --git a/net-www/dillo/files/digest-dillo-0.7.3-r1 b/net-www/dillo/files/digest-dillo-0.7.3-r1
new file mode 100644
index 000000000000..7d85e0e54a69
--- /dev/null
+++ b/net-www/dillo/files/digest-dillo-0.7.3-r1
@@ -0,0 +1,2 @@
+MD5 896f4d8c752b86376bfb445740f01470 dillo-0.7.3.tar.bz2 345295
+MD5 3bc2370883e41905791f94f0b8e2f79b dillo-gentoo-extras-patch3.tar.bz2 86929