summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-09-05 19:06:38 +0000
committerJim Ramsay <lack@gentoo.org>2007-09-05 19:06:38 +0000
commit1208063ea4ef6d32e8f58dc6c7ff01250b4ae249 (patch)
tree643dd9a726534e5a500c762bd8ba7c131109a532 /net-www
parentMasking new beta netscape-flash build because of flaky behaviour. But still ... (diff)
downloadgentoo-2-1208063ea4ef6d32e8f58dc6c7ff01250b4ae249.tar.gz
gentoo-2-1208063ea4ef6d32e8f58dc6c7ff01250b4ae249.tar.bz2
gentoo-2-1208063ea4ef6d32e8f58dc6c7ff01250b4ae249.zip
Adding the beta release with h.264 support (bug 189833)
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/netscape-flash/ChangeLog8
-rw-r--r--net-www/netscape-flash/files/digest-netscape-flash-9.0.60.0_beta0822073
-rw-r--r--net-www/netscape-flash/netscape-flash-9.0.60.0_beta082207.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 19d523fb367a..e02570c98228 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.56 2007/07/19 16:48:16 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.57 2007/09/05 19:06:38 lack Exp $
+
+*netscape-flash-9.0.60.0_beta082207 (05 Sep 2007)
+
+ 05 Sep 2007; Jim Ramsay <lack@gentoo.org>
+ +netscape-flash-9.0.60.0_beta082207.ebuild:
+ Adding the beta release with h.264 support (bug 189833)
*netscape-flash-9.0.48.0-r1 (19 Jul 2007)
diff --git a/net-www/netscape-flash/files/digest-netscape-flash-9.0.60.0_beta082207 b/net-www/netscape-flash/files/digest-netscape-flash-9.0.60.0_beta082207
new file mode 100644
index 000000000000..50edca461693
--- /dev/null
+++ b/net-www/netscape-flash/files/digest-netscape-flash-9.0.60.0_beta082207
@@ -0,0 +1,3 @@
+MD5 80efe45d4347403891d25cbabe0bc625 flashplayer9_install_linux_082207.tar.gz 3001031
+RMD160 1c5fb6f25944823023dc48caa8932d16cbfd4d4b flashplayer9_install_linux_082207.tar.gz 3001031
+SHA256 2aaef3a540342b7f9eedd21797e6d2b33d2335d641a9935e17aa366b714d6d42 flashplayer9_install_linux_082207.tar.gz 3001031
diff --git a/net-www/netscape-flash/netscape-flash-9.0.60.0_beta082207.ebuild b/net-www/netscape-flash/netscape-flash-9.0.60.0_beta082207.ebuild
new file mode 100644
index 000000000000..d6eff244927a
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-9.0.60.0_beta082207.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-9.0.60.0_beta082207.ebuild,v 1.1 2007/09/05 19:06:38 lack Exp $
+
+inherit nsplugins versionator
+
+MY_BETADATE=$(get_version_component_range 5)
+MY_PV=${MY_BETADATE:4}
+MY_P="install_flash_player_9_linux"
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://download.macromedia.com/pub/labs/flashplayer9_update/flashplayer9_install_linux_${MY_PV}.tar.gz"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+S=${WORKDIR}/${MY_P}
+RESTRICT="strip mirror"
+
+DEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig )"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ cd ${MY_P}
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+}
+
+pkg_postinst() {
+ elog "This is a trimmed-down BETA version of flashplayer."
+ elog "It only includes the netscape plugin, not the standalone"
+ elog "'flashplayer' executable. If you need the standalone player,"
+ elog "you must downgrade to the previous version."
+ ewarn "This BETA version has a number of known bugs (so far minor),"
+ ewarn "which is why it is package masked. You have been warned."
+}