summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-16 19:54:12 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-16 19:54:12 +0000
commit67f7dc228f44e062cfbecb294d8fc1beff7e21cf (patch)
tree3d9e87e38b9a5371313c18bddc19e36acb81b194 /net-www/tux/tux-2.2.7.ebuild
parentuse mirror:// in SRC_URI (diff)
downloadgentoo-2-67f7dc228f44e062cfbecb294d8fc1beff7e21cf.tar.gz
gentoo-2-67f7dc228f44e062cfbecb294d8fc1beff7e21cf.tar.bz2
gentoo-2-67f7dc228f44e062cfbecb294d8fc1beff7e21cf.zip
initial ebuild
Diffstat (limited to 'net-www/tux/tux-2.2.7.ebuild')
-rw-r--r--net-www/tux/tux-2.2.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-www/tux/tux-2.2.7.ebuild b/net-www/tux/tux-2.2.7.ebuild
new file mode 100644
index 000000000000..1737a730db55
--- /dev/null
+++ b/net-www/tux/tux-2.2.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/tux/tux-2.2.7.ebuild,v 1.1 2003/06/16 19:54:02 vapier Exp $
+
+DESCRIPTION="kernel level httpd"
+HOMEPAGE="http://people.redhat.com/mingo/TUX-patches/"
+SRC_URI="http://people.redhat.com/mingo/TUX-patches/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-libs/glib
+ dev-libs/popt"
+
+src_compile() {
+ emake tux tux2w3c tuxstat TMPDIR=${T} || die
+}
+
+src_install() {
+ make install TOPDIR=${D} || die
+ rm -rf ${D}/etc/{rc.d,sysconfig} ${D}/var/tux
+ exeinto /etc/init.d ; newexe ${FILESDIR}/tux.init.d tux
+ insinto /etc/conf.d ; newins ${FILESDIR}/tux.conf.d tux
+
+ dodoc NEWS SUCCESS tux.README docs/*.txt
+ docinto samples
+ dodoc samples/* demo*.c
+}