summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2004-07-22 01:33:02 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2004-07-22 01:33:02 +0000
commit7ce1dd9c19d8fff37c585f4d2bc30f873399c7aa (patch)
tree20c67f41c0de7780833a4cc3a98b86092edb8212 /net-www/mplayerplug-in
parentMarked stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-7ce1dd9c19d8fff37c585f4d2bc30f873399c7aa.tar.gz
gentoo-2-7ce1dd9c19d8fff37c585f4d2bc30f873399c7aa.tar.bz2
gentoo-2-7ce1dd9c19d8fff37c585f4d2bc30f873399c7aa.zip
Adding GTK1 support
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog7
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild23
2 files changed, 25 insertions, 5 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 844614924fd1..efc8a715db96 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.25 2004/06/25 01:06:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.26 2004/07/22 01:33:02 jbms Exp $
+
+ 18 Jul 2004; Jeremy Maitin-Shepard <jbms@gentoo.org>
+ mplayerplug-in-2.66.ebuild:
+ Added support for GTK1, so that the plugin works with mozilla browsers built
+ against GTK1
*mplayerplug-in-2.66 (20 Jun 2004)
diff --git a/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild b/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
index ebb599f2d0cb..ae6b561496bf 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild,v 1.2 2004/06/25 01:06:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild,v 1.3 2004/07/22 01:33:02 jbms Exp $
inherit nsplugins
@@ -15,13 +15,28 @@ HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~sparc ~alpha ~hppa ~mips"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=media-video/mplayer-0.92"
+IUSE="gtk2"
+
+DEPEND=">=media-video/mplayer-0.92
+ gtk2? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1 )
+ !gtk2? (
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )"
src_compile() {
local myconf
use x86 && myconf="${myconf} --with-gecko-sdk=${WORKDIR}/gecko-sdk"
+ if use gtk2; then
+ einfo Configuring to build using gtk2
+ myconf="${myconf} --enable-gtk2"
+ else
+ einfo Configuring to build using gtk1
+ myconf="${myconf} --disable-gtk2 --enable-gtk1"
+ fi
econf ${myconf} || die
emake || die
}