summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2004-11-03 15:31:52 +0000
committerMarkus Rothe <corsair@gentoo.org>2004-11-03 15:31:52 +0000
commit5672f3156bfb80095bc72e190a5173b5c31459c7 (patch)
tree486f5184dc8dc1d4c4e26e049b034d04597334ee /net-www/gplflash
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-5672f3156bfb80095bc72e190a5173b5c31459c7.tar.gz
gentoo-2-5672f3156bfb80095bc72e190a5173b5c31459c7.tar.bz2
gentoo-2-5672f3156bfb80095bc72e190a5173b5c31459c7.zip
version bumb
Diffstat (limited to 'net-www/gplflash')
-rw-r--r--net-www/gplflash/ChangeLog7
-rw-r--r--net-www/gplflash/Manifest4
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.121
-rw-r--r--net-www/gplflash/gplflash-0.4.12.ebuild51
4 files changed, 61 insertions, 2 deletions
diff --git a/net-www/gplflash/ChangeLog b/net-www/gplflash/ChangeLog
index abae03daa793..0bbdfa77a12c 100644
--- a/net-www/gplflash/ChangeLog
+++ b/net-www/gplflash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/gplflash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.14 2004/06/25 00:53:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.15 2004/11/03 15:31:52 corsair Exp $
+
+*gplflash-0.4.12 (03 Nov 2004)
+
+ 03 Nov 2004; Markus Rothe <corsair@gentoo.org> +gplflash-0.4.12.ebuild:
+ Version bumb; won't work on ppc64 -> -ppc64
03 Oct 2003; Joel Hill <hillster@gentoo.org> gplflash-0.4.10-r3.ebuild:
added einfo regarding support only for older flash and also changed
diff --git a/net-www/gplflash/Manifest b/net-www/gplflash/Manifest
index 21edee78d21d..efac96f4aec7 100644
--- a/net-www/gplflash/Manifest
+++ b/net-www/gplflash/Manifest
@@ -1,6 +1,8 @@
MD5 82e01333869fbb6cf92f524266bbf829 ChangeLog 2064
MD5 b77d6f11ab00bbbc4a435e2362492dc5 gplflash-0.4.10-r3.ebuild 1259
+MD5 4b156d1c7e7a95a556beb501ac241cea gplflash-0.4.12.ebuild 1172
+MD5 37d2d7738b1e06fcb5c161ffce30f238 files/digest-gplflash-0.4.10-r3 61
MD5 986f1d69944d8e520137dd61e3c480ed files/gplflash-0.4.10-fPIC.patch 2011
MD5 4e51ed812f940be98742997fee035846 files/gplflash-0.4.10-gcc3-gentoo.diff 1060
MD5 1560bb78cb5b479b310c1604fb1b46da files/gplflash-0.4.10-ppc.diff 2018
-MD5 37d2d7738b1e06fcb5c161ffce30f238 files/digest-gplflash-0.4.10-r3 61
+MD5 1318f3bcf0259626c50162947f7eb7d5 files/digest-gplflash-0.4.12 68
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.12 b/net-www/gplflash/files/digest-gplflash-0.4.12
new file mode 100644
index 000000000000..2dd067bdd288
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.12
@@ -0,0 +1 @@
+MD5 7d53803486b255665a80cd834ee3c463 gplflash-0.4.12.tar.bz2 378727
diff --git a/net-www/gplflash/gplflash-0.4.12.ebuild b/net-www/gplflash/gplflash-0.4.12.ebuild
new file mode 100644
index 000000000000..bde5f4cd5373
--- /dev/null
+++ b/net-www/gplflash/gplflash-0.4.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/gplflash-0.4.12.ebuild,v 1.1 2004/11/03 15:31:52 corsair Exp $
+
+inherit nsplugins eutils flag-o-matic
+
+DESCRIPTION="GPLFlash is a free portable and useable alternative to the
+ flash-decoder released by Macromedia"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gplflash.sourceforge.net/"
+
+KEYWORDS="-ppc64 ~x86 ~ppc ~sparc ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="debug alsa oss"
+
+RDEPEND="media-libs/libmad
+ media-libs/jpeg
+ sys-libs/zlib
+ virtual/x11
+ !net-www/netscape-flash
+ !media-libs/libflash"
+
+PLUGDIR="/opt/netscape/plugins"
+
+src_compile() {
+ # check if sound support is wanted
+ if ( ( use !alsa ) && ( use !oss ) ); then
+ einfo "you don't have alsa or oss in your use flags."
+ einfo "disabling sound support..."
+ append-flags -DNOSOUND
+ fi
+
+ # configure
+ econf --with-plugin-dir=${D}/${PLUGDIR} $(use_enable debug) \
+ || die "configure failed"
+
+ # compile
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ # install the plugin
+ inst_plugin ${PLUGDIR}/libnpflash.so
+
+ # install doc
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}