summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-06-30 02:41:03 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-06-30 02:41:03 +0000
commit1d7532a8228069d45d4ea2a6334907c3dc06c785 (patch)
treec101f3d1e6184b0d4fde33b3acada1276534ed54 /net-www/gplflash
parentmasked gplflash-0.4.10-r1 until it's known to work with gcc2 (diff)
downloadgentoo-2-1d7532a8228069d45d4ea2a6334907c3dc06c785.tar.gz
gentoo-2-1d7532a8228069d45d4ea2a6334907c3dc06c785.tar.bz2
gentoo-2-1d7532a8228069d45d4ea2a6334907c3dc06c785.zip
new support for gcc3 etc.
Diffstat (limited to 'net-www/gplflash')
-rw-r--r--net-www/gplflash/ChangeLog11
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.10-r11
-rw-r--r--net-www/gplflash/files/gplflash-0.4.10-gcc3-gentoo.diff33
-rw-r--r--net-www/gplflash/gplflash-0.4.10-r1.ebuild40
4 files changed, 85 insertions, 0 deletions
diff --git a/net-www/gplflash/ChangeLog b/net-www/gplflash/ChangeLog
new file mode 100644
index 000000000000..e34af11995f0
--- /dev/null
+++ b/net-www/gplflash/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-www/gplflash
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gplflash/ChangeLog,v 1.1 2002/06/30 02:41:03 mkennedy Exp $
+
+*gplflash-0.4.10-r1 (29 Jun 2002)
+
+ 29 Jun 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ gplflash-0.4.10-r1.ebuild :
+
+ Added missing ChangeLog, lintool fixups, patch for GCC3.1 support
+ (thanks to José Fonseca <j_r_fonseca@yahoo.co.uk> of bug #4134).
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.10-r1 b/net-www/gplflash/files/digest-gplflash-0.4.10-r1
new file mode 100644
index 000000000000..559fd82f09cb
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.10-r1
@@ -0,0 +1 @@
+MD5 1473f085c599d8076fa866cd91e11598 flash-0.4.10.tgz 358995
diff --git a/net-www/gplflash/files/gplflash-0.4.10-gcc3-gentoo.diff b/net-www/gplflash/files/gplflash-0.4.10-gcc3-gentoo.diff
new file mode 100644
index 000000000000..a19f6fcf0408
--- /dev/null
+++ b/net-www/gplflash/files/gplflash-0.4.10-gcc3-gentoo.diff
@@ -0,0 +1,33 @@
+diff -u -r flash-0.4.10.old/Lib/shape.cc flash-0.4.10/Lib/shape.cc
+--- flash-0.4.10.old/Lib/shape.cc Wed Jun 7 19:11:08 2000
++++ flash-0.4.10/Lib/shape.cc Tue Jun 25 12:03:56 2002
+@@ -22,6 +22,8 @@
+
+ #include "swf.h"
+
++#include <math.h>
++
+ #ifdef RCSID
+ static char *rcsid = "$Id: gplflash-0.4.10-gcc3-gentoo.diff,v 1.1 2002/06/30 02:41:02 mkennedy Exp $";
+ #endif
+diff -u -r flash-0.4.10.old/Makefile flash-0.4.10/Makefile
+--- flash-0.4.10.old/Makefile Mon Jun 12 09:19:14 2000
++++ flash-0.4.10/Makefile Tue Jun 25 12:00:07 2002
+@@ -1,4 +1,4 @@
+-SUBDIRS= Jpeg Zlib Lib Player Plugin Kflash
++SUBDIRS= Jpeg Zlib Lib Player Plugin
+
+ all:
+ for subdir in $(SUBDIRS); do (cd $$subdir; $(MAKE)); done
+diff -u -r flash-0.4.10.old/Player/Makefile flash-0.4.10/Player/Makefile
+--- flash-0.4.10.old/Player/Makefile Wed Jun 7 19:19:50 2000
++++ flash-0.4.10/Player/Makefile Tue Jun 25 12:09:34 2002
+@@ -1,7 +1,7 @@
+ FLASH=../Lib
+ CPPFLAGS=-I$(FLASH)
+ CFLAGS=-O3
+-LIBS = $(FLASH)/libflash.a ../Zlib/libz.a ../Jpeg/libjpeg.a -L/usr/X11R6/lib -lX11 -lXext -lm
++LIBS = $(FLASH)/libflash.a ../Zlib/libz.a ../Jpeg/libjpeg.a -L/usr/X11R6/lib -lX11 -lXext -lm -lstdc++
+ CC=gcc
+ LDFLAGS=
+
diff --git a/net-www/gplflash/gplflash-0.4.10-r1.ebuild b/net-www/gplflash/gplflash-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..375e54969509
--- /dev/null
+++ b/net-www/gplflash/gplflash-0.4.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Pieter Van den Abeele <pvdabeel@gentoo.org>
+# $Id: gplflash-0.4.10-r1.ebuild,v 1.1 2002/06/30 02:41:03 mkennedy Exp $
+
+S=${WORKDIR}/flash-0.4.10
+DESCRIPTION="GPL Shockwave Flash Player/Plugin"
+SRC_URI="http://www.swift-tools.com/Flash/flash-0.4.10.tgz"
+HOMEPAGE="http://www.swift-tools.com/Flash"
+
+DEPEND="media-libs/libflash"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack flash-0.4.10.tgz
+ cd ${S}
+ patch -p1 <${FILESDIR}/gplflash-0.4.10-gcc3-gentoo.diff
+}
+
+src_compile() {
+ cd ${S}
+ emake
+}
+
+src_install() {
+ cd ${S}/Plugin
+ insinto /opt/netscape/plugins
+ doins npflash.so
+ cd ${S}
+ dodoc README COPYING
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npflash.so \
+ /usr/lib/mozilla/plugins/npflash.so
+ fi
+}