summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-05 07:58:48 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-05 07:58:48 +0000
commite17893b89362fcde724c7231f517fa78ff5f9c9f (patch)
treee5e729dfbb2c94dfc8bf05b241e55614f5f8898f /net-www/cocoon
parent*** empty log message *** (diff)
downloadgentoo-2-e17893b89362fcde724c7231f517fa78ff5f9c9f.tar.gz
gentoo-2-e17893b89362fcde724c7231f517fa78ff5f9c9f.tar.bz2
gentoo-2-e17893b89362fcde724c7231f517fa78ff5f9c9f.zip
Update related fixes.
httpd.conf now uses IfDefine for SSL PHP4 PERL TOMCAT COCOON cocoon examples now get installed into /opt/tomcat/webapps/cocoon and can be accessed via http://localhost/cocoon/samles/index.xml A statuspage is located at http://localhost/cocoon/Cocoon.xml Tomcat still writes its log files to /usr/local/httpd/logs and /opt/tomcat/logs this must be change
Diffstat (limited to 'net-www/cocoon')
-rw-r--r--net-www/cocoon/cocoon-1.8.ebuild16
-rw-r--r--net-www/cocoon/files/cocoon.properties71
2 files changed, 66 insertions, 21 deletions
diff --git a/net-www/cocoon/cocoon-1.8.ebuild b/net-www/cocoon/cocoon-1.8.ebuild
index 64ec1be9b389..d1ad4a94edca 100644
--- a/net-www/cocoon/cocoon-1.8.ebuild
+++ b/net-www/cocoon/cocoon-1.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/cocoon-1.8.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/cocoon-1.8.ebuild,v 1.2 2001/01/05 07:58:48 achim Exp $
A=Cocoon-${PV}.tar.gz
S=${WORKDIR}/${P}
@@ -18,7 +18,7 @@ src_unpack() {
unpack ${A}
}
-src_compile() {
+src_compile() {
CLASSPATH=/opt/java/src.jar:/opt/java/lib/tools.jar
CLASSPATH=${CLASSPATH}:/usr/lib/java/jndi.jar
CLASSPATH=${CLASSPATH}:/usr/lib/java/xt.jar:/usr/lib/java/sax.jar
@@ -31,15 +31,17 @@ src_compile() {
src_install() {
cd ${S}
- insinto /usr/lib/java
+ insinto /opt/tomcat/lib/cocoon
for i in xerces_1_2 xalan_1_2_D02 fop_0_13_0 \
- servlet_2_2 stylebook-1.0-b2 turbine-pool
+ servlet_2_2 turbine-pool
do
doins lib/$i.jar
done
doins build/cocoon.jar
- insinto /opt/tomcat/webapps/ROOT
- doins ${O}/files/cocoon.properties
+ insinto /opt/tomcat/webapps/cocoon/WEB-INF
+ cp -a samples ${D}/opt/tomcat/webapps/cocoon
+ doins ${FILESDIR}/cocoon.properties
+ doins ${FILESDIR}/web.xml
dodoc README LICENSE
dodir /usr/doc/${PF}/html
cp -a docs/* ${D}/usr/doc/${PF}/html
@@ -47,5 +49,3 @@ src_install() {
}
-
-
diff --git a/net-www/cocoon/files/cocoon.properties b/net-www/cocoon/files/cocoon.properties
index aa22517db9c7..3bb7f67e3fea 100644
--- a/net-www/cocoon/files/cocoon.properties
+++ b/net-www/cocoon/files/cocoon.properties
@@ -71,7 +71,6 @@ producer.parameter = producer
# producer.type.xxx = full.class.name
# where "xxx" is the producer indentier used in the request
producer.type.file = org.apache.cocoon.producer.ProducerFromFile
-producer.type.request = org.apache.cocoon.producer.ProducerFromRequest
# This is used in the example files
producer.type.dummy = org.apache.cocoon.example.DummyProducer
@@ -106,6 +105,9 @@ processor.type.sql = org.apache.cocoon.processor.sql.SQLProcessor
# in order for this processor to work. Check the FAQ for more information.
#processor.type.ldap = org.apache.cocoon.processor.ldap.LdapProcessor
+# XInclude Processor
+processor.type.xinclude = org.apache.cocoon.processor.xinclude.XIncludeProcessor
+
##########################################
# XSP Processor #
##########################################
@@ -117,19 +119,21 @@ processor.type.xsp = org.apache.cocoon.processor.xsp.XSPProcessor
processor.xsp.languages = java
# Default encoding to be used for code generation and compilation
-# If omitted, the platform's default encoding will be used
-# This encoding should be used in:
-# - The XSP document <?xml?> declaration
-# - The XSLT stylesheet <xsl:output> "encoding" attribute
-# - Cocoon's default formatter "encoding" configuration property
-### Example: Russian uses "Cp1251"
-### processor.xsp.encoding = Cp1251
+# If omitted, the platform's default encoding will be used
+# This encoding should also be used in:
+# - The XSP document <?xml?> declaration
+# - The "encoding" configuration property of the formatter to be used
+# Example: Russian uses "Cp1251"
+# processor.xsp.encoding = Cp1251
# support for the java language
processor.xsp.java.processor = org.apache.cocoon.processor.xsp.language.java.XSPJavaProcessor
+processor.xsp.java.processor.compiler = org.apache.cocoon.processor.xsp.language.java.SunJavaCompiler
+#processor.xsp.java.processor.compiler = org.apache.cocoon.processor.xsp.language.java.JikesJavaCompiler
processor.xsp.java.logicsheet = xsp-java.xsl
processor.xsp.java.preprocessor = org.apache.cocoon.processor.xsp.language.java.XSPJavaPreprocessor
+
# sets the repository where the compiled pages are stored.
# NOTE: make sure the directory is readable. This directory is usually
# relative to the web server's or to the servlet engine's. In case you're not
@@ -152,7 +156,36 @@ processor.xsp.logicsheet.request.java = resource://org/apache/cocoon/processor/
processor.xsp.logicsheet.response.java = resource://org/apache/cocoon/processor/xsp/library/java/response.xsl
processor.xsp.logicsheet.session.java = resource://org/apache/cocoon/processor/xsp/library/java/session.xsl
processor.xsp.logicsheet.util.java = resource://org/apache/cocoon/processor/xsp/library/java/util.xsl
-processor.xsp.logicsheet.sql.java = resource://org/apache/cocoon/processor/xsp/library/java/sql.xsl
+processor.xsp.logicsheet.sql.java = resource://org/apache/cocoon/processor/xsp/library/sql/sql.xsl
+processor.xsp.logicsheet.fp.java = resource://org/apache/cocoon/processor/xsp/library/fp/fp.xsl
+
+# Turbine DB Connection Pool
+############################
+
+# These are your database settings, look in the
+# org.apache.turbine.util.db.pool.* package for more information.
+processor.xsp.pool.database.default.driver=oracle.jdbc.driver.OracleDriver
+processor.xsp.pool.database.default.url=jdbc:oracle:thin:@localhost:1521:ORCL
+processor.xsp.pool.database.default.username=dbUser
+processor.xsp.pool.database.default.password=dbPass
+processor.xsp.pool.database.default.maxConnections=3
+processor.xsp.pool.database.default.expiryTime=3600000
+
+# These are the supported jdbc-drivers and their adaptors.
+# These properties are used by the DBFactory.
+processor.xsp.pool.database.adaptor=DBWeblogic,DBOracle,DBInstantDB,DBPostgres,DBSybase,DBInformix
+processor.xsp.pool.database.adaptor.DBWeblogic=weblogic.jdbc.pool.Driver
+processor.xsp.pool.database.adaptor.DBOracle=oracle.jdbc.driver.OracleDriver
+processor.xsp.pool.database.adaptor.DBInstantDB=org.enhydra.instantdb.jdbc.idbDriver
+processor.xsp.pool.database.adaptor.DBPostgres=postgresql.Driver
+processor.xsp.pool.database.adaptor.DBInformix=com.informix.jdbc.IfxDriver
+processor.xsp.pool.database.adaptor.DBSybase=com.sybase.jdbc.SybDriver
+
+# The full path name to a pool log file
+# if not given, commands to log events using org.apache.turbine.util.Log will be ignored.
+# This file must already exist and be writable.
+# Default: none
+#processor.xsp.pool.logfile=/opt/apache/var/log/dbPool.log
#### !!!!WARNING!!!! ###########
@@ -245,9 +278,9 @@ formatter.application/smil.doctype-system = http://www.w3.org/TR/REC-smil/SMIL10
formatter.application/smil.MIME-type = application/smil
# SVG (20000303 WD)
-formatter.image/svg.doctype-public = -//W3C//DTD SVG 20000303 Stylable//EN
-formatter.image/svg.doctype-system = http://www.w3.org/TR/2000/03/WD-SVG-20000303/
-formatter.image/svg.MIME-type = image/svg-xml
+formatter.image/svg-xml.doctype-public = -//W3C//DTD SVG 20000303 Stylable//EN
+formatter.image/svg-xml.doctype-system = http://www.w3.org/TR/2000/03/WD-SVG-20000303/
+formatter.image/svg-xml.MIME-type = image/svg-xml
@@ -285,7 +318,7 @@ store.heapsize = 60000000
# Indicates the thread priority (1-10: 10 is maximum, 1 is minimum)
#store.threadpriority = 10
-# Uncomment this to disable the background thread that manages the cache
+# Uncomment this to disable the background thread that manages the cache
# overflow and leave this at request time.
#store.usethread = false
@@ -334,3 +367,15 @@ browser.11 = mozilla5=Mozilla/5
browser.12 = mozilla5=Netscape6/
browser.13 = netscape=Mozilla
+##########################################
+# Profiling #
+##########################################
+
+#Uncomment this to enable coarse performance profiling.
+#Look at samples/profiler/profiler.xml to see the results of the profiler
+
+#profiler.enabled=true
+
+#Comment this out to remove the <--this page was served ... comment from the
+#end of text pages served by Cocoon
+verbosity=true