summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-05-30 00:28:10 +0000
committerRick Farina <zerochaos@gentoo.org>2013-05-30 00:28:10 +0000
commit8c6f12aa8900d190f23f9eb32c3c6bdbbc668392 (patch)
treeb57bd3b3499cadf5af83876a7720cd895f8602a3 /net-wireless
parentVersion bump. (diff)
downloadgentoo-2-8c6f12aa8900d190f23f9eb32c3c6bdbbc668392.tar.gz
gentoo-2-8c6f12aa8900d190f23f9eb32c3c6bdbbc668392.tar.bz2
gentoo-2-8c6f12aa8900d190f23f9eb32c3c6bdbbc668392.zip
now with more version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/ChangeLog9
-rw-r--r--net-wireless/uhd/uhd-3.5.3.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/net-wireless/uhd/ChangeLog b/net-wireless/uhd/ChangeLog
index b377d8344c7d..6ee6b745cc18 100644
--- a/net-wireless/uhd/ChangeLog
+++ b/net-wireless/uhd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/uhd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.6 2012/12/27 04:53:40 zerochaos Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.7 2013/05/30 00:28:10 zerochaos Exp $
+
+*uhd-3.5.3 (30 May 2013)
+
+ 30 May 2013; Rick Farina <zerochaos@gentoo.org> +uhd-3.5.3.ebuild:
+ now with more version bump
*uhd-3.5.0 (27 Dec 2012)
diff --git a/net-wireless/uhd/uhd-3.5.3.ebuild b/net-wireless/uhd/uhd-3.5.3.ebuild
new file mode 100644
index 000000000000..7af43d8272b3
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/uhd-3.5.3.ebuild,v 1.1 2013/05/30 00:28:10 zerochaos Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+inherit versionator python cmake-utils
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+image_version=uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).000-release
+SRC_URI="https://github.com/EttusResearch/UHD-Mirror/tarball/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3) -> EttusResearch-UHD-Mirror-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/maint_images/archive/${image_version}.tar.gz"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/master_images/archive
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}"/EttusResearch-UHD-Mirror-f4c5812/host
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-python/cheetah"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ #this may not be needed in 3.4.3 and above, please verify
+ sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/"${image_version}"/share/uhd/images
+}