summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-10-18 17:33:05 +0000
committerRick Farina <zerochaos@gentoo.org>2012-10-18 17:33:05 +0000
commit58094793a10e446f8a97fc411566a1a6cdfe44dc (patch)
tree8817deb4d887881729230f7dfab3dd116cf505fc /net-wireless
parentVersion bump. (diff)
downloadgentoo-2-58094793a10e446f8a97fc411566a1a6cdfe44dc.tar.gz
gentoo-2-58094793a10e446f8a97fc411566a1a6cdfe44dc.tar.bz2
gentoo-2-58094793a10e446f8a97fc411566a1a6cdfe44dc.zip
fix QA violation wrt bug #437996
(Portage version: 2.1.11.29/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/ChangeLog7
-rw-r--r--net-wireless/uhd/uhd-3.4.3-r2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-wireless/uhd/ChangeLog b/net-wireless/uhd/ChangeLog
index 666dd820557d..4d7c57a1213c 100644
--- a/net-wireless/uhd/ChangeLog
+++ b/net-wireless/uhd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/uhd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.4 2012/10/09 21:08:50 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.5 2012/10/18 17:33:05 zerochaos Exp $
+
+*uhd-3.4.3-r2 (18 Oct 2012)
+
+ 18 Oct 2012; Rick Farina <zerochaos@gentoo.org> +uhd-3.4.3-r2.ebuild:
+ fix QA violation wrt bug #437996
*uhd-3.4.3-r1 (09 Oct 2012)
diff --git a/net-wireless/uhd/uhd-3.4.3-r2.ebuild b/net-wireless/uhd/uhd-3.4.3-r2.ebuild
new file mode 100644
index 000000000000..5e859f517cad
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.4.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/uhd-3.4.3-r2.ebuild,v 1.1 2012/10/18 17:33:05 zerochaos Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+inherit versionator python cmake-utils
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+SRC_URI="https://github.com/EttusResearch/UHD-Mirror/tarball/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3) -> EttusResearch-UHD-Mirror-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/maint_images/archive/uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).002-12-geb083300.tar.gz"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/master_images/archive
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}"/EttusResearch-UHD-Mirror-6047010/host
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-python/cheetah"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ #this may not be needed in 3.4.3 and above, please verify
+ sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).002-12-geb083300/share/uhd/images
+}