summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-05-26 05:10:58 +0000
committerRick Farina <zerochaos@gentoo.org>2013-05-26 05:10:58 +0000
commit4ea13b2247a9123a7b6b3fc457f05bd4009d85d2 (patch)
tree914f89cb1b7c446ee473bbe6dc3c81591ae7f969 /net-wireless
parentVersion bump, remove old. (diff)
downloadgentoo-2-4ea13b2247a9123a7b6b3fc457f05bd4009d85d2.tar.gz
gentoo-2-4ea13b2247a9123a7b6b3fc457f05bd4009d85d2.tar.bz2
gentoo-2-4ea13b2247a9123a7b6b3fc457f05bd4009d85d2.zip
adding snapshot
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/lorcon/ChangeLog7
-rw-r--r--net-wireless/lorcon/lorcon-0.0_p20130212.ebuild108
2 files changed, 114 insertions, 1 deletions
diff --git a/net-wireless/lorcon/ChangeLog b/net-wireless/lorcon/ChangeLog
index 241a14803733..e7246c84cbca 100644
--- a/net-wireless/lorcon/ChangeLog
+++ b/net-wireless/lorcon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/lorcon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/ChangeLog,v 1.2 2013/04/19 13:34:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/ChangeLog,v 1.3 2013/05/26 05:10:58 zerochaos Exp $
+
+*lorcon-0.0_p20130212 (26 May 2013)
+
+ 26 May 2013; Rick Farina <zerochaos@gentoo.org> +lorcon-0.0_p20130212.ebuild:
+ adding snapshot
19 Apr 2013; Rick Farina <zerochaos@gentoo.org> lorcon-9999.ebuild:
cleanup DEPEND so it's correct
diff --git a/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild b/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild
new file mode 100644
index 000000000000..89d64c85fe20
--- /dev/null
+++ b/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild,v 1.1 2013/05/26 05:10:58 zerochaos Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL=yes
+
+inherit distutils ruby-ng
+
+DESCRIPTION="A generic library for injecting 802.11 frames"
+HOMEPAGE="http://802.11ninja.net/lorcon"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://code.google.com/p/lorcon/"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="python ruby"
+
+DEPEND="ruby? ( $(ruby_implementations_depend) )
+ dev-libs/libnl
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup;
+ DISTUTILS_SETUP_FILES=("${S}/pylorcon2|setup.py")
+ fi
+ use ruby && ruby-ng_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ default_src_unpack
+ fi
+ use ruby && ruby-ng_src_unpack
+}
+
+src_prepare() {
+ sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
+ sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
+ sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/all#" ruby-lorcon/extconf.rb
+ sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
+ use python && distutils_src_prepare
+ use ruby && ruby-ng_src_prepare
+}
+
+src_configure() {
+ default_src_configure
+ use ruby && ruby-ng_src_configure
+}
+
+src_compile() {
+ default_src_compile
+ if use python; then
+ LDFLAGS+=" -L${S}/.libs/"
+ distutils_src_compile
+ fi
+ use ruby && ruby-ng_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ use python && distutils_src_install
+ use ruby && ruby-ng_src_install
+}
+
+src_test() {
+ :
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
+
+each_ruby_configure() {
+ ${RUBY} -C "ruby-lorcon" extconf.rb
+ sed -i "s#-L\.#-L. -L${WORKDIR}/all/.libs -lorcon2 #g" ruby-lorcon/Makefile
+}
+
+each_ruby_compile() {
+ emake -C ruby-lorcon
+}
+
+each_ruby_install() {
+ DESTDIR="${ED}" emake -C ruby-lorcon install
+}