summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-04-05 18:39:53 +0000
committerOlivier Crête <tester@gentoo.org>2008-04-05 18:39:53 +0000
commitc683b5f46ae578599fb3db6ef5efd0f84b6404c3 (patch)
tree526881e2411163c207f72818cad8c414aa243995 /net-voip
parentadd gnome-common to DEPEND, fix bug #213193 (diff)
downloadgentoo-2-c683b5f46ae578599fb3db6ef5efd0f84b6404c3.tar.gz
gentoo-2-c683b5f46ae578599fb3db6ef5efd0f84b6404c3.tar.bz2
gentoo-2-c683b5f46ae578599fb3db6ef5efd0f84b6404c3.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-stream-engine/ChangeLog10
-rw-r--r--net-voip/telepathy-stream-engine/telepathy-stream-engine-0.5.0.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/net-voip/telepathy-stream-engine/ChangeLog b/net-voip/telepathy-stream-engine/ChangeLog
index 7d31ec813765..b4eb6ff609f7 100644
--- a/net-voip/telepathy-stream-engine/ChangeLog
+++ b/net-voip/telepathy-stream-engine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-stream-engine
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-stream-engine/ChangeLog,v 1.16 2007/09/28 18:01:27 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-stream-engine/ChangeLog,v 1.17 2008/04/05 18:39:53 tester Exp $
+
+*telepathy-stream-engine-0.5.0 (05 Apr 2008)
+
+ 05 Apr 2008; Olivier Crête <tester@gentoo.org>
+ +telepathy-stream-engine-0.5.0.ebuild:
+ Version bump
*telepathy-stream-engine-0.4.0 (28 Sep 2007)
diff --git a/net-voip/telepathy-stream-engine/telepathy-stream-engine-0.5.0.ebuild b/net-voip/telepathy-stream-engine/telepathy-stream-engine-0.5.0.ebuild
new file mode 100644
index 000000000000..77afdac6e78c
--- /dev/null
+++ b/net-voip/telepathy-stream-engine/telepathy-stream-engine-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-stream-engine/telepathy-stream-engine-0.5.0.ebuild,v 1.1 2008/04/05 18:39:53 tester Exp $
+
+DESCRIPTION="A Telepathy client that handles channels of type 'StreamedMedia'"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/stream-engine/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug v4l v4l2 xv alsa esd oss"
+
+DEPEND=">=dev-libs/glib-2.4
+ dev-libs/libxml2
+ >=media-libs/farsight-0.1.26
+ =media-libs/gst-plugins-base-0.10*
+ >=net-libs/telepathy-glib-0.7.1
+ >=dev-libs/dbus-glib-0.71
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-x
+ v4l? ( media-plugins/gst-plugins-v4l )
+ v4l2? ( media-plugins/gst-plugins-v4l2 )
+ xv? ( media-plugins/gst-plugins-xvideo )
+ alsa? ( media-plugins/gst-plugins-alsa )
+ esd? ( media-plugins/gst-plugins-esd )
+ oss? ( media-plugins/gst-plugins-oss )
+ gnome? ( media-plugins/gst-plugins-gconf )
+ pulseaudio? ( media-plugins/gst-plugins-pulse )"
+
+src_compile() {
+ econf \
+ $(use_enable debug backtrace) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake failed"
+ dodoc TODO ChangeLog
+}