summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-09-03 21:01:39 +0000
committerOlivier Crête <tester@gentoo.org>2009-09-03 21:01:39 +0000
commit3957015d000a226fef5410bc6c2c3198c9486fd3 (patch)
treee1b063bb5925c13d0c7242a361b7b231b792c4b4 /net-voip/telepathy-gabble
parentFix bug #283053, missing $(use_with wordperfect) in src_configure() which cau... (diff)
downloadgentoo-2-3957015d000a226fef5410bc6c2c3198c9486fd3.tar.gz
gentoo-2-3957015d000a226fef5410bc6c2c3198c9486fd3.tar.bz2
gentoo-2-3957015d000a226fef5410bc6c2c3198c9486fd3.zip
Version bump, disabled tests because they fail
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog8
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.8.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 028945aa427e..393eb534067c 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.50 2009/08/30 17:23:55 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.51 2009/09/03 21:01:39 tester Exp $
+
+*telepathy-gabble-0.8.2 (03 Sep 2009)
+
+ 03 Sep 2009; Olivier Crête <tester@gentoo.org>
+ +telepathy-gabble-0.8.2.ebuild:
+ Version bump, disabled tests because they fail
30 Aug 2009; Olivier Crête <tester@gentoo.org>
telepathy-gabble-0.8.1.ebuild:
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.8.2.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.8.2.ebuild
new file mode 100644
index 000000000000..06776becf637
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.8.2.ebuild,v 1.1 2009/09/03 21:01:39 tester Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.78
+ >=net-libs/telepathy-glib-0.7.34
+ >=net-libs/loudmouth-1.3.2[ssl]
+ net-libs/libsoup:2.4[ssl]"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-lang/python-2.5
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )"
+
+# 2 tests still fail :-(
+RESTRICT=test
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ emake -j1 check || die "Make check failed. See above for details."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog README || die "dodoc failed"
+}