summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 10:48:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 10:48:34 +0000
commit638ffff32cf4d3c39466c1e3515882337384b287 (patch)
tree9b7764a13008db4ff52a28a59945049f4c01f322 /net-proxy
parentStable on amd64 wrt bug #350776 (diff)
downloadgentoo-2-638ffff32cf4d3c39466c1e3515882337384b287.tar.gz
gentoo-2-638ffff32cf4d3c39466c1e3515882337384b287.tar.bz2
gentoo-2-638ffff32cf4d3c39466c1e3515882337384b287.zip
Fix build with Berkeley DB 5.0 (bug #319955).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/oops/ChangeLog9
-rw-r--r--net-proxy/oops/files/oops-1.5.24_pre20050503+db-5.0.patch13
-rw-r--r--net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild5
3 files changed, 23 insertions, 4 deletions
diff --git a/net-proxy/oops/ChangeLog b/net-proxy/oops/ChangeLog
index 77c0a81fa08a..d5edfaa6c3e9 100644
--- a/net-proxy/oops/ChangeLog
+++ b/net-proxy/oops/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/oops
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/oops/ChangeLog,v 1.25 2010/07/11 11:41:51 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/oops/ChangeLog,v 1.26 2011/01/10 10:48:34 flameeyes Exp $
+
+ 10 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ oops-1.5.24_pre20050503-r4.ebuild,
+ +files/oops-1.5.24_pre20050503+db-5.0.patch:
+ Fix build with Berkeley DB 5.0 (bug #319955).
11 Jul 2010; Raúl Porcel <armin76@gentoo.org>
oops-1.5.24_pre20050503-r4.ebuild:
diff --git a/net-proxy/oops/files/oops-1.5.24_pre20050503+db-5.0.patch b/net-proxy/oops/files/oops-1.5.24_pre20050503+db-5.0.patch
new file mode 100644
index 000000000000..190944828ee8
--- /dev/null
+++ b/net-proxy/oops/files/oops-1.5.24_pre20050503+db-5.0.patch
@@ -0,0 +1,13 @@
+Index: oops-1.5.23/src/modules/berkeley_db_api.c
+===================================================================
+--- oops-1.5.23.orig/src/modules/berkeley_db_api.c
++++ oops-1.5.23/src/modules/berkeley_db_api.c
+@@ -283,7 +283,7 @@ int rc;
+ dbp->set_bt_compare(dbp, my_bt_compare);
+ dbp->set_pagesize(dbp, OOPS_DB_PAGE_SIZE);
+ rc = dbp->open(dbp,
+- #if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0
++ #if DB_VERSION_MAJOR > 4 || DB_VERSION_MINOR > 0
+ NULL,
+ #endif
+ dbname,
diff --git a/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild b/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild
index e1a49510c41f..c08f993acd00 100644
--- a/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild
+++ b/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild,v 1.4 2010/07/11 11:41:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/oops/oops-1.5.24_pre20050503-r4.ebuild,v 1.5 2011/01/10 10:48:34 flameeyes Exp $
EAPI="2"
@@ -38,6 +38,7 @@ src_prepare() {
epatch "${FILESDIR}/implicit-decl.patch"
epatch "${FILESDIR}/libpcreposix.patch"
epatch "${FILESDIR}/rotate-logs.patch"
+ epatch "${FILESDIR}/${P}+db-5.0.patch"
sed -i -e 's:y\.tab\.h:y.tab.c:' src/Makefile.in
eautoreconf
}