summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-05-13 20:11:16 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-05-13 20:11:16 +0000
commit59c83c31f2998387601b94ab3a2cfd264bf61b4f (patch)
tree1f714b560012ca0b7aee261bb276911e515ae5a3 /net-proxy
parentVersion bump (diff)
downloadgentoo-2-59c83c31f2998387601b94ab3a2cfd264bf61b4f.tar.gz
gentoo-2-59c83c31f2998387601b94ab3a2cfd264bf61b4f.tar.bz2
gentoo-2-59c83c31f2998387601b94ab3a2cfd264bf61b4f.zip
Add haproxy live ebuild
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog7
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index b93dff66a3c7..9610bfd93bb4 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.79 2013/04/05 17:10:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.80 2013/05/13 20:11:16 idl0r Exp $
+
+*haproxy-9999 (13 May 2013)
+
+ 13 May 2013; Christian Ruppert <idl0r@gentoo.org> +haproxy-9999.ebuild:
+ Add haproxy live ebuild
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> haproxy-1.4.23.ebuild:
Stable for ppc, wrt bug #464340
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
new file mode 100644
index 000000000000..473963bc9521
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-9999.ebuild,v 1.1 2013/05/13 20:11:16 idl0r Exp $
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic git-2
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+EGIT_REPO_URI="http://master.formilux.org/git/people/willy/haproxy.git"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="+crypt examples +pcre ssl vim-syntax +zlib"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl[zlib?] )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local args="TARGET=linux2628 USE_GETADDRINFO=1"
+
+ if use pcre; then
+ args="${args} USE_PCRE=1 USE_PCRE_JIT=1"
+ else
+ args="${args} USE_PCRE= USE_PCRE_JIT="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use crypt; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+ if use ssl; then
+ args="${args} USE_OPENSSL=1"
+ else
+ args="${args} USE_OPENSSL="
+ fi
+
+ if use zlib; then
+ args="${args} USE_ZLIB=1"
+ else
+ args="${args} USE_ZLIB="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+# append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
+}
+
+src_install() {
+ dobin haproxy || die
+
+ newinitd "${FILESDIR}/haproxy.initd-r2" haproxy || die
+
+ # Don't install useless files
+# rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ if use examples;
+ then
+ docinto examples
+ dodoc examples/*.cfg || die
+ fi
+
+ if use vim-syntax;
+ then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}