summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-12-31 10:20:17 +0000
committerAlin Năstac <mrness@gentoo.org>2005-12-31 10:20:17 +0000
commit53beb8ab33bc8034c149d11ca318488d02486db2 (patch)
treea35632fa2882f0f0b3929459e454b2a811f673e0 /net-proxy
parentAdded linux-mod_pkg_postinst call to pkg_postinst that got lost when the depr... (diff)
downloadgentoo-2-53beb8ab33bc8034c149d11ca318488d02486db2.tar.gz
gentoo-2-53beb8ab33bc8034c149d11ca318488d02486db2.tar.bz2
gentoo-2-53beb8ab33bc8034c149d11ca318488d02486db2.zip
Stop service correctly by calling squid -k shutdown instead using Stop service correctly by calling squid -k shutdown instead using start-stop-daemon
(Portage version: 2.0.53)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squid/ChangeLog6
-rw-r--r--net-proxy/squid/files/squid.initd123
2 files changed, 63 insertions, 66 deletions
diff --git a/net-proxy/squid/ChangeLog b/net-proxy/squid/ChangeLog
index 507bdd4de631..bd67d15de2c4 100644
--- a/net-proxy/squid/ChangeLog
+++ b/net-proxy/squid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/squid
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.54 2005/12/28 13:39:00 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.55 2005/12/31 10:20:17 mrness Exp $
+
+ 31 Dec 2005; Alin Nastac <mrness@gentoo.org> files/squid.initd:
+ Stop service correctly by calling squid -k shutdown instead using
+ start-stop-daemon.
28 Dec 2005; Gustavo Zacarias <gustavoz@gentoo.org> squid-2.5.12.ebuild:
Stable on sparc
diff --git a/net-proxy/squid/files/squid.initd b/net-proxy/squid/files/squid.initd
index 9d9a038d4909..950f1bf9fe84 100644
--- a/net-proxy/squid/files/squid.initd
+++ b/net-proxy/squid/files/squid.initd
@@ -1,89 +1,82 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/files/squid.initd,v 1.1 2005/07/16 10:14:17 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/files/squid.initd,v 1.2 2005/12/31 10:20:17 mrness Exp $
opts="${opts} reload"
depend() {
- need net
+ need net
}
# Try to increase the # of filedescriptors we can open.
maxfds() {
- [ -n "$SQUID_MAXFD" ] || return
- [ -f /proc/sys/fs/file-max ] || return 0
- [ $SQUID_MAXFD -le 8192 ] || SQUID_MAXFD=8192
- global_file_max=`cat /proc/sys/fs/file-max`
- minimal_file_max=$(($SQUID_MAXFD + 4096))
- if [ "$global_file_max" -lt $minimal_file_max ]
- then
- echo $minimal_file_max > /proc/sys/fs/file-max
- fi
- ulimit -n $SQUID_MAXFD
+ [ -n "$SQUID_MAXFD" ] || return
+ [ -f /proc/sys/fs/file-max ] || return 0
+ [ $SQUID_MAXFD -le 8192 ] || SQUID_MAXFD=8192
+ global_file_max=`cat /proc/sys/fs/file-max`
+ minimal_file_max=$(($SQUID_MAXFD + 4096))
+ if [ "$global_file_max" -lt $minimal_file_max ]
+ then
+ echo $minimal_file_max > /proc/sys/fs/file-max
+ fi
+ ulimit -n $SQUID_MAXFD
}
checkconfig() {
- maxfds
- CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
- grep cache_dir | awk '{ print $3 }'`
- [ -z "$CACHE_SWAP" ] && CACHE_SWAP=/var/cache/squid
- umask 027
- for x in $CACHE_SWAP ; do
- if [ ! -d $x/00 ] ; then
- einfo "Initializing cache directory: $x"
- cd $x
- /usr/sbin/squid -z -F 2>/dev/null
- if [ $? -ne 0 ] ; then
- eerror "Error initializing: $x"
- return 1
- fi
- fi
- done
+ maxfds
+ CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
+ grep cache_dir | awk '{ print $3 }'`
+ [ -z "$CACHE_SWAP" ] && CACHE_SWAP=/var/cache/squid
+ umask 027
+ for x in $CACHE_SWAP ; do
+ if [ ! -d $x/00 ] ; then
+ einfo "Initializing cache directory: $x"
+ cd $x
+ /usr/sbin/squid -z -F 2>/dev/null
+ if [ $? -ne 0 ] ; then
+ eerror "Error initializing: $x"
+ return 1
+ fi
+ fi
+ done
}
start() {
- checkconfig || return 1
- ebegin "Starting squid"
- start-stop-daemon --quiet --start --exec /usr/sbin/squid \
- --pidfile /var/run/squid.pid -- ${SQUID_OPTS} < /dev/null
- sleep 1
- eend $?
+ checkconfig || return 1
+ ebegin "Starting squid"
+ /usr/sbin/squid ${SQUID_OPTS}
+ eend $? && sleep 1
}
stop() {
- ebegin "Stopping squid"
- PID=`cat /var/run/squid.pid 2>/dev/null`
- start-stop-daemon --stop --quiet --exec /usr/sbin/squid \
- --pidfile /var/run/squid.pid
- # Now we have to wait until squid has _really_ stopped.
- sleep 2
- if test -n "$PID" && kill -0 $PID 2>/dev/null
- then
- einfon "Waiting ."
- cnt=0
- while kill -0 $PID 2>/dev/null
- do
- cnt=`expr $cnt + 1`
- if [ $cnt -gt 60 ]
- then
- # Waited 120 seconds now. Fail.
- eend 1 "Failed."
- break
- fi
- sleep 2
- echo -n "."
- done
- echo -n "done."
- eend 0
- else
- eend 0
- fi
+ ebegin "Stopping squid"
+ /usr/sbin/squid -k shutdown
+ # Now we have to wait until squid has _really_ stopped.
+ sleep 1
+ if [ -f /var/run/squid.pid ] ; then
+ einfon "Waiting ."
+ cnt=0
+ while [ -f /var/run/squid.pid ] ; do
+ cnt=`expr $cnt + 1`
+ if [ $cnt -gt 60 ] ; then
+ # Waited 120 seconds now. Fail.
+ eend 1 "Failed."
+ break
+ fi
+ sleep 2
+ echo -n "."
+ done
+ echo -n "done."
+ eend 0
+ else
+ eend 0
+ fi
}
reload() {
- checkconfig || return 1
- ebegin "Reloading squid"
- /usr/sbin/squid -k reconfigure
- eend $?
+ checkconfig || return 1
+ ebegin "Reloading squid"
+ /usr/sbin/squid -k reconfigure
+ eend $?
}