summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-02-05 23:42:02 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-02-05 23:42:02 +0000
commitc39c35be5903afc5dcc617c9c9ded6098ce322c3 (patch)
treec74b194f4cd0238643613297741df8fe3aacc8f3 /net-print
parentclean up (diff)
downloadgentoo-2-c39c35be5903afc5dcc617c9c9ded6098ce322c3.tar.gz
gentoo-2-c39c35be5903afc5dcc617c9c9ded6098ce322c3.tar.bz2
gentoo-2-c39c35be5903afc5dcc617c9c9ded6098ce322c3.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog9
-rw-r--r--net-print/splix/splix-1.1.1.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index ec1b0e7b77b5..59afc43addf6 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/splix
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.9 2007/10/27 12:07:43 wschlich Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.10 2008/02/05 23:42:02 wschlich Exp $
+
+*splix-1.1.1 (05 Feb 2008)
+
+ 05 Feb 2008; Wolfram Schlich <wschlich@gentoo.org> +splix-1.1.1.ebuild:
+ version bump
*splix-1.0.2 (27 Oct 2007)
diff --git a/net-print/splix/splix-1.1.1.ebuild b/net-print/splix/splix-1.1.1.ebuild
new file mode 100644
index 000000000000..a99097a1e582
--- /dev/null
+++ b/net-print/splix/splix-1.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-1.1.1.ebuild,v 1.1 2008/02/05 23:42:02 wschlich Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_p/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ net-print/cupsddk
+ media-libs/jbigkit"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.1.0-fix-makefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ CUPSFILTERDIR="$(cups-config --serverbin)/filter"
+ CUPSPPDDIR="$(cups-config --datadir)/model"
+
+ dodir "${CUPSFILTERDIR}"
+ dodir "${CUPSPPDDIR}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ebeep 5
+ ewarn ""
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+ ewarn ""
+}