summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 02:49:15 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 02:49:15 +0000
commit02ea16df01eb41ab805b31ee5c5e678180c5aa38 (patch)
tree11f2d27d6c23a086999be69e3735fe567ab05841 /net-print/pdq
parentStable on x86, sparc, and amd64. (Manifest recommit) (diff)
downloadgentoo-2-02ea16df01eb41ab805b31ee5c5e678180c5aa38.tar.gz
gentoo-2-02ea16df01eb41ab805b31ee5c5e678180c5aa38.tar.bz2
gentoo-2-02ea16df01eb41ab805b31ee5c5e678180c5aa38.zip
Fix use invocation, use econf, add error-checking, get rid of broken subshells so that die is possible, etc
Diffstat (limited to 'net-print/pdq')
-rw-r--r--net-print/pdq/ChangeLog6
-rw-r--r--net-print/pdq/pdq-2.2.1-r1.ebuild71
2 files changed, 37 insertions, 40 deletions
diff --git a/net-print/pdq/ChangeLog b/net-print/pdq/ChangeLog
index 4235985a69c9..6904eea50412 100644
--- a/net-print/pdq/ChangeLog
+++ b/net-print/pdq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/pdq
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pdq/ChangeLog,v 1.4 2004/04/09 13:03:28 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pdq/ChangeLog,v 1.5 2004/06/15 02:49:15 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org> pdq-2.2.1-r1.ebuild:
+ Fix use invocation, use econf, add error-checking, get rid of broken subshells
+ so that die is possible, etc
09 Apr 2004; Heinrich Wendel <lanius@gentoo.org> pdq-2.2.1-r1.ebuild:
remove S=${WORKDIR}/${P}
diff --git a/net-print/pdq/pdq-2.2.1-r1.ebuild b/net-print/pdq/pdq-2.2.1-r1.ebuild
index 85c46fe0923e..450abfe34486 100644
--- a/net-print/pdq/pdq-2.2.1-r1.ebuild
+++ b/net-print/pdq/pdq-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pdq/pdq-2.2.1-r1.ebuild,v 1.10 2004/04/09 13:03:28 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pdq/pdq-2.2.1-r1.ebuild,v 1.11 2004/06/15 02:49:15 agriffis Exp $
IUSE="gtk"
@@ -15,57 +15,50 @@ LICENSE="GPL-2"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
src_compile() {
-
- ./configure --prefix=/usr --host=${CHOST} || die
- cd src
- use gtk && ( \
+ econf || die "econf failed"
+ if use gtk; then
echo "Making pdq and xpdq"
- make || die
- ) || ( \
+ make -C ${S}/src || die
+ else
echo "Making only pdq (xpdq disabled)"
- make pdq || die
- )
- cd ..
- cd lpd
- make || die
- cd ..
-
+ make -C ${S}/src pdq || die
+ fi
+ make -C ${S}/lpd || die
}
src_install () {
-
- cd src
+ cd ${S}/src
exeinto /usr/bin
- if [ -z "`use gtk`" ] ; then
- doexe pdq
+ if use gtk ; then
+ doexe pdq xpdq || die
else
- doexe pdq xpdq
+ doexe pdq || die
fi
- cd ..
- cd lpd
+
+ cd ${S}/lpd
exeopts -m 4755 -o root
exeinto /usr/bin
- doexe lpd_cancel lpd_print lpd_status
- cd ..
- cd doc
- if [ -z "`use gtk`" ] ; then
- echo "man w/o gtk"
- doman lpd_cancel.1 lpd_print.1 lpd_status.1 pdq.1 pdqstat.1 printrc.5
- else
+ doexe lpd_cancel lpd_print lpd_status || die
+
+ cd ${S}/doc
+ if use gtk ; then
echo "man w/ gtk"
- doman *.1 *.5
+ doman *.1 *.5 || die
+ else
+ echo "man w/o gtk"
+ doman lpd_cancel.1 lpd_print.1 lpd_status.1 pdq.1 pdqstat.1 \
+ printrc.5 || die
fi
- dodoc rfc1179.txt
- cd ..
- cd etc
- mv Makefile Makefile.orig
- sed -e 's/$$dir/$(DESTDIR)$$dir/' \
+ dodoc rfc1179.txt || die
+
+ cd ${S}/etc
+ sed -i -e 's/$$dir/$(DESTDIR)$$dir/' \
-e 's/$(pdqlibdir)\/$$file/$(DESTDIR)\/$(pdqlibdir)\/$$file/' \
- Makefile.orig > Makefile
+ Makefile || die 'sed failed'
insinto /etc/pdq
- newins printrc.example printrc
- make DESTDIR=${D} install || die
- cd ..
- dodoc CHANGELOG INSTALL README LICENSE BUGS
+ newins printrc.example printrc || die
+ make DESTDIR=${D} install || die 'make install failed'
+ cd ${S}
+ dodoc CHANGELOG INSTALL README LICENSE BUGS || die
}