summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-18 08:11:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-18 08:11:49 +0000
commitd2b19ad1674ab7a817b603788892625ff52874f0 (patch)
tree68817537be04698bf35742332c8d65a7db8fd47d /net-print/cups
parentVersion bump. Bug #376371 (diff)
downloadgentoo-2-d2b19ad1674ab7a817b603788892625ff52874f0.tar.gz
gentoo-2-d2b19ad1674ab7a817b603788892625ff52874f0.tar.bz2
gentoo-2-d2b19ad1674ab7a817b603788892625ff52874f0.zip
cups 1.5 should handle the usb printing properly without any kernel hackery.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'net-print/cups')
-rw-r--r--net-print/cups/ChangeLog5
-rw-r--r--net-print/cups/cups-1.5.0-r2.ebuild49
2 files changed, 6 insertions, 48 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 53ff508c3d92..b8c0a9be9c88 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/cups
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.435 2011/09/03 13:21:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.436 2011/09/18 08:11:49 scarabeus Exp $
+
+ 18 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> cups-1.5.0-r2.ebuild:
+ cups 1.5 should handle the usb printing properly without any kernel hackery.
03 Sep 2011; Raúl Porcel <armin76@gentoo.org> cups-1.4.8-r1.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #380771
diff --git a/net-print/cups/cups-1.5.0-r2.ebuild b/net-print/cups/cups-1.5.0-r2.ebuild
index 80965f60e242..992ee8c33956 100644
--- a/net-print/cups/cups-1.5.0-r2.ebuild
+++ b/net-print/cups/cups-1.5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.5.0-r2.ebuild,v 1.1 2011/08/28 23:20:47 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.5.0-r2.ebuild,v 1.2 2011/09/18 08:11:49 scarabeus Exp $
#
# See http://git.overlays.gentoo.org/gitweb/?p=dev/dilfridge.git;a=blob;f=net-print/cups/notes.txt;hb=HEAD
@@ -11,7 +11,7 @@ EAPI=3
PYTHON_DEPEND="python? 2:2.5"
-inherit autotools eutils flag-o-matic linux-info multilib pam perl-module python versionator java-pkg-opt-2
+inherit autotools eutils flag-o-matic multilib pam perl-module python versionator java-pkg-opt-2
MY_P=${P/_}
MY_PV=${PV/_}
@@ -86,51 +86,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
fi
-
- if use usb; then
- elog "You are going to use new libusb backed to access your usb printer."
- elog "This interface has quite few known issues and does not report all"
- elog "issues and just refuses to print."
- elog "Please consider disabling usb useflag if you are having issues."
- elog
- elog "Please note that if you disable the usb useflag your device will be"
- elog "still working using kernel usblp interface instead of libusb."
- echo
- fi
-
- linux-info_pkg_setup
- if ! linux_config_exists; then
- ewarn "Can't check the linux kernel configuration."
- ewarn "You might have some incompatible options enabled."
- else
- # recheck that we don't have usblp to collide with libusb
- if use usb; then
- if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb which collides with kernel module."
- eerror "${P} requires the USB_PRINTER support disabled."
- eerror "Please disable it:"
- eerror " CONFIG_USB_PRINTER=n"
- eerror "in /usr/src/linux/.config or"
- eerror " Device Drivers --->"
- eerror " USB support --->"
- eerror " [ ] USB Printer support"
- eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
- fi
- else
- #here we should warn user that he should enable it so he can print
- if ! linux_chkconfig_present USB_PRINTER; then
- ewarn "If you plan to use USB printers you should enable the USB_PRINTER"
- ewarn "support in your kernel."
- ewarn "Please enable it:"
- ewarn " CONFIG_USB_PRINTER=y"
- ewarn "in /usr/src/linux/.config or"
- ewarn " Device Drivers --->"
- ewarn " USB support --->"
- ewarn " [*] USB Printer support"
- ewarn "Alternatively, enable the usb useflag for cups and use the new, less-tested libusb code."
- fi
- fi
- fi
}
src_prepare() {