summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-12-09 20:53:22 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-12-09 20:53:22 +0000
commitec65fa66f1f33bbffc3e136c85e47015398da8e6 (patch)
treecce6f0ed4eba1fa51c1fac665e6d2ca70d4d800f /net-p2p
parentmore sparc fixes (diff)
downloadgentoo-2-ec65fa66f1f33bbffc3e136c85e47015398da8e6.tar.gz
gentoo-2-ec65fa66f1f33bbffc3e136c85e47015398da8e6.tar.bz2
gentoo-2-ec65fa66f1f33bbffc3e136c85e47015398da8e6.zip
version bump, now compiles from source
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/ChangeLog11
-rw-r--r--net-p2p/mldonkey/files/digest-mldonkey-2.00-r13
-rw-r--r--net-p2p/mldonkey/mldonkey-2.00-r1.ebuild92
3 files changed, 103 insertions, 3 deletions
diff --git a/net-p2p/mldonkey/ChangeLog b/net-p2p/mldonkey/ChangeLog
index c6bc794846cf..18def86af60a 100644
--- a/net-p2p/mldonkey/ChangeLog
+++ b/net-p2p/mldonkey/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-p2p/mldonkey
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# Author: José Alberto Suárez López <bass@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.1 2002/06/26 11:09:16 bangert Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.2 2002/12/09 20:53:22 hannes Exp $
+
+*mldonkey-2.00-r1 (09 Dec 2002)
+
+ 09 Dec 2002; Hannes Mehnert <hannes@mehnert.org> mldonkey-2.00-r1.ebuild:
+ this ebuild is now from source. Thanks to gentoo-bug@loitsch.org (Christian
+ Loitsch) for submission (bug #9677)
26 Jun 2002; Thilo Bangert <bangert@gentoo.org> :
diff --git a/net-p2p/mldonkey/files/digest-mldonkey-2.00-r1 b/net-p2p/mldonkey/files/digest-mldonkey-2.00-r1
new file mode 100644
index 000000000000..9738719135d4
--- /dev/null
+++ b/net-p2p/mldonkey/files/digest-mldonkey-2.00-r1
@@ -0,0 +1,3 @@
+MD5 f2494ffeff8308f103a814b321019fdb mldonkey-2.00.sources.tar.gz 1173174
+MD5 06072ae1a0ff6580bc0315f6fa30da8e diff-2.00-2.00+2.patch.gz 253593
+MD5 03707521fa089baac2f94ed1232587e0 pango-20021208a.tar.gz 64222
diff --git a/net-p2p/mldonkey/mldonkey-2.00-r1.ebuild b/net-p2p/mldonkey/mldonkey-2.00-r1.ebuild
new file mode 100644
index 000000000000..8d739426c7e6
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-2.00-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.00-r1.ebuild,v 1.1 2002/12/09 20:53:22 hannes Exp $
+
+IUSE="gtk"
+DESCRIPTION="edonkey, opennap,... client written in ocaml"
+HOMEPAGE="http://www.nongnu.org/mldonkey/"
+SRC_URI="http://savannah.nongnu.org/download/mldonkey/stable/${P}.sources.tar.gz
+ http://concept.free.free.fr/mldonkey/goodies/diff-2.00-2.00+2.patch.gz
+ http://concept.free.free.fr/mldonkey/pango-20021208a.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="gtk? ( >=lablgtk-1.2.3 )
+ >=ocaml-3.06
+ >=perl-5.6.1"
+S="${WORKDIR}/mldonkey"
+
+src_unpack() {
+ unpack ${P}.sources.tar.gz
+ cd ${S}
+ cp ${DISTDIR}/diff-2.00-2.00+2.patch.gz ./
+ cp ${DISTDIR}/pango-20021208a.tar.gz ./
+ gunzip diff-2.00-2.00+2.patch.gz
+ tar -xzf pango-20021208a.tar.gz
+ patch -p0 < diff-2.00-2.00+2.patch
+ patch -p0 -E -s < pango.patch
+}
+
+src_compile() {
+ use gtk || export GTK_CONFIG="no"
+
+ # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/usr/var/mldonkey \
+ --localstatedir=/usr/var/mldonkey \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dobin mldonkey mlchat
+ for i in mldonkey_gui mldonkey_gui2 mldonkey_guistarter
+ do
+ if [[ -f ${i} ]]
+ then
+ dobin ${i}
+ fi
+ done
+
+ for i in AUTHORS BUGS COPYING ChangeLog Developers.txt ed2k_links.txt \
+ Readme.txt TODO;
+ do
+ dodoc distrib/${i}
+ done
+
+ dohtml FAQ.html
+
+ insinto scripts
+ for i in kill_mldonkey mldonkey_command mldonkey_previewer;
+ do
+ doins distrib/${i}
+ done
+
+ insinto scripts/ed2k_submit
+ echo "Ignore CVS error:"
+ doins distrib/ed2k_submit/*
+
+ insinto /usr/share/doc/${PF}/distrib
+ for i in servers.ini directconnect.ini;
+ do
+ doins distrib/${i}
+ done
+}
+
+pkg_postinst() {
+ echo
+ echo
+ einfo "To start mldonkey, copy the contents of \$doc/distrib in a"
+ einfo "writable directory, and start mldonkey from there."
+ einfo "Eg: cp everything to /home/user1/mldonkey"
+ einfo "then: cd /home/user1/mldonkey && mldonkey >> mld.log &"
+ echo
+ echo
+}