summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-01 04:02:55 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-01 04:02:55 +0000
commite340595b9dae941b9924dae62c3869f1a3326a30 (patch)
treea011ed99cd3fe1b5b7c826952207b8c50d8faee5 /net-p2p
parentnew ebuild - new toys (diff)
downloadgentoo-2-e340595b9dae941b9924dae62c3869f1a3326a30.tar.gz
gentoo-2-e340595b9dae941b9924dae62c3869f1a3326a30.tar.bz2
gentoo-2-e340595b9dae941b9924dae62c3869f1a3326a30.zip
new ebuild - new toys
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gift-cvs/ChangeLog8
-rw-r--r--net-p2p/gift-cvs/Manifest4
-rw-r--r--net-p2p/gift-cvs/files/digest-gift-cvs-0.11.00
-rw-r--r--net-p2p/gift-cvs/gift-cvs-0.11.0.ebuild94
4 files changed, 103 insertions, 3 deletions
diff --git a/net-p2p/gift-cvs/ChangeLog b/net-p2p/gift-cvs/ChangeLog
index 13eb330d8bdb..422c4837126a 100644
--- a/net-p2p/gift-cvs/ChangeLog
+++ b/net-p2p/gift-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gift-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/ChangeLog,v 1.9 2003/06/01 03:39:56 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/ChangeLog,v 1.10 2003/06/01 04:02:52 lostlogic Exp $
+
+*gift-cvs-0.11.0 (31 May 2003)
+
+ 31 May 2003; Brandon Low <lostlogic@gentoo.org> gift-cvs-0.11.0.ebuild:
+ New ebuild thanks to Frank Straetz from bug 21123 adds support for Gnutella
+ and FastTrack networks.
31 May 2003; Brandon Low <lostlogic@gentoo.org> gift-cvs-0.10.0.ebuild:
Add fix for sandbox violations from bug 21701
diff --git a/net-p2p/gift-cvs/Manifest b/net-p2p/gift-cvs/Manifest
index 5364fed6f4c5..3e09cd4593af 100644
--- a/net-p2p/gift-cvs/Manifest
+++ b/net-p2p/gift-cvs/Manifest
@@ -1,5 +1,5 @@
MD5 d3a8edef24632770acea87143985a8d3 gift-cvs-0.10.0.ebuild 1244
-MD5 9bf1ec238d86a32e53f6e1a3fc7de106 ChangeLog 996
-MD5 0965b81235c4ed925c77b01280bce3e8 gift-cvs-0.11.0.ebuild 2720
+MD5 eb8111de8550a9fe46807eee461b8a06 ChangeLog 997
+MD5 01f0e9a0b0bbc297b3170c2f224ec702 gift-cvs-0.11.0.ebuild 2720
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.11.0 0
diff --git a/net-p2p/gift-cvs/files/digest-gift-cvs-0.11.0 b/net-p2p/gift-cvs/files/digest-gift-cvs-0.11.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-p2p/gift-cvs/files/digest-gift-cvs-0.11.0
diff --git a/net-p2p/gift-cvs/gift-cvs-0.11.0.ebuild b/net-p2p/gift-cvs/gift-cvs-0.11.0.ebuild
new file mode 100644
index 000000000000..68fd17f1dd39
--- /dev/null
+++ b/net-p2p/gift-cvs/gift-cvs-0.11.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/gift-cvs-0.11.0.ebuild,v 1.1 2003/06/01 04:02:52 lostlogic Exp $
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network client"
+HOMEPAGE="http://gift.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPENDS="virtual/glibc
+ >=sys-libs/zlib-1.1.4"
+
+inherit cvs debug flag-o-matic
+
+strip-flags
+
+# CVS settings for giFT
+ECVS_SERVER="cvs.gift.sourceforge.net:/cvsroot/gift"
+ECVS_MODULE="giFT"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+S=${WORKDIR}/${ECVS_MODULE}
+
+
+src_unpack() {
+
+ local ECVS_MODULE_GIFT
+ local ECVS_MODULE_FTPLUGIN
+
+ # Fetch and unpack the giFT cvs sources
+ ECVS_MODULE_GIFT=${ECVS_MODULE}
+ cvs_src_unpack
+
+ # CVS settings for the FastTrack plugin
+ ECVS_SERVER="cvs.gift-fasttrack.berlios.de:/cvsroot/gift-fasttrack"
+ ECVS_MODULE="giFT-FastTrack"
+ ECVS_TOP_DIR="${DISTDIR}/cvs-src/gift-fasttrack-cvs"
+
+ # Fetch and unpack the cvs sources of the FastTrack plugin
+ ECVS_MODULE_FTPLUGIN=${ECVS_MODULE}
+ cvs_src_unpack
+
+ # Move the FastTrack plugin to the right position
+ mv ${WORKDIR}/${ECVS_MODULE_FTPLUGIN} ${WORKDIR}/${ECVS_MODULE_GIFT}/FastTrack || die
+
+}
+
+src_compile() {
+
+ # Compile giFT. Gnutella support is enabled by default (can be switched off).
+ cd ${S}
+ ./autogen.sh --prefix=/usr --enable-gnutella --host=${CHOST} || die "Bootstrap configure failed"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
+
+ # Compile the FastTrack plugin. Some paths are hardcoded into the Makefile,
+ # so we have to change them using sed.
+ cd ${S}/FastTrack
+ sed -i -e "s:\$(HOME)/.giFT:${D}/etc/giFT:" \
+ -e "s:/usr/local/lib/giFT:${D}/usr/lib/giFT:" Makefile
+ emake || die "FastTrack plugin failed to build"
+
+}
+
+src_install() {
+
+ # Install giFT.
+ cd ${S}
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+ # Install the FastTrack plugin.
+ cd ${S}/FastTrack
+ einstall || "FastTrack plugin failed to install"
+
+ # Fix the giFT-setup executable.
+ cd ${D}/usr/bin
+ sed -i -e 's:$prefix/etc/giFT/:/etc/giFT/:' giFT-setup
+
+}
+
+pkg_postinst() {
+ einfo "First of all you need to run giFT-setup with your normal"
+ einfo "user account to create the giFT configuration files."
+ echo
+ einfo "To run giFT with FastTrack support, run:"
+ einfo "giFT -p /usr/lib/giFT/FastTrack.so"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/gift.conf configuration file:"
+ einfo "plugins = OpenFT:/usr/lib/giFT/FastTrack.so"
+}
+