summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-10 21:15:44 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-10 21:15:44 +0000
commita7aa2d7663b664258ebdba85d51f470f82ce8482 (patch)
tree4d83c8357aa8b945ee4a1089e70d4eca1b13ea01 /net-p2p
parentprune older release (diff)
downloadgentoo-2-a7aa2d7663b664258ebdba85d51f470f82ce8482.tar.gz
gentoo-2-a7aa2d7663b664258ebdba85d51f470f82ce8482.tar.bz2
gentoo-2-a7aa2d7663b664258ebdba85d51f470f82ce8482.zip
Made the launcher handle upgrades from 2.3* better.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog6
-rw-r--r--net-p2p/azureus/files/azureus-2.5.0.0-pre35
2 files changed, 27 insertions, 14 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index c333533fafff..1e4115625c9d 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.38 2007/02/10 15:40:41 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.39 2007/02/10 21:15:44 betelgeuse Exp $
+
+ 10 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
+ files/azureus-2.5.0.0-pre:
+ Made the launcher handle upgrades from 2.3* better.
10 Feb 2007; nixnut <nixnut@gentoo.org> azureus-2.5.0.0-r3.ebuild:
Stable on ppc wrt bug 113389
diff --git a/net-p2p/azureus/files/azureus-2.5.0.0-pre b/net-p2p/azureus/files/azureus-2.5.0.0-pre
index 40a21949643f..505a7e704df3 100644
--- a/net-p2p/azureus/files/azureus-2.5.0.0-pre
+++ b/net-p2p/azureus/files/azureus-2.5.0.0-pre
@@ -22,20 +22,13 @@ ${olddotazudir} is deprecated and you can delete this directory.
END
fi
-if [[ -f "${gentoocfg}" ]] ; then
- . "${gentoocfg}"
- echo "using ${gentoocfg}"
-elif [[ -f "${oldgentoocfg}" ]]; then
- . "${oldgentoocfg}"
- echo "using ${oldgentoocfg}"
-else
+create_initial_config() {
if [[ ! -e "${dotazudir}" ]] ; then
mkdir "${dotazudir}"
echo "Creating ${dotazudir}"
fi
- # Setup defaults
- UI="swt"
+ [[ ${UI} ]] && UI="swt"
echo "Creating ${gentoocfg}"
@@ -49,18 +42,34 @@ UI="${UI}"
# Options you want to pass to the java binary
JAVA_OPTIONS=""
END
+}
+if [[ -f "${gentoocfg}" ]] ; then
+ . "${gentoocfg}"
+ echo "using ${gentoocfg}"
+elif [[ -f "${oldgentoocfg}" ]]; then
+ . "${oldgentoocfg}"
+ echo "using ${oldgentoocfg}"
+else
+ create_initial_config
fi
-if [[ -n "${UI_OPTIONS}" ]]; then
+if [[ -z "${UI}" && -n "${UI_OPTIONS}" ]]; then
echo '${UI_OPTIONS} is no longer supported. ${UI} should be used instead instead' > /dev/stderr
- echo 'Unsetting ${UI_OPTIONS}'
+ echo 'Unsetting ${UI_OPTIONS} and trying to migrate to ${UI}' > /dev/stderr
+ if [[ ${UI_OPTIONS} = *--ui=console* ]]; then
+ UI=console
+ elif [[ ${UI_OPTIONS} = *--ui=swt* ]]; then
+ UI=swt
+ else
+ echo 'Could not make $UI from $UI_OPTIONS' > /dev/stderr
+ fi
unset UI_OPTIONS
fi
if [[ -z "${UI}" ]]; then
- echo '$UI not set adding UI="swt" to your ' ${gentoocfg}
- echo 'UI="swt"' >> ${gentoocfg}
+ echo '$UI not set defaulting to swt' > /dev/stderr
UI="swt"
fi
+[[ ! -e "${dotazudir}" ]] && create_initial_config